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Token

Tokens are string labels that are defined in a separate ASCII file and can be assigned to a 
particular bus value. These labels can be useful in applications such as address decoding 
and state machines. The token file (.tok extension) has a very simple format, and can be 
created or edited in any text editor. An example token file is provided in the token 
directory in the install path (Figure 4-1).

Tokens are chosen by selecting a bus, then choosing Bus Radix → Token from the 
right-click menu. A dialog box opens and you can choose the token file. If the bus is wider 
than the tokens specify (such as choosing 4-bit tokens for an 8-bit bus) the upper bits are 
assumed 0 for the tokens to apply. Figure 4-2 shows such a waveform, with the example 
token file in Figure 4-1, page 103 applied to an 8-bit bus.

Deleting Buses

To delete a bus, right click on it and select Delete Bus. The bus is immediately deleted in 
every data view it is resident.

Type and Persistence (VIO only)

VIO signals have two additional properties: Type and Persistence. See “VIO Bus/Signal 
Activity Persistence,” page 137 for explanations of these properties.

X-Ref Target - Figure 4-1

Figure 4-1: Example Token File

X-Ref Target - Figure 4-2

Figure 4-2: Example Waveform with Tokens
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Message Pane
The Message pane displays a scroll list of status messages. Error messages appear in red. 
The Message pane can be resized by dragging the split bar above it to a new location. This 
also changes the height of the project tree/signal browser split pane.

Main Window Area
The main window area can display multiple child windows (such as Trigger, Waveform, 
Listing, Plot windows) at the same time. Each window can be resized, minimized, 
maximized, and moved as needed.

Analyzer Features

Working with Projects
Projects hold important information about the Analyzer program state, such as signal 
naming, signal ordering, bus configurations, and trigger conditions. They allow you to 
conveniently store and retrieve this information between Analyzer sessions

When you first run the Analyzer tool, a new project is automatically created and is titled 
new project. To open an existing project, select File → Open Project, or select one of the 
recently used projects in the File menu. The title bar of the Analyzer and the project tree 
displays the project name. If the new project is not saved during the course of the session, 
a dialog box appears when the Analyzer is about to exit, asking you if you wish to save the 
project.

Creating and Saving A New Project

To create a new project, select File → New Project. A new project called new project is 
created and made active in the Analyzer. To save the new project under a different name, 
select File → Save Project. The project file will have a .cpj extension.

Saving Projects

To rename the current project, or to save a copy to another filename, select File → Save 
Project As (Figure 4-3), type the new name in the File name dialog box, and click Save.

X-Ref Target - Figure 4-3

Figure 4-3: Saving a Project
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Printing Waveforms
One of the features of ChipScope Pro is the ability to print a captured data waveform 
(Figure 4-4) by using the File → Print menu option (Figure 4-5). Selecting the File → Print 
menu option starts the Print Wizard.

The Print Wizard consists of three consecutive windows:

1. (1 of 3) is the Print options and settings window (Figure 4-6, page 106)

2. (2 of 3) is the Print waveform printout preview navigator window (Figure 4-8, 
page 108)

3. (3 of 3) is the Print confirmation window (Figure 4-11, page 110)

X-Ref Target - Figure 4-4

Figure 4-4: Example Waveform

X-Ref Target - Figure 4-5

Figure 4-5: Selecting the File Print Option
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Print Wizard (1 of 3) Window

The first Print Wizard window (Figure 4-6) is used to set up various waveform printing 
options. The following sections describe these waveform printing options in more detail.

Horizontal Scaling

You can control the amount of waveform data that prints to each column of pages using 
one of two methods:

• Fit To: Fit the waveform to one or more columns of pages

• Fixed: Fit a specific number of waveform samples on each column of pages

The default fits the entire waveform printout to a single column of pages wide.

Signal/Bus Selection

You can control which signals and buses will be present in the waveform printout using 
one of three methods:

• Current View: Print waveform data for all of the signals and buses in the current view 
of the waveform window

• All: Print waveform data for all of the signals and buses available in the entire core 
unit

• Selected: Print waveform data for only those signals and buses that are currently 
selected in the waveform window

The default prints waveform data using the Current View method.

Time/Sample Range

You can control the range of time units or number of samples printed using one of four 
methods:

• Current View: Print waveform data using the same range of samples that is present in 
the current waveform view

• Full Range: Print waveform data using a range of samples consisting of all samples in 
the entire sample buffer

• Between X/O Cursors: Print waveform data using a range of samples starting with the 
X cursor and ending with the O cursor (or vice versa)

• Custom View: Print waveform data using a range of samples defined by a starting 
window and sample number and an ending window and sample number

The default prints waveform data using the Current View method.

X-Ref Target - Figure 4-6

Figure 4-6: Print Wizard (1 of 3)
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Print Signal Names

You can choose to print the signal names (and X/O cursor values) on each page or only on 
the first page. Printing the X/O cursor values on the first page only is useful when you 
assemble multiple printed pages together to form a larger multi-dimensional plot.

X/O Cursor Values

You can also choose whether or not to include the X/O cursor values in the waveform 
printout. If you choose to display the X/O cursor values in the waveform printout, then 
they will either appear on each page or only on the first page, depending on the Print 
Signal Names setting (see “Print Signal Names”).

Footer

You can enable or disable the inclusion of a footer at the bottom of each page by selecting 
the Show Footer checkbox. An example of the information that appears in the footer is 
shown in Figure 4-7.

Navigation Buttons

The buttons at the bottom of the Print Wizard (1 of 3) window (Figure 4-6, page 106) are 
defined as follows:

• Page Setup: Opens the page setup window (refer to Figure 4-12, page 110)

• Next: Opens the Print Wizard (2 of 3) window

• Cancel: Closes the Print Wizard window without printing

Clicking on the Next button takes you to the Print Wizard (2 of 3) window, described in 
“Print Wizard (2 of 3) Window,” page 108.

X-Ref Target - Figure 4-7

Figure 4-7: Waveform Printout Footer Example
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Print Wizard (2 of 3) Window

The second Print Wizard window (Figure 4-8) shows a preview of the waveform printout. 

Page Preview Buttons

The buttons at the top of the page control which page of the waveform printout is being 
previewed as follow:

• The << and >> buttons go to the first and last preview pages, respectively

• The < and > buttons go to the previous and next preview pages, respectively

• The text box in the middle can be used to go to a specific preview page

Navigation Buttons

The buttons at the bottom of the Print Wizard (2 of 3) window (Figure 4-8) are defined as 
follows:

• Back: Returns to the Print Wizard (1 of 3) window

• Send to PDF: Opens the Print Wizard (3 of 3) window for writing directly to a PDF File

• Send to Printer: Opens the Print Wizard (3 of 3) window for sending to a printer

• Close: Closes the Print Wizard window without printing

X-Ref Target - Figure 4-8

Figure 4-8: Print Wizard (2 of 3)
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Bus Expansion and Contraction

You can manipulate the waveform by expanding and contracting the buses in the print 
preview window. For example, if you expand a bus in Figure 4-8, page 108 such that it 
pushes other signals/buses to another page, the total print preview page count at the top 
will change accordingly, as shown in Figure 4-9.
X-Ref Target - Figure 4-9

Figure 4-9: Expanding Buses in Print Wizard (2 of 3)
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Print Wizard (3 of 3) Window

In the Print Wizard (2 of 3) window, clicking on the Send to PDF button goes to the Print 
Wizard (3 of 3) PDF confirmation window (Figure 4-10). Clicking on the Yes button causes 
the waveform printout to be written to the specified PDF file while clicking on the No 
button returns you to the Print Wizard (2 of 3) window. Clicking on Change File opens a 
file browser window that allows you to select or create a new PDF file.

In the Print Wizard (2 of 3) window, clicking on the Send to Printer button goes to the Print 
Wizard (3 of 3) Printer confirmation window (Figure 4-11). Clicking on the Yes button 
causes the waveform printout to be sent to the printer while clicking on the No button 
returns you to the Print Wizard (2 of 3) window.

Page Setup

The Page Setup window (Figure 4-12) can be invoked either from the Print Wizard (1 of 3) 
window (Figure 4-6, page 106) or by using the File → Page Setup menu option.

Note: In the ChipScope Pro Analyzer program, you can print only to the default system printer. 
Changing the target printer in the print setup window does not have any effect. To change printers, 
you must close the Analyzer program, change your default system printer, and restart the Analyzer 
program.

X-Ref Target - Figure 4-10

Figure 4-10: Print Wizard (3 of 3) for Sending to a PDF File

X-Ref Target - Figure 4-11

Figure 4-11: Print Wizard (3 of 3) for Sending to a Printer

X-Ref Target - Figure 4-12

Figure 4-12: Page Setup Window
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Importing Signal Names
At the start of a project, all of the signals in every core have generic names. You can rename 
the signals individually as described in “Renaming Signals, Buses, and Triggers Ports,” 
page 101 or import a file that contains all the names of all the signals in one or more cores. 
The Core Generator, Core Inserter, Synplicity Certify, and the FPGA Editor tools can create 
such files. To import signal names from a file, select File → Import. A Signal Import dialog 
box appear (Figure 4-13).

To select the signal import file, select Select New File. A file dialog box will appear for you 
to navigate and specify the signal import file. After you choose the file, the Unit/Device 
combo box will be populated, according to the core types specified in the signal import file. 
If the signal import file contains signal names for more than one core, the combo box will 
contain device numbers for all devices that contain only ChipScope Pro capture cores.

If the signal import file contains signal names for only one core, the combo box will be 
populated with names of the individual cores that match the type specified in the signal 
import file. If the import file is a file from Synplicity Certify, you will also have the option 
of choosing a device name from the Certify file as well as the device in the JTAG chain.

To import the signal names, click OK. If the parameters in the file do not match the 
parameters of the target core or cores, a warning message will be displayed. If you choose 
to proceed, the signal names will be applied to the cores as applicable.

X-Ref Target - Figure 4-13

Figure 4-13: Blank Signal Import Dialog Box
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Exporting Data
Captured data from an ILA or IBA core can be exported to a file, for future viewing or 
processing. To export data, select File → Export. The Export Signals dialog box appears 
(Figure 4-14).

Three formats are available: value change dump (VCD) format, tab-delimited ASCII format, or 
the Agilent Technologies Fast Binary Data Format (FBDF). To select a format, click its radio 
button. To select the target core to export, select it from the Core combo box.

Different sets of signals and buses are available for export. Use the Signals to Export combo 
box to select:

• All the signals and buses for that particular core, or

• All the signals and buses present in the core’s waveform viewer, or

• All the signals and buses in the core’s listing viewer, or

• All the signals and buses in the core’s bus plot viewer

To export the signals, click Export. A file dialog box will appear from which you can 
specify the target directory and filename.

Closing and Exiting the Analyzer
To exit the Analyzer, select File → Exit. The current active project is automatically saved 
upon exit.

Viewing Options
The split pane on the left of the Analyzer window and the Message pane at the bottom of 
the window can both be hidden or displayed per the user’s choice. Both are displayed the 
first time the Analyzer is launched. To hide the project tree/signal browser split pane, 
uncheck it under View → Project Tree. To hide the Message pane, uncheck it under 
View → Messages.

X-Ref Target - Figure 4-14

Figure 4-14: Export Signals Dialog Box
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Setting up a Server Host Connection
The Analyzer client GUI application requires a connection to the Analyzer server 
application that is running on either the local or a remote system. Select the JTAG Chain 
JTAG Chain → Server Host Setting. This pops up the server settings dialog (Figure 4-15).

For local mode operation, the server Host setting should always be set to localhost 
(Figure 4-15). The Port setting can be set to any unused TCP/IP port number. The default 
Port number is 50001. In local mode, the Password setting is not necessary in local mode.

Note: In local mode, the server is started automatically.

For remote mode operation, the server Host setting should be set to an IP address or 
appropriate system name (Figure 4-16). The Port and Password settings should be set to 
the same port that was used when the server was started on the remote system. In remote 
mode, the connection is not actually established until you open a connection to a JTAG 
download cable, as described in the subsequent sections of this document.

Note: In remote mode, the server needs to be started manually, as described in “Analyzer Server 
Interface,” page 100.

X-Ref Target - Figure 4-15

Figure 4-15: Server Settings for Local Mode

X-Ref Target - Figure 4-16

Figure 4-16: Server Settings for Remote Mode
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Opening a Parallel Cable Connection
To open a connection to the Parallel Cable (including the MultiPRO cable), make sure the 
cable is connected to one of the computer’s parallel ports. Select JTAG Chain → Xilinx 
Parallel Cable (Figure 4-17). This pops up the Parallel Cable Selection configuration 
dialog box. You can choose the Parallel Cable III, Parallel Cable IV, or have the Analyzer 
autodetect the cable type. 

Note: In order to open a connection to the MultiPRO cable, select either Parallel Cable IV or Auto 
Detect Cable Type.

If the Parallel Cable IV or Auto Detect Cable Type option is selected, you can choose the 
speed of the cable; the choices are 10 MHz, 5 MHz, 2.5 MHz (default), 1.25 MHz, or 
625 kHz. Choose the speed that makes the most sense for the board under test. Type the 
printer port name in the Port selection box (usually the default LPT1 is correct) and click 
OK. If successful, the Analyzer queries the Boundary Scan chain to determine its 
composition (see “Setting Up the Boundary Scan (JTAG) Chain,” page 117).

If the Analyzer returns the error message Failed to Open Communication Port, 
verify that the cable is connected to the correct LPT port. If you have not installed the 
Parallel Cable driver, follow the instructions in the ChipScope Pro software installation 
program to install the required device driver software. 

X-Ref Target - Figure 4-17

Figure 4-17: Opening a Parallel Cable Connection
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Opening a Platform Cable USB Connection
To open a connection to the Parallel Cable (including the MultiPRO cable), make sure the 
cable is connected to one of the computer’s parallel ports. Selecting the JTAG Chain → 
Xilinx Platform USB Cable menu option pops up a dialog window (Figure 4-18). 

Platform Cable USB Clock Speeds

You can choose the speed of the cable from any of the settings: 24 MHz, 12 MHz, 6 MHz, 
3 MHz (default), 1.5 MHz, or 750 kHz. Choose the speed that makes the most sense for the 
board under test. 

Platform Cable USB Port Number

You can also choose the USB port from a selection of port enumerations in the range of 
USB2<n>, where <n> is an integer value is 1 through 127. The default port setting is 
USB21. The USB port enumeration number is based on the order in which the Platform 
Cable USB download cables are plugged into USB ports of the system. For instance, the 
first Platform Cable USB download cable plugged into the system is assigned the port 
enumeration of USB21, the second cable is assigned USB22, and so on.

Note: The enumerations are not necessarily preserved when the system is power cycled. Also, 
there is currently no way to identify a particular Platform Cable USB other than by physically plugging 
the cables into the system in a particular order.

X-Ref Target - Figure 4-18

Figure 4-18: Opening a Platform Cable USB Connection
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Using Multiple Platform Cable USB Connections
To use the ChipScope Pro Analyzer with multiple cables, you need three things:

1. Multiple Xilinx JTAG cables connected to one machine

2. Multiple instances of the cs_server application running on one machine, each one 
listening to a different port

3. Multiple instances of ChipScope Pro Analyzer running on that same machine, or a 
different machine (via the remote server feature)

1. Multiple Xilinx JTAG Cables Connected to One Machine

To interact with multiple JTAG cables connected to the same machine, you first need to be 
able to connect multiple Platform Cable USB, Parallel Cable III, or Parallel Cable IV cables 
to the machine. For Platform Cable USB cables, you might need to use one or more USB 
hubs depending on how many cables you need. For PC3/PC4, you may need one or more 
parallel port extender cards.

Note: Currently, enumerations are not associated with a particular physical Platform Cable USB 
cable. This means that rebooting your machine might result in different associations between 
enumerations and physical cables. One work-around is to unplug all cables and re-plug them in the 
order you wish for them to be enumerated.

2. Multiple Instances of cs_server

Set up the ChipScope Pro Analyzer to use multiple cables first by starting multiple 
instances of the cs_server.exe Windows application or cs_server.sh Linux 
application on the same machine using different ports. For example, to start up two servers 
on different ports on Linux, use:

# cs_server.sh -port 50001
# cs_server.sh -port 50002

3. Multiple Instances of the ChipScope Pro Analyzer

Start and configure multiple ChipScope Pro Analyzer client instances (see Table 4-4). Each 
instance of the Analyzer connects to a different cs_server and cable enumeration.

Table 4-4: Configuration of Multiple Client Instances

Analyzer 
Instance #

Server Host Setting
Platform Cable 

USB Port #

1 <IP Address>:50001 USB21

2 <IP Address>:50002 USB22
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Polling the Auto Core Status
When the cores are armed, the interface cable queries the cores on a regular basis to 
determine the status of the capture. If other programs are using the cable at the same time 
as the Analyzer, it can often be beneficial to turn this polling off. This can be done in the 
JTAG Chain menu by un-checking JTAG Chain → Auto Core Status Poll. If this option 
is unchecked, when the Run or Trigger Immediate operation is performed, the Analyzer 
will not query the cores automatically to determine the status. 

Note that this does not completely disable communication with the cable; it will only 
disable the periodic polling when cores are armed. If one or more cores trigger after the 
polling has been turned off, the capture buffer will not be downloaded from the device and 
displayed in any of the data viewer(s) until the Auto Core Status Poll option is turned on 
again.

Configuring the Target Device(s)
You can use the Analyzer software with one or more valid target devices. The first step is 
to set up all of the devices in the Boundary Scan chain.

Setting Up the Boundary Scan (JTAG) Chain

After the Analyzer has successfully communicated with a download cable, it 
automatically queries the Boundary Scan (JTAG) chain to find its composition. All Xilinx 
FPGA, CPLD, PROM, and System ACE devices are automatically detected. The entire 
IDCODE can be verified for valid target devices. To view the chain composition, select 
JTAG Chain → JTAG Chain Setup. A dialog box appears with all detected devices in 
order.

For devices that are not automatically detected, you must specify the IR (Instruction 
Register) length to insure proper communication to the cores. This information can be 
found in the device’s BSDL file. The following example has one System ACE CF controller 
device (System_ACE_CF), one Platform Flash PROM device (XCF32P™), one Virtex-4 
FPGA device (XC4VLX25™), and one CPLD device (XC9500XL™) in the JTAG chain 
(Figure 4-19). USERCODEs can be read out of the ChipScope Pro target devices (only the 
XC4VLX25 device in this example) by selecting Read USERCODEs. 

The Analyzer tool automatically keeps track of the test access port (TAP) state of the 
devices in the JTAG chain, by default. If the Analyzer is used in conjunction with other 
JTAG controllers (such as the System ACE CF controller or processor debug tools), then the 
actual TAP state of the target devices can differ from the tracking copy of the Analyzer. In 
this case, the Analyzer should always put the TAP controllers into a known state (for 
example, the Run-Test/Idle state) before starting any JTAG transaction sequences. Clicking 
on the Advanced button on the JTAG Chain Device Order dialog box reveals the 

X-Ref Target - Figure 4-19

Figure 4-19: Boundary Scan (JTAG) Setup Window
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parameters that control the start and end states of JTAG transactions (Figure 4-20). Use the 
second parameter if the JTAG chain is shared with other JTAG controllers.

Device Configuration

The Analyzer can configure target FPGA devices using the following download cables in 
JTAG mode only: Platform Cable USB, Parallel Cable III, Parallel Cable IV, or MultiPRO.

If the target device is to be programmed using a download cable by way of the JTAG port, 
select the Device menu, select the device you wish to configure, and select the Configure 
menu option. Only valid target devices can be configured and are, therefore, the only 
devices that have the Configure option available (Figure 4-21). Alternatively, you can 
right-click on the device in the project tree to get the same menu as Device. 

After selecting the configuration mode, the JTAG Configuration dialog box opens 
(Figure 4-22). This dialog box reflects the configuration choice, and defaults to a blank 
entry for the configuration file.

X-Ref Target - Figure 4-20

Figure 4-20: Advanced JTAG Chain Parameters Setup Window

X-Ref Target - Figure 4-21

Figure 4-21: Device Menu Options

X-Ref Target - Figure 4-22

Figure 4-22: Selecting a Bitstream
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To select the BIT file to download, click on Select New File. The Open Configuration File 
dialog box (Figure 4-23) opens. Using the browser, select the device file you want to use to 
configure the target device. It is important to select a BIT file generated with the proper 
BitGen settings. Specifically, the -g StartupClk:JtagClk option must be used in BitGen in 
order for configuration to be successful.

Once you locate and select the proper device file, click Open to return to the JTAG 
Configuration dialog box (Figure 4-22, page 118).

Once the BIT file has been chosen, click OK to configure the device.

Observing Configuration Progress

While the device is being configured, the status of the configuration is displayed at the 
bottom of the Analyzer window. If the DONE status is not displayed, a dialog box opens, 
explaining the problem encountered during configuration. If the download is successful, 
the target device is automatically queried for ChipScope Pro cores, and the project tree is 
updated with the number of cores present. A folder is created for each core unit found and 
Trigger Setup, Waveform, and Listing leaf nodes appear under each ChipScope Pro unit. 
A Bus Plot leaf node will appear only if the core unit is determined to be an ILA core.

X-Ref Target - Figure 4-23

Figure 4-23: Opening a Configuration File
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Displaying JTAG User and ID Codes

One method of verifying that the target device was configured correctly is to upload the 
device and user-defined ID codes from the target device. The user-defined ID code is the 
8-digit hexadecimal code that can be set using the BitGen option -g UserID.

To upload and display the user-defined ID code for a particular device, select the Show 
USERCODE option from the Device menu for a particular device (Figure 4-21, page 118). 
Select the Show IDCODE option from the Device menu to display the fixed device ID code 
for a particular device. The results of these queries are displayed in the messages window 
(Figure 4-24). The IDCODE and USERCODE can also be displayed in the JTAG Chain 
Setup dialog box, JTAG Chain → JTAG Chain Setup (Figure 4-19, page 117).

Displaying Configuration Status Information

The 32-bit configuration status register contains information such as status of the 
configuration pins and other internal signals. If configuration problems occur, select Show 
Configuration Status from the Device menu for a particular target device to display this 
information in the messages window (Figure 4-25).

Note: All target devices contain two internal registers that contain status information: 1) the 
Configuration Status register (32 bits) and 2) the JTAG Instruction register (variable length, 
depending on the device). Only valid target devices have a Configuration Status register. Although all 
devices have a JTAG Instruction register that can be read, the implementation of that particular 
device determines whether any status information is present. Refer to the documentation for the 
particular FPGA device for information on the definition of each specific configuration status bit.

X-Ref Target - Figure 4-24

Figure 4-24: Device USERCODE and IDCODE

X-Ref Target - Figure 4-25

Figure 4-25: Displaying Device Configuration Status
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For some devices, the JTAG Instruction register also contains status information. Use 
Device → Show Instruction Register to display this information in the messages 
window for any device in the JTAG chain (Figure 4-26). 

Trigger Setup Window
To set up the trigger for an ILA or IBA core, select Window → New Unit Windows and the 
core desired(Figure 4-27). A dialog box will be displayed for that core, and you can select 
the Trigger Setup, Waveform, Listing, Bus Plot and/or Console window(s) in any 
combination (Figure 4-27). Windows cannot be closed from this dialog box. 

The same operation can by achieved by double-clicking on the Trigger Setup leaf node in 
the project tree, or by right-clicking on the Trigger Setup leaf node and selecting Open 
Trigger Setup.

Each ILA and IBA core has its own Trigger Setup window which provides a graphical 
interface for the user to set up triggers. The trigger mechanism inside each core can be 
modified at run-time without having to re-compile the design. The following sections 
describe how to modify the trigger mechanism’s three components: 

• Match Functions: Defines the match or comparison value for each match unit

• Trigger Conditions: Defines the overall trigger condition based on a binary equation or 
sequence of one or more match functions

• Capture Settings: Defines how many samples to capture, how many capture windows, 
and the position of the trigger in those windows

X-Ref Target - Figure 4-26

Figure 4-26: Displaying Device Instruction Register Status

X-Ref Target - Figure 4-27

Figure 4-27: Opening New Unit Windows
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Each component is expandable and collapsible in the Trigger Setup window. To expand, 
click on the desired button at the bottom of the window (Figure 4-28).

To collapse, click on the button to the left of the expanded section you wish to collapse 
(Figure 4-29).

Capture Settings

The capture settings section of the Trigger Setup window (Figure 4-30) defines the number 
of windows, and where the trigger event occur in each of those windows. A window is a 
contiguous sequence of samples containing one (and only one) trigger event. If an invalid 
number is entered for any parameter, the text field turns red, and an error is displayed in 
the Message pane. 

X-Ref Target - Figure 4-28

Figure 4-28: Trigger Setup Window with Only Match Functions Expanded

X-Ref Target - Figure 4-29

Figure 4-29: Trigger Setup Window with All Sections Expanded

X-Ref Target - Figure 4-30

Figure 4-30: Capture Settings
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Type

The Type combo box in the capture settings defines the type of windows to use. If Window 
is selected, the number of samples in each window must be a power of two. However, the 
trigger can be in any position in the window. If N Samples is selected, the buffer will have 
as many windows as possible with the defined samples per trigger. The trigger will always 
be the first sample in the window if N Samples is selected.

Windows

The Windows text field is only available when Window is selected in the Type combo box. 
The number of windows is specified in this field and can be any positive integer from 1 to 
the depth of the capture buffer.

Depth

The Depth combo box is only available when Window is selected in the Type combo box. 
The Depth combo box defines the depth of each capture window. It is automatically 
populated with valid selections when values are typed into the Windows text field. Only 
powers of two are available.

Note: When the overall trigger condition consists of at least one match unit function that has a 
counter that is set to either Occurring in at least n cycles or Lasting for at least n consecutive 
cycles, the Window Depth or Samples Per Trigger setting cannot be less than eight samples. This is 
due to the pipelined nature of the trigger logic inside the ILA, IBA/OPB and IBA/PLB cores. 

Position

The Position text field is only available when Window is selected in the Type combo box. 
The Position field defines the position of the trigger in each window. Valid values are 
integers from 0 to the depth of the capture buffer minus 1.

Samples Per Trigger

The Sample Per Trigger text field is only available when N Samples is selected in the Type 
combo box. Samples per trigger defines how many samples to capture once the trigger 
condition occurs. Valid values are any positive integer from 1 to the depth of the capture 
buffer. The trigger mark will always appear as sample 0 in the window. There will be as 
many sample windows as possible captured, given the overall sample depth.

Note: When occurring in at least n cycles or occurring for at least n consecutive cycles is selected 
for a match unit, and that match unit is a part of the overall trigger condition, the Window Depth or 
Samples Per Trigger cannot be less than 8. This is due to pipeline effects inside the ILA or IBA core. 

Storage Qualification Condition

The storage qualification condition is a Boolean combination of events that are detected by the 
match unit comparators that are subsequently attached to the trigger ports of the core. The 
storage qualification condition evaluates trigger port match unit events to decide whether 
or not to capture and store each individual data sample. The trigger and storage 
qualification conditions can be used together to define when to start (or finish) the capture 
process and what data is captured, respectively.

The Storage Condition dialog box has a table of all the match units. Each match unit 
occupies a row in the table. The Enable column indicates if that match unit is part of the 
trigger condition. The Negate column indicates if that match unit should be individually 
negated (Boolean NOT) in the trigger condition.

The storage qualification condition can be configured to capture all data (see Figure 4-31, 
page 124), or it can be set up to capture data that satisfies a Boolean AND or OR 
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combination of all the enabled match units (see Figure 4-32, page 124). The overall Boolean 
equation can also be negated, selectable using the Negate Whole Equation checkbox 
above the table. The resulting equation appears in the Storage Condition Equation pane at 
the bottom of the window.

X-Ref Target - Figure 4-31

Figure 4-31: Storage Qualification Condition Set to Capture All Data

X-Ref Target - Figure 4-32

Figure 4-32: Storage Qualification Condition Using Boolean Equation
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Match Functions

A match function is a definition of a trigger value for a single match unit. All the match 
functions are defined in the Match Functions section of the Trigger Setup window 
(Figure 4-33). One or more match functions can be defined in an equation or sequence in 
the Trigger Conditions section to specify the overall trigger condition of the core.

Match Unit

The Match Unit field indicates which match unit the function applies to. Clicking on the 
+ symbol next to the match unit number (or double clicking on the field) will expand that 
match unit so it is displayed as individual trigger port bits in at tree structure. Individual 
values for each bit can then be viewed and set.

Function

The Function combo box selects which type of comparison is done. Only those 
comparators that are allowed for that match unit are listed.

Value

The Value field selects exactly which trigger value to apply to that match unit. It is 
displayed according to the Radix field. Double-clicking on the field will make it editable. 
Place the cursor before the value you want to change, and typing a valid trigger character 
will overwrite that character. Or, select the field by single-clicking, then proceed by typing 
the trigger characters. Valid characters for the different radices are:

• Hex: X, 0-9, and A-F. X indicates that all four bits of that nibble are don’t cares. The “?” 
character indicates that the nibble consists of a mixture of 1s, 0s, Xs, Rs, Fs, and Bs 
(where appropriate)

• Octal: X, ?, 0-7

• Binary: X (don’t care), 0, 1, R (rising), F (falling), and B (either transition). R, F, and B 
are only available if the match unit can detect transitions (Basic w/edges, Extended 
w/edges, Range w/edges)

• Unsigned: 0-9 (0 to 2n-1 for an n-bit bus)

• Signed: 0-9 (-2n-1 to 2n-1 - 1 for an n-bit bus)

Also, when Bin is chosen as the radix, positioning the mouse pointer over a specific 
character will display a tool-tip, indicating the name and position of that bit.

X-Ref Target - Figure 4-33

Figure 4-33: Setting the Match Functions
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Radix

The Radix combo box selects which radix to display in the Value field. Values are Hex, 
Octal, Bin, Signed (not allowed for In Range and Out of Range comparisons), and 
Unsigned.

Counter

The Counter field selects how many match function events must occur for the function to 
be satisfied. If the match counter is present for a particular match unit, the text in the 
Counter column will be in black text. If the counter is not present in the core, the text in that 
column will be grayed out. To change the value of the match counter, click on the counter 
cell, which will bring up the match unit counter dialog box (Figure 4-34).

The Counter field selects how many match function events must occur for the function to 
be satisfied.

• If occurring in exactly n clock cycles is selected, then n contiguous or n noncontiguous 
events will satisfy the match function counter condition.

• If occurring in at least n clock cycles is selected, then n contiguous or n noncontiguous 
events will satisfy the match function counter condition and will remain satisfied 
until the overall trigger condition is met.

• If occurring for at least n consecutive cycles is selected, then n contiguous events will 
satisfy the match function counter condition and will remain satisfied until the overall 
trigger condition is met or the match function value is no longer satisfied.

Note: When the overall trigger condition consists of at least one match unit function that has a 
counter set to either Occurring in at least n cycles or Lasting for at least n consecutive cycles, 
the Window Depth or Samples Per Trigger setting cannot be less than eight samples. This is due to 
the pipelined nature of the trigger logic inside the ILA, IBA/OPB or IBA/PLB cores.

Trigger Conditions

A trigger condition is a Boolean equation or sequence of one or more match functions. The 
core will capture data based on the trigger condition. More than one trigger condition can 
be defined. To add a new trigger condition, click the Add button. To delete a trigger 
condition, highlight any cell in the row and click Del. Although many trigger conditions 
can be defined for a single core, only one trigger condition can be chosen (active) at any one 
time.

Active

The Active field is a radio button that indicates which trigger condition is the currently 
active one.

X-Ref Target - Figure 4-34

Figure 4-34: Setting up the Match Counter
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Trigger Condition Name Field

The Trigger Condition Name field provides a mnemonic for a particular trigger condition. 
Trigger Condition n is used by default (Figure 4-35).

Trigger Condition Equation

The Condition Equation field displays the current Boolean equation or state sequence of 
match functions that make up the overall trigger condition. By default, a logical AND of all 
the match functions present (one match function for each match unit) is the trigger 
condition. To change the trigger condition, click on the Condition Equation field, which 
brings up the Trigger Condition dialog box.

Trigger Condition Editor Dialog Box

If a trigger sequencer is present in the core, the Trigger Condition dialog will have two tabs: 
Boolean and Sequencer. When the Boolean tab is active, the trigger condition of a Boolean 
equation of the available match units. When the sequencer tab is active, the trigger 
condition is a state machine, where each state transition is triggered by a match function 
being satisfied.

The Boolean tab of the Trigger Condition dialog box has a table of all the match units. Each 
match unit occupies a row in the table. The Enable column indicates if that match unit is 
part of the trigger condition. The Negate column indicates if that match unit should be 
individually negated (Boolean NOT) in the trigger condition. 

All the enabled match units can be combined in a Boolean AND or OR operation, 
selectable using the radio buttons below the match unit table. The overall equation can also 
be negated, selectable using the Negate checkbox below the table. The resulting equation 
appears in the Trigger Condition Equation pane at the bottom of the window (Figure 4-36).

X-Ref Target - Figure 4-35

Figure 4-35: Viewing the Trigger Condition

X-Ref Target - Figure 4-36

Figure 4-36: Setting the Trigger Condition Boolean Equation
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The Sequencer tab of the Trigger Condition dialog box has a combo box from which you 
can select the number of levels in the trigger sequence and a table listing all the levels. The 
sequencer begins at Level 1 and proceeds to Level 2 when the match unit specified in 
Level 1 has been satisfied. The number of levels available is a parameter of the core, up to 
a maximum of 16 levels. Each level can look for a match unit being satisfied or not satisfied. 
To negate a level (for instance, to look for the absence of a particular match function) check 
the Negate cell for that level. A representation of the sequence appears in the Trigger 
Condition Equation pane at the bottom of the window (Figure 4-37).

The trigger sequence in Figure 4-37 can be satisfied by the eventual occurrence of match 
unit events M0 followed by M1 followed by M3 (with any occurrence or non-occurrence of 
events in between). Enable the Use Contiguous Match Events Only checkbox if you 
desire the trigger sequence to be satisfied only upon contiguous transitions from M0 to M1 
to M3 (and not, for instance, the transitions of M0 followed by M1 followed by !M1 
followed by M3).

Output Enable

If the trigger output is present in the core, a column named Output Enable becomes 
available. This cell is a combo box that allows the user to select which type of signal will be 
driven by the trig_out port of the ILA or IBA core.

• Disabled: The output is a constant 0.

• Pulse (High): The output is a single clock cycle pulse of logic 1, 10 cycles after the 
actual trigger event.

• Pulse (Low): The output is a single clock cycle pulse of logic 0, 10 cycles after the actual 
trigger event.

• Level (High): The output transitions from a 0 to a 1, 10 cycles after the actual trigger 
event.

• Level (Low): The output transitions from a 1 to a 0, 10 cycles after the actual trigger 
event.

X-Ref Target - Figure 4-37

Figure 4-37: Setting the Trigger Condition Sequencer
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Saving and Recalling Trigger Setups

All the information in the Trigger Setup window can be saved to a file for recall later with 
the current project or other projects. To save the current trigger settings, select Trigger 
Setup → Save Trigger Setup. A Save Trigger Setup As File dialog box will open, and the 
trigger settings can be saved in any location, with a .ctj extension. To load a trigger 
settings file into the current project, select Trigger Setup → Read Trigger Setup. A Read 
Trigger Setup file dialog box will open, and you can navigate to the folder where the 
trigger settings file (with a.ctj extension) exists. Once the trigger setting file is chosen, 
select Open, and those settings will be loaded into the Trigger Settings window.

Running/Arming the Trigger

After setting up the trigger, select Trigger Setup → Run to arm it. The trigger stays armed 
until the trigger condition is satisfied or you disarm the trigger. Once the trigger condition 
is satisfied, the core captures data according to the capture settings. When the sample 
buffer is full, the core stops capturing data. The data is then uploaded from the core and is 
displayed in the Waveform and/or Listing windows.

To force the trigger, select Trigger Setup → Trigger Immediate. This causes the unit to 
ignore the trigger and storage qualification conditions and trigger immediately using a 
single sample window with the trigger position set to sample 0. After the sample buffer 
fills with data, the trigger disarms and the captured data appears in the Waveform and/or 
Listing window(s).

Stopping/Disarming the Trigger

To disarm the trigger, select Trigger Setup → Stop Acquisition. If the trigger condition 
has been satisfied at least once before the acquisition is stopped, the Analyzer disarms the 
trigger and downloads/displays the captured data. Subsequent selections of Trigger 
Setup → Run cause the trigger to re-arm.
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Waveform Window
To view the waveform for a particular ILA or IBA core, select Window → New Unit 
Windows, and the core desired. A dialog box appears for that ChipScope Pro Unit, and the 
user can select the Trigger Setup, Waveform, Listing, and/or Bus Plot window, or any 
combination. Windows cannot be closed from this dialog box. The same operation can be 
achieved by double-clicking on the Waveform leaf node in the project tree, or right-
clicking on the Waveform leaf node and selecting Open Waveform.

The Waveform window displays the sample buffer as a waveform display, similar to many 
modern simulators and logic analyzers. All signal browser operations can also be 
performed in the waveform window, such as bus creation, radix selection, and renaming. 
To perform a signal operation, right-click on a signal or bus in the Bus/Signal column.

Bus and Signal Reordering

Buses and signals can be reordered in the Waveform window (Figure 4-38). Select one or 
more signals and buses, and drag it to its new location. A ghost image of the signal or 
signals appears with the cursor, and a red line shows the potential drop location.

Cut/Copy/Paste/Delete Signals and Buses

Signals and buses can be cut, copied, pasted, or deleted using right-click menus. Select one 
or more signals and/or buses, right click on a selected signal or bus, and select the 
operation desired. Alternatively, the standard Windows key combinations are available 
(Ctrl+X for cut, Ctrl+C for copy, Ctrl+V for paste, Del for delete).

X-Ref Target - Figure 4-38

Figure 4-38: Reordering Buses or Signals in the Waveform
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Zooming In and Out

Select Waveform → Zoom → Zoom In to zoom in to the center of the waveform display, or 
right-click in the waveform section and select Zoom → Zoom In. To zoom out from a 
waveform, use Waveform → Zoom → Zoom Out, or right-click in the waveform and 
select Zoom → Zoom Out.

To view the entire waveform display select Waveform → Zoom → Zoom Fit, or right click 
in the waveform and select Zoom → Zoom Fit.

To zoom into a specific area, just use the left mouse button to drag a rectangle in the 
waveform display. Once the drag is complete, a popup appears. Select Zoom Area to 
perform the zoom (Figure 4-39).

To zoom in to the space marked by the X and O cursors, select Waveform → Zoom → 
Zoom X, O, or right-click in the waveform and select Zoom → Zoom X, O. Other zoom 
features include zooming to the previous zoom factor by selecting Zoom → Zoom 
Previous, zooming to the next zoom factor by selecting Zoom → Zoom Forward, and 
zoom to a specific range of samples by selecting Zoom → Zoom Sample (Figure 4-40).

X-Ref Target - Figure 4-39

Figure 4-39: Zoom Area Using the Automatic Popup Menu

X-Ref Target - Figure 4-40

Figure 4-40: Zoom to Sample Range
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Centering the Waveform

Center the waveform display around a specific point in the waveform by selecting 
Waveform → Go To, then centering the waveform display around the X and O markers, as 
well as the previous or next trigger position, or right-click in the waveform and select 
Go To (Figure 4-41). 

Cursors

Two cursors are available in the Waveform window: X and O. To place a cursor, right-click 
anywhere in the waveform section, and select Place X Cursor or Place O Cursor. A 
colored vertical line will appear indicating the cursor’s position. Additionally, the status of 
all the signals and buses at that point will be displayed in the X or O column. The position 
of both cursors, and the difference in position of the cursors appears at the bottom of the 
Waveform window. Both cursors are initially placed at sample 0.

To move a cursor, either right-click in a new location in the waveform, or drag the cursor 
using the handles (X or O labels) in the waveform header, or drag the cursor-line itself in 
the waveform. Special drag icons will appear when the mouse pointer is over the cursor.

Sample Display Numbering

The horizontal axis of the waveform can be displayed as the sample number relative to the 
sample window (default) or by the overall sample number in the buffer. To display the 
sample number starting over at 0 for each window, select Ruler → Sample # in Window 
in the right-click menu. To display the sample number as an overall sample count in the 
buffer, select Ruler → Sample # in Buffer in the right-click menu. You can also select 
toggle the way that the samples that occur before the trigger marker are shown in the ruler 
(either negative or positive) by selecting Ruler → Negative Time/Samples in the 
right-click menu.

X-Ref Target - Figure 4-41

Figure 4-41: Centering the Waveform on a Marker
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Displaying Markers

A static red vertical bar is displayed at each trigger position. A static black bar is displayed 
between two windows to indicate a period of time where no samples were captured. To not 
display either of these markers, un-check them on the right-click menu under Markers → 
Window Markers or Markers → Trigger Markers.

Listing Window
To view the Listing window for a particular ILA or IBA core, select Window → New Unit 
Windows, and the core desired. A dialog box will be displayed for that ChipScope Pro 
Unit, and the user can select the Trigger Setup, Waveform, Listing, and/or Bus Plot 
window, or any combination. Windows cannot be closed from this dialog box. The same 
operation can be achieved by double-clicking on the Listing leaf node in the project tree, or 
right-clicking on the Listing leaf node and selecting Open Listing.

The Listing window displays the sample buffer as a list of values in a table. Individual 
signals and buses are columns in the table (Figure 4-42). All signal browser operations can 
also be performed in the listing window, such as bus creation, radix selection, and 
renaming. To perform a signal operation, right-click on a signal or bus in the column 
heading.

Bus and Signal Reordering

Buses and signals can be reordered in the Listing window. Simply click on a signal or bus 
heading in the table, and drag it to a new location.

Removing Signals/Buses

Individual signals and buses can be removed from the Listing window by right-clicking 
anywhere in the signal’s column and selecting Remove. If Remove All is selected, all 
signals and buses will be removed.

X-Ref Target - Figure 4-42

Figure 4-42: The Listing View
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Cursors

Cursors are available in the Listing window the same way as in the Waveform window. To 
place a cursor, right-click in the data section of the Listing window, and select either Place 
X Cursor or Place O Cursor. That line in the table will be colored the same as the cursor 
color. To move the cursor to a different position in the table, either right-click in the new 
location and do the same operation as before, or right-click on the cursor handle in the first 
column, and drag it to the new location.

Goto Cursors 

To automatically scroll the listing view to a cursor, right-click and select Go To → Go To X 
Cursor or Go To → Go To O Cursor.

Bus Plot Window
To view the Bus Plot window for a particular set of ILA or IBA buses, select Window → 
New Unit Windows and the core desired. A dialog box will be displayed for that 
ChipScope Pro Unit, and the user can select the Trigger Setup, Waveform, Listing, and /or 
Bus Plot window, or any combination. Windows cannot be closed from this dialog box. The 
same operation can be achieved by double-clicking on the Bus Plot in the project tree, or 
right-clicking on Bus Plot and selecting Open Bus Plot.

Any buses for a particular core can be displayed in the Bus Plot window (Figure 4-43). The 
Bus Plot window displays buses as a graph of a bus’s values over time, or one bus’s values 
vs. another’s.

X-Ref Target - Figure 4-43

Figure 4-43: The Bus Plot Window: Data vs. Time
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Plot Type

Plot types are chosen in the upper left group of radio buttons. There are two plot types: 
data vs. time and data vs. data. When data vs. time is chosen (Figure 4-43, page 134), any 
number of buses can be displayed at one. When data vs. data is chosen (Figure 4-44), two 
buses need to be selected, and each point in the plot’s x coordinate will be the value of one 
of the buses at a particular time, and the y coordinate will the value of the other bus at the 
same time.

Each bus will have its own color, and will be displayed according to its radix (hexadecimal, 
binary, octal, token and ASCII radices are displayed as unsigned decimal values with scale 
factor = 1.0, precision = 0). 

Display Type

The bus plot can be displayed using lines, points, or lines and points. The display type 
affects all bus values being displayed.

Bus Selection

The bus selection control allows you to select the individual buses to plot (in data vs. time 
mode) or the buses to plot against one another (in data vs. data mode). The color of each 
bus can be changed by clicking on the colored button next to the bus name (Figure 4-43, 
page 134).

Min/Max

The Min/Max display is used to show the maximum and minimum values of the axis in 
the current view of the bus plot.

Cursor Tracking

The X: and Y: displays at the bottom of the bus plot indicate the current X and Y 
coordinates of the mouse cursor when it is present in the bus plot view.

X-Ref Target - Figure 4-44

Figure 4-44: The Bus Plot Window: Data vs. Data
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VIO Console Window
To open the Console window for a VIO core, select Window → New Unit Windows, and 
the core desired. A dialog box will be displayed for that ChipScope Pro Unit, and the user 
can select the Console window. (Windows cannot be closed from this dialog box.)

The Console window is for VIO cores only. The Console allows users to see the status and 
activity of the VIO core input signals and modify the status of the VIO core output signals. 
To open the Console for a particular VIO core, double-click on the Console leaf node in the 
project tree.

All signal browser operations can also be performed in the Console window, such as bus 
creation, radix selection, and renaming. To perform a signal operation, right-click on a 
signal or bus in the column heading.

The Console window has a table with two columns: Bus/Signal and Value (Figure 4-45).
X-Ref Target - Figure 4-45

Figure 4-45: The VIO Console Window
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Bus/Signal Column

The Bus/Signal column contains the name of the bus or signal in the VIO core. If it is a bus, 
it can be expanded or contracted to view or hide the constituent signals in the bus. In 
addition to all the operations available in the signal manager, two additional parameters 
can be set through the right-click menus: type and activity persistence. 

VIO Bus/Signal Type

The signal’s type determines how that signal is displayed in the Value column of the VIO 
Console. Different types are available depending on the type of VIO signal:

• VIO input signals have the following display types:

♦ Text: ASCII characters

♦ LEDs

- Choose between red, blue, and green LEDs

- Either active-High or active-Low

• VIO input buses have only one valid display type:

♦ Text

• VIO output signals have the following control types:

♦ Text: ASCII text field
♦ Push button (either active-High or active-Low)
♦ Toggle button
♦ Pulse train (synchronous outputs only)
♦ Single pulse (synchronous outputs only)

• VIO output buses have two valid control types:

♦ Text

♦ Pulse train (synchronous output buses only)

VIO Bus/Signal Activity Persistence

The persistence of a signal indicates how long the activity is displayed in the Value column 
(see “Value Column,” page 138 or a description of signal activity).

If the persistence is:

• Infinite: The activity is displayed in the column forever.

• Long: The activity is displayed in the column for 80 times the sample period

• Short: The activity is displayed in the column for 8 times the sample period

When the time limit on the persistence expires, a new activity is displayed. If no activity 
occurred in the last sample cycle, no activity is displayed in the Value column.

Bus and Signal Reordering

Buses and signals can be reordered in the Waveform window. Click on a signal or bus, and 
drag it to its new location. A red line then appears in the Bus/Signal column indicating the 
potential drop location.

Cut/Copy/Paste/Delete Signals and Buses

Individual signals and buses can be cut, copied, pasted, or deleted using right-click menus. 
Either right-click on a signal or bus and select the operation desired, or use the standard 
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Windows key combinations (Ctrl+X for cut, Ctrl+C for copy, Ctrl+V for paste, Del for 
delete).

Value Column

The Value column displays the current value of each of the signals in the console (see 
Figure 4-45, page 136). In the case of VIO core inputs, those cells are non-editable. Buses 
are displayed according to their selected radix. The VIO core inputs are updated 
periodically by default, according to a drop down combo box at the bottom of the console. 
Each of the VIO core inputs captures, along with the current value of the signal, activity 
information about the signal since the last time the input was queried. At high design 
speeds, it is possible for a signal to be sampled as a 0, then have the signal transition from 
a 0 to a 1, then back to a 0 again before the signal is sampled again.

In the case of synchronous inputs, the activity is also detected with respect to the design 
clock. This can be useful in detecting glitches. If a 0 to 1 transition is detected, an up arrow 
appears alongside the value. If a 1 to 0 transition is detected, a down arrow appears. If both 
are detected, a two-headed arrow is displayed. The length of time the activity is displayed 
in the table is called the persistence. The persistence is also individually selectable via the 
right-click menu.

Note: The activity arrow is displayed in black if the activity is synchronous and red if it is 
asynchronous.

You can choose the VIO signal/bus value type by right-clicking on the signal or bus and 
selecting the Type menu choice (Figure 4-46).
X-Ref Target - Figure 4-46

Figure 4-46: The Type Selection Menu
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Text Field

When the Text Field type is selected, a text field is available for input using only the 
following valid characters:

• 0 and 1 for individual signals and binary buses

• 0-9, A-F for hex buses

• 0-7 for octal buses

• Valid signed and unsigned integers

Push Button

The Push Button type simulates an actual push button on a PCB. The inactive value is set 
when the button is not pressed in (0 for active-High, 1 for active-Low). As long as the 
button is pressed in, the active value will be output from the VIO core.

Toggle Button

The Toggle Button type switches between a 1 and a 0 with a single click.

Pulse Train (Synchronous outputs only)

The Pulse Train output type provides a control for synchronous outputs. A pulse train is 
a 16-cycle train of 1’s and 0’s, defined by the user. To edit the pulse train, click Edit. This 
brings up the Pulse Train dialog box (see Figure 4-47). One text field is available for each 
cycle in the pulse train. The text fields are populated by default according to the last value 
of the bus or signal. For buses, the fields are always displayed in binary to allow explicit 
control over each of the individual signals.

When Run is clicked, the pulse train is executed one time. This allows fine control over the 
output with respect to the design clock.

Single Pulse (Synchronous Outputs Only)

The Signal Pulse control is a special kind of push button. When the button is pressed, 
instead of the core driving a constant active value for the duration of the button being 
pressed, a pulse train with a single high cycle is executed exactly once.

X-Ref Target - Figure 4-47

Figure 4-47: The Pulse Train Dialog
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VIO Core Menu and Toolbar Controls

When the VIO console is in focus, the VIO core-specific menu and toolbar controls can be 
used to change the behavior of the VIO core inputs or outputs, as applicable (see 
Figure 4-48). The toolbar controls are described from left-to-right in the following sections.

JTAG Scan Rate

The JTAG Scan Rate at which the VIO core inputs are read is selectable via a combo box. 
The default scan rate is 250 ms. You can also set the sample period to 500 ms, 1s, 2s, or 
Manual Scan. When Manual Scan is chosen, the Sample Once (S!) button becomes 
enabled. At that point, the VIO core inputs are only read by pressing the Sample Once 
toolbar button or by selecting the VIO → Sample Once menu option.

Update Static Outputs

By default, when one VIO core output is changed, information is immediately sent to the 
VIO core to set up that particular output. To update all non-pulse train outputs at once, 
click Update Static Outputs (U!) toolbar button or select the VIO → Update Static 
Outputs menu option.

Reset All Outputs

To reset all outputs to their default state (0 for text fields and toggle buttons, all 0 pulse 
train for pulse trains) click the Reset All Outputs toolbar button or select the VIO → Reset 
All Outputs menu option.

Clear All Activity

At some point, it might be desirable to reset the activity display for all VIO core inputs. To 
do so, press the Clear All Activity toolbar button or select the VIO → Clear All Activity 
menu option. All input activity will be reset, regardless of the selected persistence.

X-Ref Target - Figure 4-48

Figure 4-48: VIO Toolbar and Menu Options
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System Monitor
The Virtex-5 devices include a new feature called a System Monitor. The System Monitor 
function is built around a 10-bit, 200-kSPS (kilo samples per second) analog-to-digital 
converter (ADC). When combined with a number of on-chip sensors, the ADC can 
measure FPGA physical operating parameters including on-chip power supply voltages 
and die temperature. For additional information, see UG192, Virtex-5 System Monitor User 
Guide. 

The Analyzer provides real-time JTAG access to the on-chip voltage and temperature 
sensors of the System Monitor primitive. All of the on-chip sensors are available before and 
after the Virtex-5 device has been configured with a valid bitstream. The System Monitor 
functionality does not require that you instantiate a System Monitor primitive block into 
your design. The only requirement is that the System Monitor-specific pins of the Virtex-5 
device are properly connected on the system board.

In the Analyzer project tree, each Virtex-5 device in the JTAG chain will have a System 
Monitor Console node (as shown in Figure 4-49). Right-clicking on the System Monitor 
node in the project tree will show an option for opening the System Monitor viewer. Left-
clicking on the System Monitor node in the project tree will show the various sensors in the 
signal browser. In the signal (or sensor) browser, you can rename or change the display 
units of the various sensors.

X-Ref Target - Figure 4-49

Figure 4-49: System Monitor Project Tree Node and Signal Browser
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System Monitor Console

The System Monitor Console sensor value viewer is shown in Figure 4-50. Each sensor 
value can be displayed in a history window or written to a log file. The following display 
values can be enabled for each sensor:

• Current value that is read directly from the System Monitor sensor

• Device maximum and minimum values that are read directly from the System 
Monitor sensor peak detectors

• Sampled maximum and minimum values that are derived from all sensor values that 
have been collected by the Analyzer since opening a JTAG cable connection (or the 
last System Monitor reset)

• Windowed average, maximum, and minimum values that are calculated over a 
sliding window of sensor values that have been collected by the Analyzer since 
opening a JTAG cable connection (or the last System Monitor reset)

The sampled and windowed values that are calculated by the System Monitor viewer can be 
reset by clicking on the Reset button on the toolbar.

X-Ref Target - Figure 4-50

Figure 4-50: System Monitor Console Showing Valid Sensor Data
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Note: If the System Monitor is not reporting valid sensor data, the System Monitor Console displays 
an Invalid Data banner message across the window (see Figure 4-51).

System Monitor Console Toolbar

The System Monitor Console toolbar and right-click menu options shown in Figure 4-49, 
page 141 provide a means to customize and interact with the System Monitor Console.

JTAG Scan Rate

The JTAG Scan Rate at which the System Monitor sensor data is read is selectable via a 
combo box. The default scan rate is 1s. You can also set the sample period to 1s, 2s, 5s, 10s, 
30s, 1min, or Manual Scan. When Manual Scan is chosen, the Sample Once (S!) button 
becomes enabled. At that point, the System Monitor data is only read by pressing the 
Sample Once toolbar button or by selecting the System Monitor → Sample Once menu 
option.

Window Depth

The depth of the window used in the sliding window calculations in the System Monitor 
viewer can be set using the Window Depth combobox on the toolbar or in the System 
Monitor → Window Depth menu. The depth of the sampling window can be set to 2, 4, 8, 
16, 32, 64, or 128 samples.

X-Ref Target - Figure 4-51

Figure 4-51: System Monitor Console Showing Invalid Sensor Data

http://www.xilinx.com


144 www.xilinx.comChipScope Pro 10.1 Software and Cores User Guide
UG029 (v10.1) March 24, 2008

Chapter 4: Using the ChipScope Pro Analyzer
R

External Input

The System Monitor component monitors voltage levels on external sensors. You can view 
any external sensor input one at a time by using the External Input option. Valid External 
Input selections include:

• Any of the 16 user-defined VAUXP/VAUXN external sensors

• The V_P/V_N dedicated external sensors

• The V_REFP reference voltage input

• The V_REFN reference voltage input

Select No Input to disable the viewing of the external input (default).

Reset

The Reset button resets the System Monitor Console display.

Enable Logging

The Enable Logging toolbar button and System Monitor → Enable Logging menu 
option enables the file logging feature that saves the System Monitor sensor data in a text 
file for use in offline analysis.

System Monitor Data Logging

The System Monitor → Setup Logging menu option opens the dialog window that is 
shown in Figure 4-52. The settings in this window are used to customize the logging 
feature.

Log File

The Browse button is used to select the location of the System Monitor log file. The default 
location is <CHIPSCOPE_INSTALL>/bin/<PLATFORM>/system_monitor.log, 
where <CHIPSCOPE_INSTALL> is the installation directory and <PLATFORM> is the 
operating system platform (nt, nt64, lin, lin64, or sol).

Log File Format

The System Monitor log file is a text file that can be formatted in two different ways: 
comma-separated value (CSV) file for machine processing or as a human-readable 
formatted file.

X-Ref Target - Figure 4-52

Figure 4-52: System Monitor Setup Logging Window
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Log File Limit

The System Monitor logging system can generate a lot of data that consumes a large 
amount of disk space. To alleviate the problem, the log data can be split across multiple 
separate files based on a log file limit. The log file limit can be based on a specific number 
of samples or by file size (in kilobytes).

Help

Viewing the Help Pages

The Analyzer help pages contain information for only the currently opened versions of 
the software and each of the core units. Selecting Help → About: ChipScope Software 
displays the version of the software. Selecting Help → About: Cores displays detailed 
core parameters for every detected core. Individual core parameters can be displayed by 
right-clicking on the unit in the project tree and selecting Show Core Info.

Also, you do not need to reinstall the ChipScope Pro tools to convert your evaluation 
version to a full version. You can also register an evaluation version of the Analyzer by 
selecting the Help → Register ChipScope Pro menu option and typing in the appropriate 
full-version registration ID. More information on how to obtain a full version of ChipScope 
Pro is available at http://www.xilinx.com/chipscopepro.
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ChipScope Pro ILA Waveform Toolbar Features
In addition to the menu options, other Analyzer ILA waveform commands are available 
on a toolbar residing directly below the Analyzer menu (Figure 4-53). The second set of 
toolbar buttons is available only when the Trigger Setup window is open. The third and 
fourth sets of toolbar buttons are only available when the Waveform window is active.

The toolbar buttons (from left to right) correspond to the following equivalent menu 
options:

• Open Cable/Search JTAG Chain: Automatically detects the cable, and queries the 
JTAG chain to find its composition

• Turn On/Off Auto Core Status Polling: Green icon means polling is on, red icon 
means polling is off. Same as JTAG Chain → Auto Core Status Poll

• Run: Same as Trigger Setup → Run (F5)

• Stop: Same as Trigger Setup → Stop Acquisition (F9)

• Trigger Immediate: Same as Trigger Setup → Trigger Immediate (Ctrl+F5)

• Go To X Marker: Same as Waveform → Go To → Go To X Marker

• Go To O Marker: Same as Waveform → Go To → Go To O Marker

• Go To Previous Trigger: Same as Waveform → Go To → Trigger → Previous

• Go To Next Trigger: Same as Waveform → Go To → Trigger → Next

• Zoom In: Same as Waveform → Zoom → Zoom In

• Zoom Out: Same as Waveform → Zoom → Zoom Out

• Fit Window: Same as Waveform → Zoom → Zoom Fit

X-Ref Target - Figure 4-53

Figure 4-53: Main ChipScope Pro Analyzer Toolbar Display
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ChipScope Pro Analyzer Command Line Options
On Windows systems, the Analyzer can be started either from the command line or from 
the Start menu.

• On Windows systems, you can invoke the analyzer from the command line by 
running: 

♦ $CHIPSCOPE\analzyer.exe

• On Linux systems, you can invoke the analyzer from the command line by running: 

♦ $CHIPSCOPE/bin/lin/analzyer.sh

• On Solaris systems, you can invoke the analyzer from the command line by running: 

♦ $CHIPSCOPE/bin/sol/analzyer.sh

where $CHIPSCOPE is the installation location.

Optional Arguments

The following command line options are available, if run from the command line:

-geometry <width>x<height>+<left edge x coord>+<top edge y coord>

Set location, width and height of the Analyzer program window.

-project <path and filename>

Reads in specified project file at start. Default is not to read a project file at start up.

-init <path and filename>

Read specified init file at start up and write to the same file when the Analyzer exits. 
The default is: %userprofile%\.chipscope\cs_analyzer.ini

-log <path and filename>

-log stdout

Write log messages to the specified file. Specifying stdout will write to standard 
output. The default is: $HOME/.chipscope/cs_analyzer.log

Windows Command Line Example

C:\Xilinx\10.1\ChipScope\analyzer.exe -log c:\proj\t\t.log -init 
C:\proj\t\t.ini -project c:\proj\t\t.cpj -geometry 1000x300+30+600
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Chapter 5

ChipScope Engine JTAG Tcl Interface

Overview
This interface provides Tcl scripting access to JTAG download cables via the ChipScope 
Engine JTAG (CseJtag) communication library. The purpose of the CseJtag Tcl interface is 
to provide a simple scripting system to access basic JTAG functions. In a few lines of Tcl 
script, you can scan and manipulate the JTAG chain through standard Xilinx cables.

For further information on JTAG, see XAPP139, Configuration and Readback of Virtex FPGAs 
Using (JTAG) Boundary Scan. For information about Tcl, see Tcl Developer Xchange at 
http://www.tcl.tk.

Requirements
• Windows XP Professional (32- or 64-bit), Windows Vista Business (32- or 64-bit), or 

RedHat Enterprise Linux 4 or 5 (32- or 64-bit)

• Supported JTAG cable such as Platform Cable USB, Parallel Cable IV, Parallel Cable 
III, or MultiPRO

• A Tcl shell (xtclsh.exe is provided in the ISE 10.1 tool installation) or the ActiveTcl 
shell (available from http://www.activestate.com)

• The required environment variables are set up by using the cs_xtclsh.bat script 
(on Windows) or cs_xtclsh.sh script (on Linux). These scripts also open the xtclsh 
shell with any arguments provided after the script name

Limitations
The ChipScope Engine JTAG Tcl interface package favors simplicity over performance. 
Some commands such as ::chipscope::csejtag_tap_shift_chain_ir and 
::chipscope::csejtag_tap_shift_chain_dr transfer bits as strings (for example, 
"0001000") instead of as packed binary data structures. The extra overhead in converting 
particularly large data strings does result in some loss of performance; however, the simple 
design of the application programming interface (API) and the use of the Tcl scripting 
language makes Tcl/JTAG an easy-to-use means to interact with devices in the JTAG chain.

Note: The CseJtag Tcl interface is only compatible with software that uses the CseJtag interface to 
the JTAG cable communication device (such as the Analyzer software tool and the Embedded 
Development Kit (EDK) XMD software debugger tool). Tools such as iMPACT do not use the CseJtag 
interface and therefore are not compatible for use with CseJtag Tcl scripts or programs.

http://www.activestate.com
http://www.xilinx.com
http://www.xilinx.com/bvdocs/appnotes/xapp139.pdf
http://www.xilinx.com/bvdocs/appnotes/xapp139.pdf
http://www.tcl.tk
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CseJtag Tcl Command Summary
The CseJtag Tcl interface commands belong to a namespace called ::chipscope::. The 
CseJtag Tcl interface is comprised of four commands (see Table 5-1), each having one or 
more subcommands.

A summary of the CseJtag Tcl subcommands is shown in Table 5-2. See “Command 
Details,” page 153 for additional information about these commands.

Table 5-1: CseJtag Tcl ::chipscope:: Commands

Command Description

::chipscope::csejtag_session Manages CseJtag sessions. A session is used to 
maintain all data and messaging associated with a 
JTAG target. See Table 5-2 for a summary of all 
subcommands for this command.

::chipscope::csejtag_db Interacts with the CseJtag JTAG database. The 
CseJtag JTAG database contains all data associated 
with known JTAG devices. See Table 5-3 for a 
summary of all subcommands for this command.

::chipscope::csejtag_target Manages connections to CseJtag targets, such as 
JTAG download cables, JTAG emulators, and other 
JTAG devices. See Table 5-4, page 151 for a 
summary of all subcommands for this command.

::chipscope::csejtag_tap Interacts with the JTAG Test Access Port (TAP) of 
CseJtag targets. Operations include navigating the 
TAP state machine and shifting data into and out of 
the TAP. See Table 5-5, page 152 for a summary of all 
subcommands for this command.

Table 5-2: Summary of ::chipscope::csejtag_session Subcommands

Subcommand Description

create Creates and initializes a session.

destroy Destroys and frees up memory resources used by an existing 
session.

get_api_version Gets the CseJtag API library version information.

send_message Sends a message using the session message router function.
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Table 5-3: Summary of ::chipscope::csejtag_db Subcommands

Subcommand Description

add_device_data Adds device records to the JTAG database.

lookup_device Looks up device information in the JTAG database.

get_device_name_for_idcode Gets the name of a device from the JTAG database by 
using an IDCODE.

parse_bsdl Extracts device data for a JTAG device by parsing a 
Boundary Scan Description Language (BSDL) buffer.

parse_bsdl_file Extracts device data for a JTAG device by parsing a 
Boundary Scan Description Language (BSDL) file.

Table 5-4: Summary of ::chipscope::csejtag_target Subcommands

Subcommand Description

open Opens a connection to a JTAG target and associate it with a 
session.

close Closes the connection to an open JTAG target and remove it 
from the session.

lock Attempts to obtain an exclusive lock on a JTAG target.

unlock Releases an exclusive lock on a JTAG target.

get_lock_status Gets the lock status of a JTAG target.

clean_locks Releases all cable locks and cleans up lock-related resources.

flush Flushes the data buffer of a JTAG target.

set_pin Sets the value of a JTAG target TAP pin.

get_pin Gets the value of a JTAG target TAP pin.

pulse_pin Pulses a JTAG target TAP pin.

wait_time Waits for a specified amount of time.

get_info Gets information associated with a JTAG target.
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Table 5-5: Summary of ::chipscope::csejtag_tap Subcommands

Subcommand Description

autodetect_chain Attempts to automatically detect all information pertaining 
to the JTAG chain currently connected to the target.

interrogate_chain Scans the JTAG chain to determine the length of the chain and 
the IDCODE information of each device in the chain.

get_device_count Gets the number of devices in the JTAG chain.

set_device_count Sets the number of devices in the JTAG chain.

get_irlength Gets the instruction register (IR) length of a device.

set_irlength Sets the instruction register (IR) length of a device.

get_device_idcode Gets the IDCODE of a device.

set_device_idcode Sets the IDCODE of a device.

navigate Navigates to a JTAG TAP state.

shift_chain_ir Shifts a stream of bits into and out of the instruction register 
of the JTAG chain.

shift_chain_dr Shifts a stream of bits into and out of the data register of the 
JTAG chain.

shift_device_ir Shifts a stream of bits into and out of the instruction register 
of a particular device in the JTAG chain.

shift_device_dr Shifts a stream of bits into and out of the data register of a 
particular device in the JTAG chain.
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Command Details

::chipscope::csejtag_session create
This is typically the first subcommand call made to the ChipScope Engine. The session 
handle that is returned by this command allows you to open and control JTAG targets. This 
command also initializes the session with data obtained from various data files located in 
the default directory called <LIBCSEJTAG_DLL_PATH>/data, where 
<LIBCSEJTAG_DLL_PATH> denotes the absolute path location of the libCseJtag.dll 
file.

Syntax

::chipscope::csejtag_session create messageRouterFn [opt_args...]

Arguments

Returns

A session handle. 

An exception is thrown if the command fails.

Example

1. Create a new session with no optional arguments.

%set handle [::chipscope::csejtag_session create messageRouterFn]

2. Create a new session using the client/server libraries to a server called “lab_machine” 
at port “50001”.

%set handle [::chipscope::csejtag_session create messageRouterFn 

-server “lab_machine” -port “50001”]

Table 5-6: Arguments for Subcommand ::chipscope::csejtag_session create

Argument Type Description

messageRouterFn Required
Message router function name. Use a value of 0 to route 
all messages to stdout.

datadir=<path> Optional

Directs the command to look for data files in <path> 
instead of in the default 
<LIBCSEJTAG_DLL_PATH>/data location. Note: All 
subsequent calls to the 
::chipscope::csejtag_session create 
subcommand use <path> unless a new one is specified.

-server <host> Optional Creates a session associated with the ChipScope server 
host name denoted by <cs_server_host_name>.

-port <portnum> Optional Creates a session associated with the ChipScope server 
port number denoted by <cs_server_port_number>.
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::chipscope::csejtag_session destroy
This command destroys an existing session and free all resources previously used by that 
session.

Syntax

::chipscope::csejtag_session destroy handle

Arguments

Returns

An exception is thrown if the command fails.

Example

1. Destroy the specified session

%::chipscope::csejtag_session destroy $handle

Table 5-7: Arguments for Subcommand ::chipscope::csejtag_session create

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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::chipscope::csejtag_session get_api_version
This command retrieves the version of the CseJtag API library.

Syntax

::chipscope::csejtag_session get_api_version

Arguments

There are no arguments for this command.

Returns

A Tcl list containing API version information. List elements are in the format:

{apiVersion versionString}

The apiVersion is the API version number and versionString is the build version 
number. An exception is thrown if command fails.

Example

1. Obtain a list containing the API version number and the build number version string

%set api_info [::chipscope::csejtag_session get_api_version]
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::chipscope::csejtag_session send_message
This subcommand sends a message to the message router function of the CseJtag library.

Syntax

::chipscope::csejtag_session send_message handle msgType msg

Arguments

Returns

An exception is thrown if the command fails.

Example

1. Send the message "Hello World!" to the message router function

%::chipscope::csejtag_session send_message $handle $CSE_MSG_INFO 
"Hello World!"

Table 5-8: Arguments for Subcommand ::chipscope::csejtag_session 
send_message

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

msgType

The type of message that must be set to one of the following:

• $CSE_MSG_ERROR
• $CSE_MSG_WARNING
• $CSE_MSG_STATUS
• $CSE_MSG_INFO
• $CSE_MSG_NOISE
• $CSE_MSG_DEBUG

msg The message string.
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::chipscope::csejtag_target open
This subcommand opens a JTAG target device and associates it with a session.

Note: Currently, only one JTAG target can be opened per session.

Syntax

::chipscope::csejtag_target open handle targetName 
progressCallbackFunc [optional args...]

Arguments

Table 5-10 shows valid combinations of targetName argument values and their optional 
arguments.

Table 5-9: Arguments for Subcommand ::chipscope::csejtag_target open

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

targetName

Name of the JTAG target to open. See Table 5-10 for 
available targetName and [optional args...] 
combinations. If targetName is set to 
$CSEJTAG_TARGET_AUTO, then the first available JTAG 
cable target will be opened.

progressCallba
ckFunc

Progress callback function that can be used to monitor 
progress of JTAG target operations. The format of the 
progress callback function is:

proc progressCallbackFunc (handle 
totalCount CurrentCount progressStatus) 
{...}

The progress callback function must return either 
$CSE_STOP or $CSE_CONTINUE. If no progress 
callback function is necessary, a 0 should be passed into 
this argument position.

Table 5-10: Argument targetName and [optional args...] combinations

targetName [optional args...]

$CSEJTAG_TARGET_AUTO N/A

$CSEJTAG_TARGET_PARALLEL "port={LPT1 | LPT2 | LPT3}"

"frequency={5000000 | 2500000 | 200000}"

$CSEJTAG_TARGET_PLATFORMUSB "port=USB2"

"frequency={24000000 | 12000000 | 6000000 | 
3000000 | 1500000 | 750000}"

$CSEJTAG_TARGET_SVFFILE "fname=<svf filename with full path>"
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Returns

A list in the format:

{target_name plugin_name fw_ver driver_ver plugin_ver vendor frequency 
port cable_name rawinfo cable_flags}

Where:

target_name

Same as the targetName string

plugin_name

The plugin library name string

fw_ver

The firmware version string

driver_ver

The driver version string

plugin_ver

The plugin version string

vendor

The vendor string

frequency

The frequency string

port

The port string

cable_name

The full cable name string

rawinfo

The raw target info string

cable_flags

The integer containing target-specific flags

An exception is thrown if the subcommand fails.

Example

1. Try to autodetect and open the target cable. Returns information on the opened target.

%set targetInfo [::chipscope::csejtag_target open $handle 
$CSEJTAG_TARGET_AUTO progressFunc]

2. Try to open a Parallel cable in the port LPT1 with a frequency of 200000. Returns 
information on the opened target.

%set targetInfo [::chipscope::csejtag_target open $handle 
$CSEJTAG_TARGET_PARALLEL progressFunc “port=LPT1” “frequency=200000”]
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::chipscope::csejtag_target close
This subcommand closes a previously opened JTAG target device.

Syntax

::chipscope::csejtag_target close handle

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Close the current target in the specified session.

%::chipscope::csejtag_target close $handle

Table 5-11: Arguments for Subcommand ::chipscope::csejtag_target close

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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::chipscope::csejtag_target lock
This subcommand attempts to obtain an exclusive lock on a previously opened JTAG 
target device.

Syntax

::chipscope::csejtag_target lock handle msWait

Arguments

Returns

The lock status in the form of one of the following:

- $CSEJTAG_LOCKED_ME 

- $CSEJTAG_LOCKED_OTHER 

- $CSEJTAG_UNKNOWN 

An exception is thrown if the subcommand fails.

Example

1. Attempt to obtain an exclusive target lock and wait at least 1000 milliseconds. Obtains 
the status of the lock.

%set lockStatus [::chipscope::csejtag_target lock $handle 1000]

Table 5-12: Arguments for Subcommand ::chipscope::csejtag_target lock

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

msWait
Wait time in milliseconds before giving up (-1 means 
wait until lock is gained)
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::chipscope::csejtag_target unlock
This subcommand releases an exclusive lock on a previously opened and locked JTAG 
target device.

Syntax

::chipscope::csejtag_target unlock handle

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Unlock the target in the specified session.

%::chipscope::csejtag_target unlock $handle

Table 5-13: Arguments for Subcommand ::chipscope::csejtag_target unlock

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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::chipscope::csejtag_target get_lock_status
This subcommand retrieves the lock status for the target device.

Syntax

::chipscope::csejtag_target get_lock_status handle

Arguments

Returns

Status of the lock in the form of one of the following:

- $CSEJTAG_LOCKED_ME 

- $CSEJTAG_LOCKED_OTHER 

- $CSEJTAG_UNKNOWN 

An exception is thrown if the subcommand fails.

Example

1. Obtain the current lock status

%set lockStatus [::chipscope::csejtag_target get_lock_status $handle]

Table 5-14: Arguments for Subcommand ::chipscope::csejtag_target 
get_lock_status

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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::chipscope::csejtag_target clean_locks
This subcommand cleans up all JTAG target locks.

Note: This subcommand should only be used as a last resort. The subcommand kills all sharing 
semaphores, including those used by other processes and applications. It currently only cleans up 
locks for JTAG cable targets.

Syntax

::chipscope::csejtag_target clean_locks handle

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Clean locks as a last resort because the application closed unexpectedly and 
::chipscope::csejtag_target open will not open the target successfully.

%::chipscope::csejtag_target clean_locks $handle

Table 5-15: Arguments for Subcommand ::chipscope::csejtag_target clean_locks

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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::chipscope::csejtag_target flush
This subcommand flushes the buffer associated with a previously opened and locked 
JTAG target device.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand.

Syntax

::chipscope::csejtag_target flush handle

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Attempt to flush an opened and locked JTAG target’s buffer to make data writes occur 
immediately

%::chipscope::csejtag_target flush $handle

Table 5-16: Arguments for Subcommand ::chipscope::csejtag_target flush

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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::chipscope::csejtag_target set_pin
This subcommand sets the value of a JTAG TAP pin for a previously opened and locked 
JTAG target device.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

If using this function to change the JTAG TAP state, please be aware that the CseJtag Tcl 
library will not keep track of the JTAG TAP state. Before using any of the 
::chipscope::csejtag_tap subcommands, use the ::chipscope::csejtag_tap 
navigate subcommand to set the JTAG TAP state machine to the 
$CSEJTAG_TEST_LOGIC_RESET state.

Syntax

::chipscope::csejtag_target set_pin handle pin value

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Set the TMS pin to 1

%::chipscope::csejtag_target set_pin $handle $CSEJTAG_TMS 1

Table 5-17: Arguments for Subcommand ::chipscope::csejtag_target set_pin

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

pin
JTAG TAP pin identifier {$CSEJTAG_TMS | $CSEJTAG_TCK | 
$CSEJTAG_TDI}.

value JTAG TAP pin value {1=set, 0=clear}
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::chipscope::csejtag_target get_pin
This subcommand retrieves the value of a JTAG TAP pin for a previously opened and 
locked JTAG target device.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

Syntax

::chipscope::csejtag_target get_pin handle pin

Arguments

Returns

JTAG TAP pin value {1=set, 0=clear}

An exception is thrown if the subcommand fails.

Example

1. Get the current value of the TDO pin

%set value [::chipscope::csejtag_target set_pin $handle $CSEJTAG_TDO]

Table 5-18: Arguments for Subcommand ::chipscope::csejtag_target get_pin

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

pin
JTAG TAP pin identifier {$CSEJTAG_TMS | $CSEJTAG_TCK | 
$CSEJTAG_TDI | $CSEJTAG_TDO}.
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::chipscope::csejtag_target pulse_pin
This subcommand pulses the value of a JTAG TAP pin for a previously opened and locked 
JTAG target device.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

If using this function to change the JTAG TAP state, please be aware that the CseJtag Tcl 
library will not keep track of the JTAG TAP state. Before using any of the 
::chipscope::csejtag_tap subcommands, use the ::chipscope::csejtag_tap 
navigate subcommand to set the JTAG TAP state machine to the 
$CSEJTAG_TEST_LOGIC_RESET state.

Syntax

::chipscope::csejtag_target pulse_pin handle pin count

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Pulse the TCK pin five times

%::chipscope::csejtag_target pulse_pin $handle $CSEJTAG_TCK 5

Table 5-19: Arguments for Subcommand ::chipscope::csejtag_target pulse_pin

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

pin
JTAG TAP pin identifier {$CSEJTAG_TMS | 
$CSEJTAG_TCK | $CSEJTAG_TDI}.

count
Number of times to pulse the JTAG TAP pin (pulse means 
driving a 0, then a 1, then a 0 on the pin).
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::chipscope::csejtag_target wait_time
This subcommand waits for a specified amount of time (in microseconds).

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

Syntax

::chipscope::csejtag_target wait_time handle usecs

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Instruct the JTAG target to wait 1000 microseconds before performing another 
operation

%::chipscope::csejtag_target wait_time $handle 1000

Table 5-20: Arguments for Subcommand ::chipscope::csejtag_target wait_time

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

usecs Number of microseconds to wait.
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::chipscope::csejtag_target get_info
This subcommand retrieves information from a previously opened JTAG target.

Note: A JTAG target lock does not need to be obtained prior to calling this function.

Syntax

::chipscope::csejtag_target get_info handle

Arguments

Returns

A list in the format:

{target_name plugin_name fw_ver driver_ver plugin_ver vendor frequency 
port cable_name rawinfo cable_flags}

Where:

target_name

Name of the JTAG target

plugin_name

The plugin library name string

fw_ver

The firmware version string

driver_ver

The driver version string

plugin_ver

The plugin version string

vendor

The vendor string

frequency

The frequency string

port

The port string

cable_name

The full cable name string

rawinfo

The raw target info string

Table 5-21: Arguments for Subcommand ::chipscope::csejtag_target get_info

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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cable_flags

The integer containing target-specific flags

An exception is thrown if the subcommand fails.

Example

1. Obtain information about the current JTAG target

%set targetInfo [::chipscope::csejtag_target get_info $handle]
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::chipscope::csejtag_tap autodetect_chain
This subcommand attempts to automatically detect the composition of the JTAG chain. 
The subcommand first obtains the number of devices and IDCODE values for devices in 
the JTAG chain. The IR lengths are then determined for the devices in the JTAG chain that 
have an IDCODE. The IR lengths for devices that do not have corresponding IDCODEs 
must be assigned manually. Upon success, all pertinent device information is determined 
and set in the session. Some IEEE 1149.1 non-compliant devices might not be compatible 
with this subcommand and might cause the entire chain to be detected incorrectly or not at 
all.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

Syntax

::chipscope::csejtag_tap autodetect_chain handle algorithm

Arguments

Returns

An exception is thrown if the subcommand fails to detect the chain completely. In the case 
of such an error, the devices in the JTAG chain must be detected and assigned manually.

Example

1. Attempt to automatically detect the chain using the default algorithm

%::chipscope::csejtag_tap autodetect_chain $handle 
$CSEJTAG_SCAN_DEFAULT

Table 5-22: Arguments for Subcommand ::chipscope::csejtag_tap 
autodetect_chain

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

algorithm

Algorithm used to determine the composition of the JTAG 
chain. Can be set to one of {$CSEJTAG_SCAN_DEFAULT | 
$CSEJTAG_SCAN_TLRSHIFT | 
$CSEJTAG_SCAN_WALKING_ONES}

The CSEJTAG_SCAN_WALKING_ONES algorithm is:

• Set each device into BYPASS by shifting long stream of 1's 
into IR

• Shift DR pattern into TDI and wait for pattern on TDO. The 
number of shifts determines the number of devices in the 
JTAG chain.

• Perform the CSEJTAG_SCAN_TLRSHIFT algorithm to get 
IDCODEs for each device.

The CSEJTAG_SCAN_TLRSHIFT algorithm is:

• Navigate to TLR

Shift out bits until all IDCODEs (or BYPASS bits) are read.

http://www.xilinx.com


172 www.xilinx.comChipScope Pro 10.1 Software and Cores User Guide
UG029 (v10.1) March 24, 2008

Chapter 5: ChipScope Engine JTAG Tcl Interface
R

::chipscope::csejtag_tap interrogate_chain
This subcommand scans the JTAG chain to obtain the IDCODE and number of devices in 
the chain. Some IEEE 1149.1 non-compliant devices might not be compatible with this 
subcommand and can cause the entire chain to be detected incorrectly or not at all.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

Syntax

::chipscope::csejtag_tap interrogate_chain handle algorithm

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Attempt to interrogate the chain using the default algorithm

%::chipscope::csejtag_tap interrogate_chain $handle 
$CSEJTAG_SCAN_DEFAULT

Table 5-23: Arguments for Subcommand ::chipscope::csejtag_tap 
interrogate_chain

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

algorithm

Algorithm used to determine the composition of the JTAG 
chain. Can be set to one of {$CSEJTAG_SCAN_DEFAULT | 
$CSEJTAG_SCAN_TLRSHIFT | 
$CSEJTAG_SCAN_WALKING_ONES}

The CSEJTAG_SCAN_WALKING_ONES algorithm is:

• Set each device into BYPASS by shifting long stream of 1's 
into IR

• Shift DR pattern into TDI and wait for pattern on TDO. The 
number of shifts determines the number of devices in the 
JTAG chain.

• Perform the CSEJTAG_SCAN_TLRSHIFT algorithm to get 
IDCODEs for each device.

The CSEJTAG_SCAN_TLRSHIFT algorithm is:

• Navigate to TLR
• Shift out bits until all IDCODEs (or BYPASS bits) are read
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::chipscope::csejtag_tap get_device_count
This subcommand is used to get the number of devices in the current JTAG chain. 

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

Syntax

::chipscope::csejtag_tap get_device_count handle

Arguments

Returns

The number of devices in the chain. 

An exception is thrown if the subcommand fails.

Example

1. Obtain the number of devices in the JTAG chain.

%set deviceCount [::chipscope::csejtag_tap get_device_count $handle]

Table 5-24: Arguments for Subcommand ::chipscope::csejtag_tap 
get_device_count

Argument Type Description

handle Required
Handle to the session that is returned by 
::chipscope::csejtag_session create.
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::chipscope::csejtag_tap set_device_count
This subcommand is used to set the number of devices in the current JTAG chain. 

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. 

Syntax

::chipscope::csejtag_tap set_device_count handle count

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Set the number of devices in the JTAG chain to four.

%::chipscope::csejtag_tap set_device_count $handle 4

Table 5-25: Arguments for Subcommand ::chipscope::csejtag_tap 
set_device_count

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

count Number of devices in the JTAG chain.
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::chipscope::csejtag_tap get_irlength
This subcommand retrieves the instruction register (IR) length of a device in the current 
JTAG chain. The IR length is used to determine the amount of padding required to shift an 
instruction into a device register. TAP shift and navigate operations will not work until all 
devices have the IR lengths set up correctly. The ::chipscope::csejtag_tap 
autodetect_chain subcommand automatically sets up IR lengths for all devices in the 
chain that support the IDCODE command.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. Also, the device count must be set prior to calling this 
subcommand using the ::chipscope::csejtag_tap set_device_count.

Syntax

::chipscope::csejtag_tap get_irlength handle deviceIndex

Arguments

Returns

The length of the IR for the device.

An exception is thrown if the subcommand fails.

Example

1. Get the IR length of the device at index 0.

%set irLength [::chipscope::csejtag_tap get_irlength $handle 0]

Table 5-26: Arguments for Subcommand ::chipscope::csejtag_tap get_irlength

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

deviceIndex Device index (0 to n-1) in the n-length JTAG chain.
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::chipscope::csejtag_tap set_irlength
This subcommand sets the instruction register (IR) length of a single device in the current 
JTAG chain. The IR length is used to determine the amount of padding required to shift an 
instruction into a device register. TAP shift and navigate operations will not work until all 
devices have the IR lengths set up correctly. The ::chipscope::csejtag_tap 
autodetect_chain subcommand automatically sets up IR lengths for all devices in the 
chain that support the IDCODE command.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. Also, the device count must be set prior to calling this 
subcommand using the ::chipscope::csejtag_tap set_device_count.

Syntax

::chipscope::csejtag_tap set_irlength handle deviceIndex irLength

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Set the IR length of the device at index 0 to 11 bits.

%::chipscope::csejtag_tap set_irlength $handle 0 11

Table 5-27: Arguments for Subcommand ::chipscope::csejtag_tap set_irlength

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

deviceIndex Device index (0 to n-1) in the n-length JTAG chain.

irLength Length of the IR (in bits)
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::chipscope::csejtag_tap get_device_idcode
This subcommand returns the 32-bit IDCODE for a given device in the current JTAG chain. 
If the device does not support the IDCODE instruction, a null string is returned.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. Also, the device count must be set prior to calling this 
subcommand using the ::chipscope::csejtag_tap set_device_count.

Syntax

::chipscope::csejtag_tap get_device_idcode handle deviceIndex

Arguments

Returns

A 32-character string of ones and zeros representing the 32-bit IDCODE of the device.

An exception is thrown if the subcommand fails.

Example

1. Get the IDCODE of the device at index 0

%set idcode [::chipscope::csejtag_tap get_device_idcode $handle 0]

Table 5-28: Arguments for Subcommand ::chipscope::csejtag_tap 
get_device_idcode

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

deviceIndex Device index (0 to n-1) in the n-length JTAG chain.
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::chipscope::csejtag_tap set_device_idcode
This subcommand sets the IDCODE for a given device in the current JTAG chain. Passing 
a null string indicates the device does not support the IDCODE instruction.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. Also, the device count must be set prior to calling this 
subcommand using the ::chipscope::csejtag_tap set_device_count.

Syntax

::chipscope::csejtag_tap set_device_idcode handle deviceIndex idcode

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Set the IDCODE of the device at index 0 to 
01010101010101010101010101010101.

%::chipscope::csejtag_tap set_device_idcode $handle 0 
“01010101010101010101010101010101”

Table 5-29: Arguments for Subcommand ::chipscope::csejtag_tap 
set_device_idcode

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

deviceIndex Device index (0 to n-1) in the n-length JTAG chain.

idcode A 32-character string of ones and zeros 
representing the 32-bit IDCODE of the device.
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::chipscope::csejtag_tap navigate
This subcommand is used to change the state of the TAP of a device in the JTAG chain.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand.

Syntax

::chipscope::csejtag_tap navigate handle newState clockRepeat 
microseconds

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Navigate the TAP state to Test Logic Reset and keep it in this state for five additional 
clock cycles.

%::chipscope::csejtag_tap navigate $handle $CSEJTAG_TEST_LOGIC_RESET 5 
0

Table 5-30: Arguments for Subcommand ::chipscope::csejtag_tap navigate

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

newState New state to navigate into.

clockRepeat Number of additional times to pulse the TCK pin 
after entering the new state.

microseconds Number of microseconds to sleep after 
navigating to the new state.
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::chipscope::csejtag_tap shift_chain_ir
This subcommand is used to shift a stream of bits into and out of the instruction register of 
the JTAG chain. No device padding is performed by this subcommand. For device-indexed 
IR shifting, see ::chipscope::csejtag_tap shift_device_ir.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand.

Syntax

::chipscope::csejtag_tap shift_chain_ir handle shiftMode exitState 
progressCallbackFunc bitCount hextdibuf [-hextdimask hextdimaskval] [-
hextdomask hextdomaskval]

Arguments

Returns

A buffer that is full of the data that is shifted out of the TDO pin of the JTAG TAP.

An exception is thrown if the subcommand fails.

Table 5-31: Arguments for Subcommand ::chipscope::csejtag_tap shift_chain_ir

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

shiftMode {CSJTAG_SHIFT_READ | CSJTAG_SHIFT_WRITE | 
CSJTAG_SHIFT_READWRITE)

exitState State to end in after shift is complete (CSEJTAG_SHIFT_IR 
if no state change is desired).

progressCallback
Func

Progress callback function that can be used to monitor 
progress of JTAG target operations. The format of the 
progress callback function is:

proc progressCallbackFunc (handle totalCount 
CurrentCount progressStatus) {...}

The progress callback function must return either 
$CSE_STOP or $CSE_CONTINUE. If no progress callback 
function is necessary, a 0 should be passed into this 
argument position.

bitCount Number of bits to shift.

hextdibuf Data buffer that holds the data bits to be written into TDI. 
The least-significant bit is shifted into TDI first.

-hextdimask

hextdimaskval

Optional

Specifies that a mask word hextdimaskval should be 
applied to the data buffer bits before the data is shifted into 
the TDI pin of the JTAG TAP.

-hextdomask

hextdomaskval

Specifies that a mask word hextdomaskval should be 
applied to the data buffer bits after the data is shifted out of 
the TDO pin of the JTAG TAP.
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Example

1. This function shifts in 64 ones into the instruction register, captures the 64 bits of 
received data, and navigates to the Run Test Idle state when finished.

%set hextdobuf [::chipscope::csejtag_tap shift_chain_ir $handle 
$CSEJTAG_SHIFT_READWRITE $CSEJTAG_RUN_TEST_IDLE progressFunc 64 
“FFFFFFFFFFFFFFFF”]
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::chipscope::csejtag_tap shift_device_ir
This subcommand is used to shift a stream of bits into and out of the instruction register of 
a particular device the JTAG chain. Device padding is performed by this subcommand by 
putting all other devices into BYPASS mode. This subcommand should be called before 
::chipscope::csejtag_tap shift_device_dr to ensure all non-target devices as 
in BYPASS mode, otherwise unexpected and unintended results can occur. For raw data 
shifting into the chain IR, see ::chipscope::csejtag_tap shift_chain_ir.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. Also, the number of bits shifted into the device IR 
must be exactly equal to the IR length of the device otherwise the subcommand will fail.

Syntax

::chipscope::csejtag_tap shift_device_ir handle deviceIndex shiftMode 
exitState progressCallbackFunc bitCount hextdibuf [-hextdimask 
hextdimaskval] [-hextdomask hextdomaskval]

Arguments

Table 5-32: Arguments for Subcommand ::chipscope::csejtag_tap shift_device_ir

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

deviceIndex Device index (0 to n-1) in the n-length JTAG chain.

shiftMode
{CSJTAG_SHIFT_READ | CSJTAG_SHIFT_WRITE | 
CSJTAG_SHIFT_READWRITE)

exitState
State to end in after shift is complete 
(CSEJTAG_SHIFT_IR if no state change is desired).

progressCallback
Func

Progress callback function that can be used to monitor 
progress of JTAG target operations. The format of the 
progress callback function is:

proc progressCallbackFunc (handle totalCount 
CurrentCount progressStatus) {...}

The progress callback function must return either 
$CSE_STOP or $CSE_CONTINUE. If no progress callback 
function is necessary, a 0 should be passed into this 
argument position.

bitCount Number of bits to shift.

hextdibuf
Data buffer that holds the data bits to be written into TDI. 
The least-significant bit is shifted into TDI first.

-hextdimask

hextdimaskva
l

Optional

Specifies that a mask word hextdimaskval should be applied 
to the data buffer bits before the data is shifted into the TDI 
pin of the JTAG TAP.

-hextdomask

hextdomaskval

Specifies that a mask word hextdomaskval should be 
applied to the data buffer bits after the data is shifted out of 
the TDO pin of the JTAG TAP.
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Returns

A buffer that is full of the data that is shifted out of the TDO pin of the JTAG TAP.

An exception is thrown if the subcommand fails.

Example

1. This function shifts in 11 ones into the instruction register of the device at index 1, 
captures the 11 bits of received data, and navigates to the Run Test Idle state when 
finished.

%set hextdobuf [::chipscope::csejtag_tap shift_device_ir $handle 1 
$CSEJTAG_SHIFT_READWRITE $CSEJTAG_RUN_TEST_IDLE progressFunc 11 “7FF”]
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::chipscope::csejtag_tap shift_chain_dr
This subcommand is used to shift a stream of bits into and out of the data register (DR) of 
the JTAG chain. No device padding is performed by this subcommand. For device-indexed 
DR shifting, see ::chipscope::csejtag_tap shift_device_dr.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand.

Syntax

::chipscope::csejtag_tap shift_chain_dr handle shiftMode exitState 
progressCallbackFunc bitCount hextdibuf [-hextdimask hextdimaskval] [-
hextdomask hextdomaskval]

Arguments

Returns

A buffer that is full of the data that is shifted out of the TDO pin of the JTAG TAP.

An exception is thrown if the subcommand fails.

Table 5-33: Arguments for Subcommand ::chipscope::csejtag_tap shift_chain_dr

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

shiftMode {CSJTAG_SHIFT_READ | CSJTAG_SHIFT_WRITE | 
CSJTAG_SHIFT_READWRITE)

exitState State to end in after shift is complete 
(CSEJTAG_SHIFT_DR if no state change is desired).

progressCallbac
kFunc

Progress callback function that can be used to monitor 
progress of JTAG target operations. The format of the 
progress callback function is:

proc progressCallbackFunc (handle totalCount 
CurrentCount progressStatus) {...}

The progress callback function must return either 
$CSE_STOP or $CSE_CONTINUE. If no progress callback 
function is necessary, a 0 should be passed into this 
argument position.

bitCount Number of bits to shift.

hextdibuf Data buffer that holds the data bits to be written into TDI. 
The least-significant bit is shifted into TDI first.

-hextdimask

hextdimaskva
l

Optional

Specifies that a mask word hextdimaskval should be 
applied to the data buffer bits before the data is shifted into 
the TDI pin of the JTAG TAP.

-hextdomask

hextdomaskval

Specifies that a mask word hextdomaskval should be 
applied to the data buffer bits after the data is shifted out of 
the TDO pin of the JTAG TAP.
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Example

1. This function shifts in 64 ones into the instruction register, captures the 64 bits of 
received data, and navigates to the Run Test Idle state when finished.

%set hextdobuf [::chipscope::csejtag_tap shift_chain_dr $handle 
$CSEJTAG_SHIFT_READWRITE $CSEJTAG_RUN_TEST_IDLE progressFunc 64 
“FFFFFFFFFFFFFFFF”]
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::chipscope::csejtag_tap shift_device_dr
This subcommand is used to shift a stream of bits into and out of the data register of a 
particular device the JTAG chain. Device padding is performed by this subcommand by 
assuming all non-target devices are in BYPASS mode, then adding the necessary heading 
and trailing bits to accommodate for the position of the target device in the chain. For raw 
data shifting into the chain DR, see ::chipscope::csejtag_tap shift_chain_dr.

Note: The JTAG target must be locked by using the ::chipscope::csejtag_target lock 
subcommand before calling this subcommand. This subcommand should be called before 
::chipscope::csejtag_tap shift_device_dr to ensure all non-target devices as in 
BYPASS mode, otherwise unexpected and unintended results can occur.

Syntax

::chipscope::csejtag_tap shift_device_dr handle deviceIndex shiftMode 
exitState progressCallbackFunc bitCount hextdibuf [-hextdimask 
hextdimaskval] [-hextdomask hextdomaskval]

Arguments

Table 5-34: Arguments for Subcommand ::chipscope::csejtag_tap shift_device_dr

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

deviceIndex Device index (0 to n-1) in the n-length JTAG chain.

shiftMode {CSJTAG_SHIFT_READ | CSJTAG_SHIFT_WRITE | 
CSJTAG_SHIFT_READWRITE)

exitState State to end in after shift is complete 
(CSEJTAG_SHIFT_DR if no state change is desired).

progressCallback
Func

Progress callback function that can be used to monitor 
progress of JTAG target operations. The format of the 
progress callback function is:

proc progressCallbackFunc (handle totalCount 
CurrentCount progressStatus) {...}

The progress callback function must return either 
$CSE_STOP or $CSE_CONTINUE. If no progress callback 
function is necessary, a 0 should be passed into this 
argument position.

bitCount Number of bits to shift.

hextdibuf
Data buffer that holds the data bits to be written into TDI. 
The least-significant bit is shifted into TDI first.

-hextdimask

hextdimaskval
Optional

Specifies that a mask word hextdimaskval should be 
applied to the data buffer bits before the data is shifted into 
the TDI pin of the JTAG TAP.

-hextdomask

hextdomaskval

Specifies that a mask word hextdomaskval should be 
applied to the data buffer bits after the data is shifted out 
of the TDO pin of the JTAG TAP.
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Returns

A buffer that is full of the data that is shifted out of the TDO pin of the JTAG TAP.

An exception is thrown if the subcommand fails.

Example

1. This function shifts in 11 ones into the data register of the device at index 1, captures 
the 11 bits of received data, and navigates to the Run Test Idle state when finished.

%set hextdobuf [::chipscope::csejtag_tap shift_device_dr $handle 1 
$CSEJTAG_SHIFT_READWRITE $CSEJTAG_RUN_TEST_IDLE progressFunc 11 “7FF”]
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::chipscope::csejtag_db add_device_data
This subcommand is used to read device records from a file and add it to the memory-
based lookup table inside the CseJtag library.

Note: The file format and device record structure is the same as the idcode.lst file. 

Syntax

::chipscope::csejtag_db add_device_data handle filename buf bufLen

Arguments

Returns

An exception is thrown if the subcommand fails.

Example

1. Adding data from the file my_idcode.lst to the internal device database. Also, store 
the data record buffer and buffer size in local variables.

%::chipscope::csejtag_db add_device_data $handle “my_idcode.lst” 
$my_idcode_buf $my_idcode_bufLen

Table 5-35: Arguments for Subcommand ::chipscope::csejtag_db add_device_data

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

filename
String containing filename from which device records 
should be read

buf String containing device records in the same format and 
structure as the idcode.lst file.

bufLen Size of the buffer (in bytes or characters)
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::chipscope::csejtag_db lookup_device
This subcommand is used to look up a device in the database using the device IDCODE. 

Syntax

::chipscope::csejtag_db lookup_device handle idcode

Arguments

Returns

A list in the format:

{deviceName irlen cmd_bypass}

where

deviceName

String containing the name of the device

irlen

Number of bits in the IR of the device

cmd_bypass

String containing the BYPASS instruction for the device (usually all ones)

An exception is thrown if the subcommand fails.

Example

1. Look in the database for the device information belonging to IDCODE 
01010101010101010101010101010101.

%set deviceInfo [::chipscope::csejtag_db lookup_device $handle 
“01010101010101010101010101010101”]

Table 5-36: Arguments for Subcommand ::chipscope::csejtag_db lookup_device

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

idcode IDCODE for the desired device.
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::chipscope::csejtag_db get_device_name_for_idcode
This subcommand is used to get the name of a device in the database using the device 
IDCODE.

Syntax

::chipscope::csejtag_db get_device_name_for_idcode handle idcode

Arguments

Returns

A string containing the device name.

An exception is thrown if the subcommand fails.

Example

1. Look in the database for the name of the device belonging to IDCODE 
01010101010101010101010101010101.

%set deviceName [::chipscope::csejtag_db get_device_name_for_idcode 
$handle “01010101010101010101010101010101”]

Table 5-37: Arguments for Subcommand ::chipscope::csejtag_db 
get_device_name_for_idcode

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

idcode IDCODE for the desired device.
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::chipscope::csejtag_db get_irlength_for_idcode
This subcommand is used to get the IR length of a device in the database using the device 
IDCODE.

Syntax

::chipscope::csejtag_db get_irlength_for_idcode handle idcode

Arguments

Returns

A string containing the size of the IR (in bits).

An exception is thrown if the subcommand fails.

Example

1. Look in the database for the IR length of the device belonging to IDCODE 
01010101010101010101010101010101.

%set irlen [::chipscope::csejtag_db get_irlength_for_idcode $handle 
“01010101010101010101010101010101”]

Table 5-38: Arguments for Subcommand ::chipscope::csejtag_db 
get_irlength_for_idcode

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

idcode IDCODE for the desired device.
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::chipscope::csejtag_db parse_bsdl
This subcommand is used to extract device information from a Boundary Scan Description 
Language (BSDL) buffer.

Syntax

::chipscope::csejtag_db parse_bsdl handle filename buf bufLen

Arguments

Returns

A list in the format:

{deviceName irlen idcode cmd_bypass}

Where:

deviceName

String containing the name of the device

irlen

Number of bits in the IR of the device

idcode

IDCODE of the device

cmd_bypass

String containing the BYPASS instruction for the device (usually all ones)

An exception is thrown if the subcommand fails.

Example

1. Extract device information from the file “device.bsd” that was placed in the buffer 
bsdl_buf of size bsdl_bufLen.

%::chipscope::csejtag_db parse_bsdl $handle “device.bsd” $bsdl_buf 
$bsdl_bufLen

Table 5-39: Arguments for Subcommand ::chipscope::csejtag_db parse_bsdl

Argument Type Description

handle

Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

filename Filename of local BSDL file (for debugging only)

buf Buffer containing the contents of the entire BSDL file

bufLen Size of the buffer buf (in bytes or characters)
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::chipscope::csejtag_db parse_bsdl_file
This subcommand is used to extract device information from a Boundary Scan Description 
Language (BSDL) file.

Syntax

::chipscope::csejtag_db parse_bsdl_file handle filename

Arguments

Returns

A list in the format:

{deviceName irlen idcode cmd_bypass}

Where:

deviceName

String containing the name of the device

irlen

Number of bits in the IR of the device

idcode

IDCODE of the device

cmd_bypass

String containing the BYPASS instruction for the device (usually all ones)

An exception is thrown if the subcommand fails.

Example

1. Extract device information from the file device.bsd.

%::chipscope::csejtag_db parse_bsdl_file $handle “device.bsd”

Table 5-40: Arguments for Subcommand ::chipscope::csejtag_db parse_bsdl_file

Argument Type Description

handle
Required

Handle to the session that is returned by 
::chipscope::csejtag_session create.

filename Filename of local BSDL file.
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CseJtag Tcl Example
The ChipScope Pro 10.1 installation includes an example Tcl script that uses the CseJtag Tcl 
interface. This example opens a Xilinx Parallel cable or Xilinx Platform USB cable and 
scans the JTAG chain and returns information about the devices found in the chain. The 
example script is located in the following location:

• On 32-bit Windows operating systems

♦ <CHIPSCOPE_INSTALL>\bin\nt\csejtag_example1.tcl 

• On 64-bit Windows operating systems

♦ <CHIPSCOPE_INSTALL>\bin\nt64\csejtag_example1.tcl 

• On 32-bit Linux operating systems

♦ <CHIPSCOPE_INSTALL>/bin/lin/csejtag_example1.tcl 

• On 64-bit Linux operating systems

♦ <CHIPSCOPE_INSTALL>/bin/lin64/csejtag_example1.tcl 

The script can be run in the Tcl shell (xtclsh) that is included with ISE software or in the 
ActiveTcl 8.4 Tcl shell from ActiveState Software Inc. (http://www.activestate.com). To 
run the tcl example in a command line shell, change to the directory where 
csejtag_example1.tcl is located (see above). Next, follow these instructions for the 
particular operating system:

• On 32-bit and 64-bit Windows operating systems:

♦ To use a Xilinx Parallel Cable, type:

cs_xtclsh.bat csejtag_example1.tcl

♦ To use a Xilinx Platform Cable USB, type:

cs_xtclsh.bat csejtag_example1.tcl -usb

• On 32-bit and 64-bit Linux operating systems:

♦ To use a Xilinx Parallel Cable, type:

cs_xtclsh.sh csejtag_example1.tcl

♦ To use a Xilinx Platform Cable USB, type:

cs_xtclsh.sh csejtag_example1.tcl -usb 
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