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Examine and Debug the Design

Change the Signal Color

ISim lets you change the signal color in the Wave window to help distinguish similar 
signals from each other.

To change the color of the drp_multiply and drp_divide signals.

1. In the Wave window, right-click a signal name in the Name column.

2. Select Signal Color, and pick a color from the color palette or a custom color by 
clicking the Browse button, (see Figure 3-21).

Note: You can also use the Divider Color option to change the color of the dividers you created in 
the Wave window.

Float the Wave Window 
Depending upon your screen resolution, you might notice that the Wave window is 
populated with more signals than the interface can show at one time. To increase the 
viewable area, you can float the Wave window. This opens a new window with just the 
Waveform contents.

To float a window, click the Float Window button  on the main toolbar.

You are done making modifications to the Wave window. The Wave window should look 
similar to Figure 3-22 when test bench groups are expanded.

X-Ref Target - Figure 3-21

Figure 3-21: Changing the Signal Color
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Save the Wave Window Configuration
You can save the current Wave Window configuration so it is available for use in future 
ISim simulation sessions of your design.

To save the Wave configuration:

1. Select File > Save As to assign a name to the current Wave configuration.

2. Save the current Wave configuration to the filename tutorial_1.wcfg.

The Wave configuration is now saved for future use.

Note: You can load the saved Wave window configuration using the menu command File > Open.

Re-Simulate the Design
You are ready to simulate the design again with the updated Wave configuration. Click the 
Run All button  to re-run the simulation.

Note: You can also re-run the simulation by typing run all at the Tcl prompt.

The simulation runs for about 13 microseconds.

After the simulation is complete, click the Zoom to Full View button  to zoom to full 
view.

The Wave configuration should look similar to Figure 3-23.

X-Ref Target - Figure 3-22

Figure 3-22: Fully Configured Floating Wave Window
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Use Markers
The self-checking test bench used in this design performs four different tests to show the 
functionality of the DCM Dynamic Reconfiguration feature. 

To use markers to mark each time a new test starts: 

1. In the Console panel, identify the simulation times when each test has started. For 
example, Test 1 starts at about 1,150 ns, as shown in Figure 3-24. 

2. From the ISim menu, select Edit > Go To and enter 1150 ns in the Go To Time field 
to move the main (yellow) cursor to the first test bench test.

X-Ref Target - Figure 3-23

Figure 3-23: Wave Window After 13 us Simulation Time

X-Ref Target - Figure 3-24

Figure 3-24: Console Window

X-Ref Target - Figure 3-25

Figure 3-25: Go To Time Field
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3. Click the Add Marker toolbar button.  

Note: Although you typed the time in nanoseconds, the Wave window displays the time unit in 
microseconds. You could have also typed the measurement in picoseconds. You can use 
whichever measurement you prefer, and the Wave window will adjust accordingly.

4. Search in the Console for the four tests performed by the test bench, and add a marker 
for each test start. The Wave window should look similar to Figure 3-26.

X-Ref Target - Figure 3-26

Figure 3-26: Using Markers to Identify Start of Tests
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Use Cursors
The Console Panel reports that Test 2 and Test 4 failed, as shown in Figure 3-27. 

In Test 2 and Test 4, a Dynamic Reconfiguration (DRP) write cycle is performed to change 
the multiply and divide factors of the Digital Frequency Synthesizer, and to set new clock 
output (CLKFX) frequencies (120 MHz and 400 MHz, respectively). 

However, at the end of the DRP cycle, the test bench measured a period that did not match 
the expected period. Test 2 and Test 4 failed due to the period discrepancy. You can view 
the failure for Test 2 in Figure 3-28.

In the next steps, you use the ISim main cursor (yellow cursor) to zoom in the Wave 
window when one of the failing tests takes place. You also use the cursor to measure the 
period of signal dcm_clkfx_out and verify that the test bench is making accurate 
measurements.

X-Ref Target - Figure 3-27

Figure 3-27: Console Report: Tests 2 and 4 Failed

X-Ref Target - Figure 3-28

Figure 3-28: Test 2 Fails Due To Period Discrepancy
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Zoom In
In the Wave window, zoom in to the start of Test 2 to review the status of output clock 
dcm_clkfx_out.

To use a cursor for zooming in on a specific area:

1. Place the cursor on the area by clicking and dragging the main (yellow) cursor close to 
the marker that represents the start of Test 2 (marker at time 3.461664 μs). The cursor 
snaps onto the marker.

Note: You can also click the Previous Marker  and Next Marker  toolbar buttons to 
quickly move the main cursor from marker to marker.

2. Zoom in using the Zoom In button .

The Wave window zooms in around the area specified by the cursor. 

3. Repeat step 2 until you can clearly see the rising and falling edges of DCM test signals 
dcm_clk0_out and dcm_clkfx_out (see Figure 3-29). 

Measure Time
You can use your mouse cursor to measure time between two endpoints. You use this 
feature to confirm the test bench calculations reported in the Console during Test 2 by 
measuring the period of dcm_clkfx_out after the DRP cycle has completed (signal 
drp_done is asserted).

To measure time using cursors:

1. Use the Snap to Transition toggle button  to snap the cursor to transition edges.

2. Click and hold in an area around the first clock rising edge following DRP cycle 
completion (drp_done signal asserted). The main cursor snaps to the rising edge of 
dcm_clkfx_out.

X-Ref Target - Figure 3-29

Figure 3-29: Viewing dcm_clk0_out and dcm_clkfx_out
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3. While holding the button, move the mouse over to the next clock rising edge. 

A second marker appears.

The time between the two defined endpoints shows at the bottom of the Wave window 
as a time delta (see Figure 3-30).

The cursors show that a measured time difference of 7,142 ps is between two rising 
edges of the dcm_clkfx_out output clock. This translates to a 140 MHz clock signal. 
Test 2 fails due to the frequency discrepancy (expected is 120 MHz).

4. Analyze the Test 4 failure using the same steps. You can observe that while the test 
bench expects a frequency of 400 MHz, the actual frequency measured is 300 MHz.

Note: You can use the Floating Ruler  feature (available from the Wave window toolbar) to 
display a hovering ruler over the Wave configuration. This feature is available when performing a time 
measurement using cursors between two endpoints. The zero (0 ps) on the ruler is placed at the first 
time endpoint. This feature is useful when making multiple time measurements with respect to the 
first endpoint.

Use Multiple Wave Configurations
Depending on the resolution of the screen, a single Wave window might not display all the 
signals of interest at the same time. You can open multiple Wave windows, each with their 
own set of signals and signal properties.

To open a new Wave window:

1. In ISim, select File > New. 

2. In the New dialog box, select Wave Configuration, and click OK.

A blank Wave configuration opens.

You can move dividers, groups, and simulation objects to the new Wave configuration. 

X-Ref Target - Figure 3-30

Figure 3-30: Measuring Time in the Wave Window
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To move the simulation objects associated with the DCM and DRP Controller units to a 
new Wave window:

1. Press and hold the Ctrl key, and highlight objects (dividers, groups, and so on) you 
want to move to the new Wave window.

2. Right-click any selected signals, and select Cut.

Note: Although you are moving signals from one Wave Configuration to another for this tutorial, 
you can also use the Copy command to copy the signals so that they remain in both windows.

You could also select the signals and drag them to the new Wave configuration 
window.

3. Click the window panel for the new Wave configuration.

4. Right-click in the Name column area of the Wave configuration, and select Paste.

5. Select File > Save As to save this Wave configuration as tutorial_2.wcfg.

You should now have two Wave windows that look similar to Figure 3-31 and Figure 3-32, 
page 43.

X-Ref Target - Figure 3-31

Figure 3-31: tutorial_1.wcfg 
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Debug the Design
You examined the design using markers, cursors, and multiple Wave configurations. 

Now, use ISim debugging features, such as setting breakpoints and stepping through 
source code, to debug the design and address the two failing DRP tests. 

View Source Code
First, look at the test bench for the tutorial design and learn how each test is performed.

Do one of the following to open the source code for the tutorial design test bench 
(drp_demo_tb.vhd). The source file opens using the integrated text editor (See 
Figure 3-33, page 44).

• Select File > Open to point to the file of choice.

• In the Instances and Processes panel, right-click on the design unit described by the 
source file of interest, then select Go to Source Code.

• In the Objects panel, right-click on any of the simulation objects declared in the source 
file of choice, then select Go to Source Code.

• In the Source Files panel (viewable by clicking the Source Files panel), double-click a 
source file.

X-Ref Target - Figure 3-32

Figure 3-32: tutorial_2.wcfg 
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Use Breakpoints and Stepping
A breakpoint is a user-determined stopping point in the source code used for debugging 
the design. When simulating a design with set breakpoints, simulation of the design stops 
at each breakpoint to verify the design behavior. After the simulation stops, an indicator 
shows in the text editor next to the line of source code where the breakpoint was set, so you 
can compare the Wave window results with a particular event in the source code.

Another useful ISim debugging tool is the Stepping feature. With stepping, you can run the 
simulator one simulation unit at the time. This is helpful if you are interested in learning 
how each line of your source code affects the results in simulation.

You next use both of these debugging features to learn how the DRP cycle is performed 
during Test 2 to debug the failing test.

Set Breakpoints

Begin by setting a breakpoint around the first signal assignment performed during each of 
the DRP cycle tests.

To set a breakpoint at line 185 in drp_demo_tb.vhd: 

1. Open the source code in which you want to add the breakpoint.

2. Go to an executable line in the source code.

X-Ref Target - Figure 3-33

Figure 3-33: Integrated Text Editor
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3. Right-click anywhere on the executable line and select Toggle Breakpoint to add the 
breakpoint (see Figure 3-38).

Note: You can also add a breakpoint by clicking the Toggle Breakpoint button .

Setting a breakpoint causes the simulator to stop every time the signal drp_multiply 
is assigned a value.

You can manage breakpoints by clicking on the Breakpoints panel, located next to the 
Console panel. All breakpoints appear in this list. From here, you can:

• Delete a selected breakpoint or all breakpoints

• Go to the line of source code for a selected breakpoint, see Figure 3-35. 

Re-Run the Simulation with the Breakpoint Enabled
Next, re-run the simulation with the breakpoint enabled.

Debugging with the breakpoints and stepping features work best when you are able to 
review the console output and the Wave window at the same time. 

Use the Float feature of the ISim panels, or resize the windows of the simulator, to best 
accommodate the windows so they can be viewed at the same time.

1. Click the Restart button  to restart the simulation.

2. To run the simulation, click the Run All button.  

The simulation runs near the start of the first test.

Focus changes to the text editor where it shows the yellow indicator ( ) at the last line of 
source code the simulator executed (see Figure 3-36). 
.

Additionally, a message displays in the Console to indicate that the simulator has 
stopped, including the line of source code last executed by the simulator.

X-Ref Target - Figure 3-34

Figure 3-34: Setting a Breakpoint at Line 185 in drp_demo_tb.vhd

X-Ref Target - Figure 3-35

Figure 3-35: Breakpoints Panel and Right-Click Menu Options

X-Ref Target - Figure 3-36

Figure 3-36: The Last Line of Executed Source Code

http://www.xilinx.com


46 www.xilinx.com ISim In-Depth Tutorial
UG682 (v14.3) October 16, 2012

Chapter 3: Using the ISim GUI and Debugging the Design

Test 1 finished successfully based on the earlier design examination. Skip debugging 
this test.

3. Continue to Test 2, and click the Run All button. 

The simulation now stops at the start of Test 2, shown in Figure 3-37. 

Step Through Source Code
You first need to verify that in Test 2, the appropriate Multiplier and Divider parameters 
are being set correctly using the drp_multiply and drp_divide bus signals. Use 
Stepping to step through the source code line-by-line, and review how the drp_multiply 
and drp_divide bus signals are assigned to the DCM DRP ports.

To step through a simulation:

1. Click the Step toolbar button. 

Note: You can also step through the simulation by typing step at the Tcl prompt.

2. Use this process to step through the design, paying attention to each of these events:

• drp_multiply and drp_divide bus signals are assigned values from a 
constant test_vectors.

• drp_start asserts to start a DRP cycle.

• drp_multiply bus signal is assigned to the 8 uppermost bits of bus signal 
DI_IN, while drp_divide bus signal is assigned to the 8 lowermost bits of the 
same bus.

• The DRP controller (drp_stmach.vhd) leaves idle mode and moves to the next 
DRP cycle step, clearing the DCM status registers.

3. In the tutorial_2 Wave window, expand the DCM Inputs bus.

4. Continue stepping through the simulation until the di_in bus signal is updated with 
a new value (you might need to zoom in to observe the change). At around 3,465 ns, 
the bus should be updated from 0203h to 0604h (see Figure 3-38).

X-Ref Target - Figure 3-37

Figure 3-37: Message in the Console Indicating That the Simulator Has Stopped
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Note: Change the radix of bus signal di_in to Hexadecimal to verify this value change.

The output clock frequency of this design (dcm_clkfx_out) depends upon the 
multiply and divide factors you provide. For Test 2, use the following parameters and 
expected output clock frequency:

Recall that for M=6 and D=5, di_in[15:0] bus value should be 0504h. Notice that 
the status of di_in in Test 2 is 0604h. Test 2 fails because an incorrect M/D factor is 
provided in the test bench drp_multiply and drp_divide signals.

5. Repeat the steps above to determine the cause of failure for Test 4. You can determine 
that the failure is also due to incorrect assignments of the multiply and divide signals 
in the test bench. 

X-Ref Target - Figure 3-38

Figure 3-38: Wave Window: Analyzing Output of DCM DI_IN Input Bus 

Table 3-1:  Parameters and Expected Output Clock Frequency

Test Freq. (MHz) Period (ps) Multiplier (M) Divider (D)

2 120 8,332 6 5
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Fix Design Bugs
By using breakpoints and stepping, you have determined that the incorrect multiply and 
divide values are assigned to the test bench drp_multiply and drp_divide signals.

In the next steps, revise the test bench test vectors to use the correct Multiplier and Divider 
parameters in Test 2 and Test 4.

1. In the ISim main menu, click the Source Files panel.

2. Right-click the drp_demo_tb.vhd file, and select Go To Source Code.

3. In lines 117 through 127, the test vectors for the four DRP tests are defined. Revise the 
constant declaration to the following displayed values (changes are highlighted in 
bold).

    ------------------------------------------------
    -- ** TEST VECTORS **
    --  (Test, Frequency, Period, Multiplier, Divider)
    ------------------------------------------------

constant test_vectors : vector_array := (
  
  ( 1, 75, 13332 ps, 3, 4),
  ( 2, 120, 8332 ps, 6, 5),
  ( 3, 250, 4000 ps, 5, 2),
  ( 4, 400, 2500 ps, 4, 1));

4. Save the file.

Verify Bug Fix
Now that you have corrected the test bench source code, you re-compile the source code 
and build a new simulation executable.

1. Click the Breakpoints panel and remove the previously-set breakpoint.

2. Click the Re-launch button  to re-launch ISim.

ISim recompiles the source files and reloads the simulation.

You are ready to simulate the design again with the updated test bench. 

3. Click the Run All button  to re-run the simulation.

Note: You can also re-run the simulation by typing run all at the Tcl prompt.

If the test vectors in the test bench were properly revised, the simulation should run to 
completion, showing that all tests pass (see Figure 3-39).
X-Ref Target - Figure 3-39

Figure 3-39: Console Showing That All Tests Pass
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Conclusion
This completes the ISE® ISim in-depth tutorial. In this tutorial, you:

• Ran ISim from either Project Navigator or in Standalone mode.

• In Project Navigator, you:

- Created a project

- Added source files to the project

- Created a VHDL library and moved files into the library

- Compiled the design within the project

- Launched Behavioral simulation after setting the properties for that 
simulation

- Reviewed the ISim GUI

- Debugged the design

- Verified the bug fix

• In the ISim Standalone, described in Chapter 4, Running ISim Standalone, you 
can do all the same steps using the command line mode.

See Appendix A, Additional Resources for links to more detailed information about ISim.
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Running ISim Standalone

You can use the ISim standalone flow to simulate your design without setting up a project 
in ISE® Project Navigator. In this flow, you:

• Prepare the simulation project by manually creating an ISim project file to create a 
simulation executable using the fuse command.

• Start the ISim Graphical User Interface (GUI) by running the simulation executable 
generated by the fuse command.

Getting Started
The tool requirements and location of tutorial design files are described in Chapter 1, Tool 
Requirements, and Chapter 1, Installing Tutorial Design Files.

Prepare the Simulation
The ISim standalone flow lets you simulate your design without setting up a project in ISE 
Project Navigator. In this flow, you manually create an ISim project file that the fuse 
command uses to create a simulation executable. Following completion of this step, you 
can launch the ISim GUI by running the simulation executable.

Manually Create an ISim Project File
The typical syntax for an ISim project file is as follows:

verilog|vhdl <library_name> {<file_name_1>.v|.vhd}

where:

• verilog|vhdl indicates that the source is a Verilog or VHDL file. Include either 
Verilog or VHDL source files.

• <library_name> indicates with which library a particular source on the given 
line to be compiled. The /work is the default library.

• <file_name> is the source file or files associated with the library. 

Note: While one or more Verilog source files can be specified on a given line, only one VHDL source 
can be specified on a given line.

To build an ISim project file for the tutorial design:

1. Browse to the script folder.

2. Open the simulate_isim.prj project file with a text editor.

The project file is incomplete. 
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3. List the missing sources using the syntax guidelines.

Missing sources:

• drp_dcm.vhd: VHDL source file. It must be compiled with the /work library.

• drp_tb_pkg.vhd: VHDL package file. It must be compiled with the 
/drp_tb_lib library.

Note: You do not need to list the sources based on their order of dependency. The fuse 
command automatically resolves the order of dependencies and processes the files in the 
appropriate order.

You can browse to the /completed folder of the tutorial files for a completed version 
of the project file for comparison.

4. Save and close the file.

Build the Simulation Executable
In this simulation step, the fuse command uses the project file created in the previous 
section to parse, compile, and link all the sources for the design. This creates a simulation 
executable that lets you to run the simulation in the ISim GUI.

Use the fuse Command 
The typical fuse syntax is as follows:

fuse –incremental –prj <project file> -o <simulation executable> 
<library.top_unit>

where:

• -incremental: requests fuse to compile only the files that have changed since 
the last compile

• -prj: specifies an ISim project file to use for input

• -o: specifies the name of the simulation executable output file

• <library.top_unit>: specifies the top design unit

Complete the following steps to parse, compile and elaborate the tutorial design using 
fuse:

1. Browse to the /scripts folder from the downloaded files.

2. Open the fuse_batch.batfile using a text editor.

3. This fuse command is incomplete. Using the syntax information provided above, edit 
the command line so it includes the following options:

a. Use incremental compilation.

b. Use simulate_isim.prj as the project file.

c. Use simulate_isim.exe as the simulation executable.

d. Use work.drp_demo_tb as the top design unit for simulation.

4. Save and close the batch file.

5. Using the ISE Command prompt, navigate to the /scripts folder and run the 
fuse_batch.bat file to run fuse.

Note: To open the ISE Command prompt, go to 
Start > Programs > Xilinx ISE Design Suite > Accessories and click the 
ISE Design Suite Command Prompt item.
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Result

After the fuse command completes compiling source code, elaborating design units, and 
linking the object code, a simulation executable (simulate_isim.exe) is available in the 
/scripts folder.

Browse to the /completed folder to see the completed version of the fuse batch file for 
comparison.

Manually Simulate the Design 
In this simulation step you launch the ISim GUI by running the simulation executable 
which was generated by the fuse command in the previous section, Build the Simulation 
Executable, page 52. After this step is complete, you will be able to use the ISim GUI to 
explore the design in more detail.

Run the Simulation Executable

The command syntax when launching the simulation executable is:

isim_exe –gui –view <wave_configuration_file> -wdb 
<waveform_database_file>

where:

• -gui: Launches ISim in GUI mode.

• -view: Opens the specified Waveform file in the ISim GUI.

• -wdb: Specifies the file name of the simulation database output file. 

Launch Simulation
To launch the simulation:

1. Browse to the /scripts folder from the downloaded files.

2. Open the simulate_isim.bat file using a text editor. The batch file is intentionally 
blank.

3. Using the syntax information provided above, edit the batch file so it includes the 
following settings:

a. Simulation Executable name: simulate_isim.exe.

b. Launch in GUI mode.

c. Set simulation database output name to simulate_isim.wdb.

Note: A Wave configuration file is not provided in the tutorial files. This file is created during 
simulation.

4. Save and close the file.

5. Using the ISE Command prompt, navigate to and run the simulate_isim.bat file 
to run the simulator.

Result
The ISim GUI opens and loads the design. The simulator time remains at 0 ns until you 
specify a run time.

For comparison purposes, you can browse to the /completed folder for a completed 
version of the simulate_isim.bat batch file.
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Appendix A

Additional Resources

Xilinx Resources 
This appendix provides links to Xilinx® documents referenced in this document:

• Xilinx Design Tools: Installation and Licensing Guide (UG798): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_3/iil.pdf 

• Xilinx Design Tool Release Notes Guide (UG631): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_3/irn.pdf 

• Xilinx Glossary: 
http://www.xilinx.com/support/documentation/sw_manuals/glossary

• Xilinx Documentation and Support: http://www.xilinx.com/support.htm

• ISE® Documents:
http://www.xilinx.com/support/documentation/dt_ise14-2.htm 

• Virtex-5 FPGA Users Guide, (UG190):
http://www.xilinx.com/support/documentation/user_guides/ug190.pdf 

• Writing Effective Testbenches, (XAPP199): 
http://www.xilinx.com/support/documentation/application_notes/xapp199.pdf 

• ISim User Guide (UG660): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_3/plugin_ism.pdf 

Tutorials Page - To find the ug682.zip design files and other ISE® Design Suite and the 
ISim Hardware Co-Simulation tutorial, see the Xilinx website:
http://www.xilinx.com/support/documentation/dt_ise14-3_tutorials.htm

http://www.xilinx.com/support/documentation/application_notes/xapp199.pdf
http://www.xilinx.com/support/documentation/dt_ise14-3_tutorials.htm 
http://www.xilinx.com
http://www.xilinx.com/support/documentation/dt_ise14-3.htm
http://www.xilinx.com/cgi-bin/docs/ndoc?l=en;t=user+guide;d=ug190.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;v=14.3;t=ise+docs;d=plugin_isim.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;v=14.3;t=install+guide;d=iil.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;v=14.3;t=install+guide;d=irn.pdf
http://www.xilinx.com/cgi-bin/docs/ndoc?l=en;t=glossary
http://www.xilinx.com/cgi-bin/docs/ndoc?l=en;t=support
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