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Profiling Applications and Create Accelerators 

Introduction 
Program hot-spots that are compute-intensive may be good candidates for hardware acceleration, 
especially when it is possible to stream data between hardware and the CPU and memory and overlap 
the computation with the communication. This lab guides you through the process of profiling an 
application, analyzing the results, identifying function(s) for hardware implementation, and then profiling 
again after targeting function(s) for acceleration. 

Objectives  

After completing this lab, you will be able to: 
 Use TCF profiler to profile a pure software application 
 Use TCF profiler to profile a software application that calls functions ported to hardware 
 Use manual profiling method by using sds_lib API and counters 

Procedure  

This lab is separated into steps that consist of general overview statements that provide information on 
the detailed instructions that follow. Follow these detailed instructions to progress through the lab. 

This lab comprises five primary steps: You will create an SDSoC project, profile the pure software project, 
accelerate one function and profile, profile using sds_lib API, and finally add another function to 
accelerators and profile.  

General Flow for this Lab 
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Create an SDSoC Project Step 1 

1-1. Launch SDSoC and create a project, called lab3, using the Empty 
Application template and then using the provided source files, targeting the 
Zed or Zybo board. 

1-1-1. Open SDSoC, and select c:\xup\SDSoC\labs as the workspace and click OK. 

1-1-2. Create a new project called lab3, and select either zybo or zed  

1-1-3. Select Standalone as the target OS, and click Next. 

1-1-4. Select Empty Application and click Finish.  

Note that the lab3 > src folder is empty. 

1-2. Import the provided source files from the source\lab3\src folder. Create an 
SDDebug configuration and build the project. 

1-2-1. Right click on src under lab3 in the Project Explorer tab and select Import… 

1-2-2. Click on File System under General category and then click Next. 

 

Figure 1. Selecting import source location 

1-2-3. For the From Directory, click on the Browse button and browse to c:\xup\SDSoC\source\lab3\src 
folder and click OK. 

1-2-4. Either select all the files in the right-side window or select src checkbox in the left-side window 
and click Finish to import the files into the project. 

The files will be copied into the src folder under lab3 folder. This can be verified by expanding the 
src folder in the Project Explorer tab and also by using Windows Explorer. 
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Figure 2. Selecting path and files to be imported 

1-2-5. Select Build Configurations > Set Active > SDDebug  

1-2-6. Right-click on lab3 and select Build Project 

This should only may take about one minute as it is a pure software compilation. 

Profile the Application Step 2 

2-1. Connect the board in the JTAG mode and power it ON. Start the Debug 
session. Add the TCF Profiler view and configure it to include the 
Aggregate per Function option. 

2-1-1. Connect the board in the JTAG mode and power it ON. 

2-1-2. Click on the Debug Application link under the Actions window in the lab3 tab on the right-side. 

 

Figure 3. Executing Debug Application action 

A Confirm Perspective Switch window will appear asking you to switch to the Debug perspective. 
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Figure 4. Perspective Switch dialog window 

2-1-3. Click Yes to open the debug perspective. 

The debug perspective will open showing various views: threads, variables, 
SDSoC_lab_design_main.c source program, Outline tab showing various objects created in the 
source program, and the console.  

Notice that the program is suspended at the main() entry on line 68. 

 

Figure 5. The Debug perspective 

2-1-4. Select Window > Show View > Other and then expand the Debug folder. 

2-1-5. Select TCF Profiler and click OK. 
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The TCF Profiler tab will open in the same window where Outline view was open. 

2-1-6. In the TCF Profiler view, click the start button. 

 

Figure 6. Opening the TCF Profiler configuration 

The Profiler Configuration window will open. 

2-1-7. Select the Enable stack tracing option and click OK. 

The Aggregate per function option will collect the same function calls be collected together. 

The Enable stack tracking option implements thread stack back tracing—essentially a summary 
of how the program execution gets to where it is when sampled. This allows the determination of 
parent/child relationships. 

The Max stack frames count field sets the number of frames to count backwards. This option is 
useful only if the Enable stack tracing is enabled. 

The View update interval (msec) field indicates at what interval the profile data will be updated in 
the TCF Profiler window. 

 

Figure 7. Selecting the options 

2-1-8. Click OK. 

2-2. Run the application for about 2 minutes, then suspend, and analyze the 
data. 

2-2-1. Click on the Resume button ( ) on the tool buttons bar or Press F8 to start the execution. 

2-2-2. Wait for about two minutes and/or when about 3200 samples are collected as indicated in the 

TCF Profiler’s view and click the Suspend button ( ). 

Note that the number of collected samples may vary depending on your PC’s performance and 
connection speed with the board. 
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Figure 8. The TCF Profiler view showing the collected number of samples  

2-2-3. Click on the Maximize view button ( ). 

Note that it shows three sections. The top-section shows various calls made after the execution 
started. The first function called is _start. In the Called From sub-window, nothing is listed as it 
the root function. In the Child Calls window, it shows main as the function being called from 
_start. 

 

(a) Zed 
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(b) Zybo 

Figure 9. The TCF Profiler result 

Address is the location of the function in memory that will match what is shown in the 
Disassembly view. 

% Exclusive is the percentage of samples encountered by the profiler for that function only 
(excluding samples of any child functions). This can also be seen as exclusive percentage for that 
particular function. 

% Inclusive is the percentage of samples of a function, including samples collected during 
execution of any child functions. 

Function is the name of the function being sampled. 

File is the name of the file containing the function. 

Line indicates the line number where the function is found in the source file. 



Profiling Applications and Create Accelerators Lab Workbook 
 

Zynq 3-8 www.xilinx.com/university  
 xup@xilinx.com 
 © copyright 2015 Xilinx 

2-2-4. Note that _start and main functions are 100% under the %inclusive column as all other functions 
are called from main. They are essentially 0% under the %exclusive column as a negligible time 
spent in those functions. Also note that _exit function is not listed since we did not profile to the 
completion (it would have taken about 10 minutes). 

2-2-5. Looking under the %inclusive column, notice that the CPU spent about 50% of its time executing 
the sharpen_filter function and its sub-functions. 

2-2-6. Click on the sharpen_filter entry to see that the source code window shows up. 

You can view the source code and see that it processes some data and calls several functions. 

2-2-7. Switch back to the TCF Profile result window and observe that the sharpen_filter function calls 
sharpen_operator, window_shift_right, linebuffer_shift_up, linebuffer_getval, and window_insert 
functions.  

The same Child Calls window shows how much time the CPU spent in each of those functions. 

 

(a) Zed 
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(b) Zybo 

Figure 10. Child Calls from sharpen_filter function 

2-2-8. Also note that window_shift_right, linebuffer_shift_up, linebuffer_getval, and window_insert 
appear multiple times. This is because they are called from different places. Click on any of these 
entries and notice that it only has a Called From entry and not a Child Calls indicating that these 
functions do not have any sub-functions, or they are leaf functions. 

2-2-9. Looking at the results sorted in the %inclusive column, we can see that sharpen_filter may be a 
good candidate for the hardware acceleration. The function and sub-functions should be carefully 
considered to determine suitability for acceleration. Typical candidates for acceleration are 
functions that can process a stream of data, or can be implemented in parallel, without excessive 
resource utilization. 

2-2-10. Click on the %Exclusive column to sort the results. 

You can see that the CPU spends a large proportion of the total time in the sharpen_operator 
function. This may be a good candidate for acceleration. 

2-2-11. Click on the Disconnect button ( ) to terminate the session. 

Accelerate sharpen_filter and Profile Step 3 

3-1. Add sharpen_filter function for hardware acceleration. Change SDSCC 
compiler setting to define TIME_SHARPEN symbol. Build the project and 
analyze the data motion network. 

3-1-1. Switch back to the SDSoC perspective. 
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3-1-2. Click on the “+” sign in the Hardware Functions area to open up the list of functions which are in 
the source files. 

3-1-3. Select sharpen_filter function and click OK. 

3-1-4. Double-click the SDSoC_lab_design_main.c under lab3 > src. 

3-1-5. Note several conditional compilation statements around lines 83 to 103.  

3-1-6. Right click on lab3 in the Project Explorer window and select C/C++ Build Settings. 

3-1-7. Select Symbols under SDSCC Compiler and click “+” button to define a symbol. 

3-1-8. Enter TIME_SHARPEN in the field and click OK. 

3-1-9. Click OK again. 

 

Figure 11. Defining symbol for conditional compilation 

3-2. Build the project and analyze the data motion network. 

3-2-1. Right-click the top-level folder for the project and click on Clean Project in the menu. 

3-2-2. Right-click the top-level folder for the project and click on Build Project in the menu. 

This may take about 20 minutes. 
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3-2-3. When build process is done, select the lab3 tab so you can access Data Motion link. 

3-2-4. Click on the Data Motion report link and analyze the result. 

 

Figure 12. Data Motion network showing buffer_depth pragmas 

3-3. Open Vivado IPI design. 

3-3-1. Open Vivado by selecting Start > All Programs > Xilinx Design Tools > SDSoC 2015.4 > 
Vivado Design Suite > Vivado 2015.4  

3-3-2. Open the design by browsing to c:\xup\SDSoC\labs\lab3\SDDebug\_sds\p0\ipi and selecting 
either the zybo.xpr or zed.xpr. 

3-3-3. Click on Open Block Design in the Flow Navigator pane. The block design will open. Note 
various system blocks which connect to the Cortex-A9 processor (identified by ZYNQ in the 
diagram). 

3-3-4. Click on the show interface connections only ( ) button followed by click on the regenerate 

layout ( ) button. 

3-3-5. Follow through both input and output data paths of the sharpen_filter_0 instance and observe that 
they are connected to the S_AXI_HP0 port of PS7. 

 

Figure 13. Built design 

Notice that two data movers are used; one for input and another for output data. They both 
connect to S_AXI_HP0 of PS7 through the axi_interconnect_S_AXI_HP0 instance. The two data 
movers and the sharpen_filter_0_if instance can be configured by their S_AXI_LITE interfaces 
which are connected to the ps7 via the axi_interconnect_M_AXI_GP0 instance. 
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3-3-6. Close Vivado by selecting File > Exit. Do not save the block design. 

3-4. Connect the board and power it ON. Start the Debug session. Add the TCF 
Profiler view and configure it to include the Aggregate per Function option. 

3-4-1. Connect the board and power it ON. 

3-4-2. Click on the Debug Application link under the Actions window in the lab3 tab on the right-side. 

Notice that the Done LED on the board goes OFF and then goes back ON this time as the FPGA 
fabric gets configured using the built hardware design. 

3-4-3. Click Yes to open the debug perspective, if prompted. 

Notice that the program is suspended at the main() entry on line 75 (instead of 68 in Figure 5). 

If you scroll up into the main() function window, you will notice code is added on lines 63 to 69 
which declares _p0_sharpen_filter_0 function prototype. 

 

Figure 14. Function prototype for the accelerated function 

3-4-4. Add TCF Profiler view as before, and configure the TCF Profiler view to include the Aggregate 
per function option. 

3-5. Run the application for about 2 minutes, then suspend, and analyze the 
data. 

3-5-1. Press the Start button of the TCF Profiler. 

3-5-2. Click on the Resume button (Green box) on the tool buttons bar to start the execution. 

3-5-3. Wait for about two minutes and/or when about 3200 samples are collected as indicated in the 
TCF Profiler’s view and click the Suspend button (green oval). 

Note that the number of collected samples may vary depending on your PC’s performance and 
connection speed with the board. 

 

Figure 15. The TCF Profiler view showing the collected number of samples  

3-5-4. Click on the Maximize view button. 
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Figure 16. The TCF Profiler result (Zed) 

 

Figure 16. The TCF Profiler result (Zybo) 

Note that _start and main functions are 100% under the %inclusive column as all other functions 
are called from main. Now the CPU spent most of its time executing the sobel_filter function and 
its sub-functions and very small amount of time is spent on the _p0_sharpen_filter_0 call (the 
hardware accelerator). 

3-5-5. Click on the Resume button and wait for little longer (3 more minutes) and see that the application 
runs to the end and the profiling stops at around 8600 samples in case of Zed or 5600 samples in 
case of Zybo. 
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(a) Zed 

 

(b) Zybo 

Figure 17. Execution suspended at _exit 

3-5-6. Click on the Disconnect button ( ) to terminate the execution. 

Profiling Using sds_lib API Step 4 

4-1. Re-launch the application in the Debug perspective. Start the terminal 
session and run the application to the end. 

4-1-1. In the Debug view, right-click on the disconnected entry and select Relaunch. 

 

Figure 18. Re-launching the debugger 

4-1-2. Click on the SDK Terminal window and make a connection. 
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4-1-3. Click on the Resume button. 

4-1-4. You will see dots being displayed as the execution is continuing. You will also see progress is 
made in the TCF Profiler view. 

Wait for about five minutes to complete the execution and the result is displayed in the Terminal 
window. 

 

(a) Zed  

 

(b) Zybo  

Figure 19. The sharpen function profiling 

4-1-5. Click on the Disconnect button ( ). 

Add sobel_filter to Accelerators and Profile Step 5 

5-1. Add sobel_filter function for hardware acceleration. Change SDSCC 
compiler setting to define TIME_EDGE_DETECT symbol. Build the project. 

Since this will take time to build, you will import lab3a project from the 
source\lab3 folder and then profile the application. The precompiled project 
has the sobel_filter already added for hardware with the compiler setting 
added. 

5-1-1. Switch back to the SDSoC perspective.  

5-1-2. Select File > Import 

5-1-3. Double-click on Import Existing Projects into Workspace. 

5-1-4. In the Import Projects window, click on the Browse button of the Select archive file option, 
browse to c:\xup\SDSoC\source\lab3, select lab3a.zip and click Open. 
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Make sure that lab3a is checked in the Projects window. 

 

Figure 20. Importing an existing project in the workspace 

5-1-5. Click Finish. 

The project will be imported and the sobel_filter and sharpen_filter function entries will be 
displayed in the Hardware Functions window. 

5-1-6. Double-click on the project_sdsoc under lab3a to access the SDSoC Project Overview. 

5-1-7. Uncheck the Generate Bit Stream and Generate SD Card Image options. 

5-1-8. Click on the Debug Application link under the Actions section.  

5-1-9. Click Yes to switch to the debug perspective if prompted. 

5-1-10. Select Window > Show View > Other and then expand the Debug folder. Select TCF Profiler 
and click OK. 

5-1-11. In the TCF Profiler view, click the start button, select the Aggregate per function option and click 
OK. 

5-2. Start serial communication. Profile the complete application and observe 
the improvements. 

5-2-1. Select the Terminal tab and make serial communication. 

5-2-2. Click on the Resume button. 

5-2-3. You will see dots being displayed as the execution progresses. You will also see progress is 
made in the TCF Profiler view. 



Lab Workbook  Profiling Applications and Create Accelerators 
 

 www.xilinx.com/university Zynq 3-17 
 xup@xilinx.com 
 © copyright 2015 Xilinx 

The execution should complete in under a minute and the result is displayed in the Terminal 
window. 

 

(a) Zed 

 

(b) Zybo 

Figure 21. The sharpen and sobel filter functions profiling 

5-2-4. Switch to the TCF Profiler tab and see the results. 

Note that now CPU spends time in rgb_2_grap function. The _p0_sobel_filter_0 takes very little 
time and you don’t see the _p0_sharpen_filter_0 entry does not appear at all since it’s execution 
time is so short that the profiler does not see it. 
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Figure 22. Profiled data (Zed) 

 

Figure 22. Profiled data (Zybo) 

5-2-5. Click on the Disconnect button ( ) to terminate the execution. 

5-3. Profile the application without running the profiler and compare the result. 

5-3-1. In the Debug view, right-click on the disconnected entry and select Relaunch 

5-3-2. This time do not click on the start button of the TCF Profiler. 
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5-3-3. Click on the Resume button. 

5-3-4. You will see dots being displayed quickly as the execution is continuing.  

5-3-5. Notice the terminal output. 

 

(a) Zed 

 

(b) Zybo 

Figure 23. The terminal window output 

Compared to output with the profiler running, the execution takes significantly fewer cycles. 

5-3-6. Click on the Disconnect button ( ) to terminate the execution. 

5-3-7. Close SDSoc by selecting File > Exit 

5-3-8. Turn OFF the power to the board. 

Conclusion  

In this lab, you profiled a pure software application which consist of three major functions. You saw the 
amount of time those three functions took to execute. Then you ported one of the most time-consuming 
function into hardware and profiled again. You then ported second most time-consuming function into 
hardware and profiled again and observed the performance improvement. You used the TCF profiler and 
sds_lib API to collect the data. 

 

 


