AR# 11847

|

3.1i CORE Generator - IP Dual-Port Block Memory will not allow a minimal depth of 1 ("Illegal Decimal value for param <depth B>")

説明

Keywords: COREGen, IP4, dual, block, memory, depth

Urgency: Standard

General Description:
Using CORE Generator 3.1 IP Update 4, I create an IP "Dual-Port Block Memory" v3_2 with the following parameters:

Port A:
Width = 4
Depth = 8
Read Only

Port B:
Width = 32
Depth =1
Write Only

When I generate the IP, an error reports: "Illegal Decimal value for param <depth B>".

ソリューション

The block memory depth of 1 is not allowed for this core -- all depths must be 2 or greater. There is a bug in the customization GUI of the Dual-Port Block Memory core that allows users to select the illegal "1" width for Port B.

This problem has been fixed in Dual-Port Block Memory V4_0, which is available with 4.1i IP Update #1. IP Updates are available from:
http://www.xilinx.com/ipcenter/coregen/updates.htm
AR# 11847
日付 08/23/2002
ステータス アーカイブ
種類 一般
People Also Viewed