AR# 14770

|

3.7 FPGA Express - スタンドアロン バージョンのツールを使用しているとエラーが発生するが、ほかのバージョンまたは ISE に付属のバージョンでは問題がない

説明

キーワード : FPGA, Express, stand, alone, error, Verilog, スタンドアロン, エラー

重要度 : 標準

概要 :
スタンドアロン バージョンの FPGA Express で Verilog ソースをコンパイルしようとすると、エラーが発生します。このソースは ISE 付属の FPGA Express やほかのバージョンの FPGA Express を使用した場合はコンパイルできます。

ソリューション

この問題は、バージョン 3.6 と 3.7 間のデフォルト オプションが異なるために発生します。 FPGA Express 3.7 のデフォルト合成エンジンは、Presto Compiler で、FPGA Express 3.5 および 3.6 のデフォルト合成エンジンは HDLC です。 ISE でのでデフォルト合成エンジンは、バージョン 3.5、3.6、3.7 ともに HDLC です。

この合成エンジンをスタンドアロン バージョンの FPGA Express で設定するには、次の手順に従います。

1. [Synthesis] から [Options] をクリックします。
2. [Project] タブをクリックします。
3. [Compatible HDL Compiler - HDLC] を選択します。
4. 合成を行う前に必ず [Force Update] を選択します。
AR# 14770
日付 08/11/2003
ステータス アーカイブ
種類 一般
People Also Viewed