UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 16128

5.1i Floorplanner - NCF に幅が広いマルチプレクサが含まれていると、「ERROR:Pack:311/312 - Unable to resolve the conflicts between two or more collections...」というエラー メッセージが表示される

説明

キーワード : Floorplanner, write RPM to NCF, macro builder, NCF, MAP, error, pack, 311, 312, RPM を NCF へ書き込み, マクロ, エラー, パック

重要度 : 標準

概要 :
Floorplanner を使用して幅が広いマルチプレクサを含むデザイン (MUXF5、MUXF6、MUXF7、MUXF8 など) の NCF を生成すると、MAP で次のエラー メッセージが表示されます。

"ERROR:Pack:311 - Unable to resolve the conflicts between two or more collections of symbols which have restrictive placement or routing requirements. The two collections are:
A wide function starting with F8 mux "MUXF8"
The RPM "widemux"
The symbol MUXF6 symbol "MUXF7" (Output Signal = my_rpm/OMUXF7_wire) belongs to more than one collection, forcing the collections to be combined.

Failure 1: Unable to combine the following symbols into a single slice.
MUXF6 symbol "MUXF7" (Output Signal = my_rpm/OMUXF7_wire)
MUXF5 symbol "my_rpm/INST_MUXF5_L" (Output Signal = my_rpm/INST_MUXF5_L/O)
The symbols have incompatible RLOC attributes."

"ERROR:Pack:312 - The intersection of two collections of symbols which have restrictive placement or routing requirements encountered a problem. The two collections are:
1) A wide function starting with F8 mux "MUXF8". The use of the MUXF6, MUXF7 and MUXF8 symbols implies a particular physical layout of the slices within a CLB.
2) The RPM "widemux". Relationally Placed Macros (RPMs) have a predetermined physical shape.

The position of the slice containing
MUXF6 symbol "MUXF8" (Output Signal = my_rpm/OMUXF8_wire) (RLOC=X3Y1, Set=widemux)
relative to the slice containing
MUXF6 symbol "MUXF7" (Output Signal = my_rpm/OMUXF7_wire) (RLOC=X2Y5, Set=widemux)
differs in the two collections."

ソリューション

この問題は、最新版の 5.1i サービス パックで修正されています。サービス パックは次のサイトから入手できます。
http://support.xilinx.co.jp/support/techsup/sw_updates
この修正は、5.1i サービス パック 3 以降に含まれます。
AR# 16128
日付 03/06/2005
ステータス アーカイブ
種類 一般
このページをブックマークに追加