UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 16166

6.1 EDK/EST/XPS - 使用しているプロセッサ システムが最上位のデザインでない場合にビヘイビア シミュレーションを実行する方法

説明

キーワード : Xilinx Platform Studio, XPS, simulation, behavioral simulation, ModelSim, MicroBlaze, Power PC, PowerPC, PPC, シミュレーション, ビヘイビア シミュレーション

重要度 : 標準

概要 :
エンベデッド開発キット (EDK) を使用してプロセッサ システム (MicroBlaze または Virtex-II Pro Power PC) を設計し、FPGA システムのサブモジュールとして使用しています。 つまり、使用しているプロセッサ システムは最上位のデザインではありません。 この場合、ModelSim でどのようにビヘイビア シミュレーションを実行したらよいですか。

ソリューション

最上位の HDL デザインでサブモジュールとしてインスタンシエートされたプロセッサでビヘイビア シミュレーションを実行するには次の手順にしたがってください。

XPS の実行前に 『Getting Started with the EDK』 にしたがいシミュレーション モデル ライブラリを設定します。『Getting Started with the EDK』 は、http://support.xilinx.co.jp/ise/embedded/edk_docs.htm から参照できます。 ライブラリ ファイルはデフォルト以外の場所に指定できるため指定したパスを忘れないようにしてください。 ModelSim XE を使用している場合は、nodebug ライブラリを使用するため ModelSim PE または SE のどちらかにアップグレードする必要があります。 ModelSim XE では、タイミング シミュレーションまたは構造シミュレーションのみしか実行できません。

XPS の場合
1. [Options] → [Project Options] をクリック。 シミュレーション ライブラリのパスを設定します。 ビヘイビア ライブラリは、『Getting Started with the EDK』の手順では、vmap_edk_libs でコンパイルされた場所に保存されています。 UniSim/SimPrim のライブラリは、Compxlib でコンパイルされた場所にあります。

例 :
ビヘイビア シミュレーション : C:EDKedk_nd_libs
SimPrim : C:xilinxsimprim
UniSim : C:xilinxunisim

2. Platform Studio ではこのシミュレーション フローがサポートされないため、最適なファイルを作成するためには、設定してから、もう 1 度設定し直す必要のあるオプションがあります。

MicroBlaze が 最上位ではない場合も、[Options] → [Project Options] を選択し、[Hierarchy and Flow] タブを選択します。 次に、[This is the top level of my design] をオンにします。

3. [Tools] -> [Sim Model Generation] を選択します。

4. [Hierarchy and Flow] タブでプロジェクトのオプションを変更し、[This is a sub-module of my design] を表示させ、使用しているプロセッサ システムの最上位のインスタンス名を入力します。

5. [Tools] → [Generate Netlist] を選択し、ネットリストを生成します。

6. [Tools] → [Export to ProjNav] を選択し、Project Navigator に出力します。

ISE の場合
1. XPS で生成された NPL ファイルを開きます。

メモ : 作業中の VHD ファイルを別のディレクトリにコピーします。これで、XPS から再び出力した場合にファイルが誤って上書きされてしまうことから回避できます。 これは、XSP で生成した system_stub.vhd ファイルを修正する場合、特に重要となります。 また、このファイルの名前を変更しておいてください。これで、他のファイルが上書きされた場合もファイルは上書きされません。これはsystem.vhd をインスタンシエートする最上位のラッパ ファイルです。

2. 最上位システムのテストベンチを作成します。

3. テストベンチには、system_init.vhd ファイルで ブロック RAM メモリの初期化文字列をロードするコンフィギュレーション ステートメントを追加します。 このステートメントをテストベンチの最後の END の後に追加します。 この命令が、内部メモリでどのように処理されるかが決定されるため非常に重要な作業となります。 このステートメントは、テストベンチから BRAM までの階層と完全に一致させる必要があるため注意してください。

次の例は、これらのアーキテクチャ、エンティティ、コンフィギュレーション名が含まれたシステムのステートメントです。 このステートメントは、使用しているテストベンチ名、システムのインスタンス名、LMB BRAM のインスタンス名、インプリメンテーション名、および階層の深さと一致させる必要のある場合もあります。

例 :
configuration testbench_conf of testbench is -- configuration <configuration name> of <testbench entity name>
for behavior -- Testbench architecture
for uut : system_stub -- Testbench instance name : system entity name
for IMP -- System architecture
for mb_sys : system -- Processor system instance name : entity name
for IMP -- Processor System Architecture
for all : bram1_wrapper use configuration work.bram1_conf; -- change "bram1" to the name of the BRAM needing initialization
end for;
end for;
end for;
end for;
end for;
end for;
end testbench_conf;

4. ModelSim で実行する新しい Custom Do ファイルを生成します。または、SimGen で生成されたシミュレーション ディレクトリの system.do ファイル を修正します。
a.<system>.do ファイルを修正する場合、SimGen および Clean の実行中にこのファイルを上書きまたは削除しないように別のディレクトリに保存することをお薦めします。
b.新規ファイルを生成する場合も、同じような理由から simulation ディレクトリ以外の場所に保存することをお薦めします。 DO ファイルを生成する場合、/simulation/system_init.do からのコマンドが DO ファイルの実行前に実行されるようにしてください。 この場合、DO ファイルの最初の行に do system_init.do を追加してください。

5. DO ファイルに次を追加します。必要な場合は、ファイルのパスを修正します。

vcom -93 -work work ../hdl/system.vhd # In hdl directory
vcom -93 -work work ./system_init.vhd # In simulation directory
vcom -93 -work work ../<top_level>.vhd # wherever you created it
vcom -93 -work work ./<testbench_name>.vhd # wherever you created it

vsim -t ps +notimingchecks work.testbench_conf


6. 上記の手順 5 と同様の VCom コマンドを使用してコンパイルの必要な他のファイルまたはライブラリのコマンドを system.do ファイルに追加します。

7. Modelsim のコンソール ウィンドウから DO ファイルを実行するか、次の手順にしたがってください。

8. [Source] ウィンドウで、<testbench_name>.vhd ファイルを選択します。

9. [Simulate Behavioral VHDL Model] で右クリックし、[プロパティ] を選択します。

10. Custom Do File を作業ディレクトリの System.do に設定します。

11. [Use Automatic Do File] のチェックボックスをオフにします。

12. [OK] をクリックします。

13. [Simulate Behavioral VHDL Model] をダブルクリックし、シミュレーションを実行します。
AR# 16166
日付 03/05/2006
ステータス アーカイブ
種類 一般
このページをブックマークに追加