UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 17156

3.2 EDK - ISE 5.2i サービス パック 1/サービス パック 2 のパッチ

説明

キーワード : XST, EDK, error, XPS, PlatGen, IP, エラー

重要度 : 重要

概要 :
ISE 5.2i サービス パック 1/サービス パック 2 で EDK 3.2 を起動する場合に、2 つの問題が確認されています。 次の IP で問題が発生します。

- IPIF インターフェイスを使用したメモリ コントローラ
- IPIF の DMA 部分を使用した IP

ISE 5.2i サービス パック 2 で EDK 3.2 を起動した場合、PlatGen で次のようなエラー メッセージが表示されます。

"ERROR:Xst:787 - c:/EDK32/hw/iplib/pcores/ipif_common_v1_00_a/hdl/vhdl/interrupt_control.vhd
line 423: Index value <8> is not in Range of array <interrupt_wrce>.

Platform Building failed
make: *** [implementation/system.ngc] Error 1"

ソリューション

EDK 3.2 を使用するには、ISE 5.2i サービス パック 1 (パッチを使用) または ISE 5.2i サービス パック 2 (パッチを使用) が必要です。

問題を解消するには、ISE 5.2i サービス パック 1 のインストールに次のパッチを使用してください。
http://www.xilinx.com/txpatches/pub/swhelp/ise5_updates/xst_patch_win_5201i.zip
http://www.xilinx.com/txpatches/pub/swhelp/ise5_updates/xst_patch_sol_5201i.tar.gz
http://www.xilinx.com/txpatches/pub/swhelp/ise5_updates/xst_patch_sol64_5201i.tar.gz

問題を解消するには、ISE 5.2i サービス パック 2 のインストールに次のパッチを使用してください。
http://www.xilinx.com/txpatches/pub/swhelp/ise5_updates/xst_patch_win_5202i.zip
http://www.xilinx.com/txpatches/pub/swhelp/ise5_updates/xst_patch_sol_5202i.tar.gz
http://www.xilinx.com/txpatches/pub/swhelp/ise5_updates/xst_patch_sol64_5202i.tar.gz

パッチをインストールするには、次のディレクトリ内でファイルを解凍してください。

Solaris の場合 : $XILINX/bin/sol
Solaris64 の場合 : $XILINX/bin/sol64
Windows の場合 : %XILINX%binnt

この問題は、最新版の 5.2i サービス パックで修正されています。次のサイトから入手してください。
http://support.xilinx.co.jp/xlnx/xil_sw_updates_home.jsp
この修正は、5.2i サービス パック 3 以降に含まれます。
AR# 17156
日付 04/28/2006
ステータス アーカイブ
種類 一般
このページをブックマークに追加