UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 19423

6.2 EDK - EDK デザインに ChipScope Pro Inserter を使用して ILA コアをインスタンシエートする方法

説明

キーワード : 6.1, BSCAN, component, コンポーネント, ChipScope ILA, プローブ, XPS

重要度 : 標準

概要 :
XPS 6.2 に ChipScope ILA コアが含まれていません。 ILA コアをインスタンシエートして内部信号をプローブするにはどうしたらよいですか。

ソリューション

ChipScope ILA コンポーネントは、EDK 6.3 から追加される予定です。

当面は、次の手順に従って EDK デザインに ILA コアをインスタンシエートしてください. このフローを使用するには、最新のサービス パックをインストールした EDK 6.2 および ChipScope Pro 6.2i が必要です。 EDK デザインで MDM デバッガ (Xilinx Answer 19412) または ChipScope コア (IBA または VIO など) を使用していない場合は、次の手順に従います。

1. XPS を使用して EDK デザインを作成します。
2. [Tools] -> [Generate Netlist] をクリックします。
3. XPS を閉じます。
4. コマンド ラインで <project_directory>/implementation ディレクトリに移動します。
5. 次のコマンドを実行します。
ngcbuild -i system.ngc system_all.ngc
このコマンドにより、EDK デザインの最上位とインスタンシエートされている IP がすべてリンクされ、1 つのネットリストが生成されます。
6. ChipScope Inserter 6.2i を起動します。
7. 「system_all.ngc」ファイルを入力ネットリストとして選択します。
ディレクトリが <project_directory>/implementation であることを確認します。
9. 次のサイトから『ChipScope Pro 6.2i User Manual』を参照して、クロック/トリガ/データを接続します。
http://www.xilinx.co.jp/literature/literature-chipscope.htm
10. [File] -> [Save As] をクリックしてプロジェクトを保存します。 これにより、ChipScope Pro Analyzer で必要な CDC ファイルが生成されます。
11. ChipScope Inserter を閉じます。
12. XPS を起動します。
13. [Tools] -> [Generate Bitstream] をクリックします。
14. FPGA Editor を起動して <project_directory>/implementation にある system.ncd を開きます.
15. [Tools] -> [ILA] をクリックし、ILA がデザインに正しくインプリメントされているかを確認します。 ILA コアが存在しないというメッセージが表示された場合は、List ウィンドウで U_icon_pro または U_ila_pro で始まるインスタンスがあるかどうかを確認してください。 これらのインスタンスがある場合は、ILA は正しくインプリメントされています。
16. ChipScope Pro Analyzer 6.2i を実行し (詳細はChipScope User Manual を参照) 、<project_directory>/implementation ディレクトリにある「system.bit」ファイルを使って FPGA をプログラムし、デザインをデバッグします。 ChipScope Inserter で以前保存しておいた CDC ファイルをインポートし、ユーザー信号名を回復させることもできます。

メモ : XPS で MHS ファイルを編集するたびに、NGCBuild をコマンド ラインで実行し (ngcbuild -i system.ngc system_all.ngc)、次に ChipScope Inserter を実行する必要があります。これは、XPS で「system.ngc」が上書きされてしまうためです。
AR# 19423
日付 04/10/2007
ステータス アーカイブ
種類 一般
このページをブックマークに追加