UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 19660

6.2i インストール - Red Hat Linux 9.0 にインストールすると LD_ASSUME_KERNEL を 2.4.7 に設定しない限り GLIBC_2.0 エラーが発生する

説明

キーワード : relocation, libwinsock44, libc.so.6, GLIBC, h_errno, インストール

重要度 : 標準

概要 :
Hat Linux 9.0 システムに 6.2i デザイン ツールをインストールすると、次のようなエラー メッセージが表示されます。

"/mnt/cdrom/xilxinfo: relocation error:
/mnt/cdrom/bin/lin/libwinsock44.so: symbol h_errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference"

ソリューション

Red Hat Linux 9.0 では、セットアップ プログラムの実行前に、次のように環境変数 LD_ASSUME_KERNEL を 2.4.7 に設定する必要があります。

in csh/tcsh, use 'setenv LD_ASSUME_KERNEL 2.4.7'
in sh/ksh, use 'export LD_ASSUME_KERNEL=2.4.
AR# 19660
日付 04/27/2006
ステータス アーカイブ
種類 一般
このページをブックマークに追加