UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 20882

6.3 EDK - サブモジュールとしてインプリメントし、ISE にエキスポートするとデザインが動作しない

説明

キーワード : 6.3, EDK, import, export, .XPS, ISE, bit, BMM, working, locate, submodule, toplevel, implement、インポート, エキスポート, ビット, サブモジュール, 最上位, インプリメント

重要度 : 標準

概要 :
XPS でデザインを作成し、デザイン全体のサブモジュールとして設定しました。 このデザインを ISE にエキスポートし、サブモジュールとしてインプリメントすると、動作しません。 同じデザインを最上位として設定し、XPS にインプリメントすると、ちゃんと動作します。

ソリューション

この問題を回避するには、EDK デザインをサブモジュールとしてインプリメントし、ISE にエキスポートする場合、次の手順に従ってください。

基本的なシステムの作成

1. Base System Builder を使用してデザインを作成し、ISE にエキスポートせずに XPS を使用して動作します。
2. ハイパ ターミナルに出力するだけの場合は、デフォルトのソース コードを使用します。

-- Entering main() --
-- Exiting main() --

3. Embedded Processor System が検証されるまで XPS を使用します。

サブモジュールの作成と ISE へのエキスポート

1. XPS で [Tools] -> [Clean] -> [All] とクリックします。

2. [Options] -> [Project Options] をクリックします。 [Hierarchy and Flow] タブをクリックし、次のように指定します。

- [Design Hierarchy] の下にある [This is a sub-module in my design] をクリックします。
- [Top Instance] フィールドに、最上位 HDL ファイルでのエンベデッド システムのインスタンシエーションに使用されたインスタンス名を入力します。
メモ : BMM ファイルの階層が ISE で正しく記述されて使用されるよう、インスタンス名はぴったり一致している必要があります。エンベデッド システムは、最上位 HDL ファイルでインスタンシエートする必要があります。
- ISE プロジェクトへのパスを指定します。 プロジェクト ディレクトリの ProjNav フォルダに新しい ISE デザインを作成するか、既存の ISE プロジェクトに追加できるよう指定します。 いずれの場合も手順は同じです。

3. [Tools] -> [Export to ProjNav] をクリックし、HDL および BMM ファイルを Project Navigator プロジェクトにエキスポートします。 新しい ISE デザインを作成している場合、これにより EDK プロジェクト ディレクトリに ISE プロジェクトと ProjNav フォルダが新たに作成されます。
4. ISE プロジェクトを開きます。 <xps_project_name>.vhd (システムの VHDL ファイル) と <xps_project_name>_stub.vhd (最上位デザイン ファイル、基本的には system.vhd のインスタンシエートされたテンプレート) という 2 つのソース ファイルが生成されます。

サブモジュールを作業中の ISE デザインにエキスポートすると、system.vhd ファイルがデザインに追加されて最上位デザインにインスタンシエートされます。

さらに、<xps_project_name>_stub.bmm ファイルが最上位の <xps_project_name>_stub.vhd ファイルに自動的に追加されます。

executable.elf および system.ucf ファイルを最上位の ISE モジュールに追加する必要があります。

メモ : executable.elf ファイルを ISE に追加する必要があるのは、ISE でデザイン フローすべてを実行し、XPS にデザインをインポートし直さない場合のみです。

5. デザインをインプリメントし、iMPACT を使用して生成された BIT ファイルをダウンロードします。

XPS へのインポート
1. ISE でデザインがうまく動作しており、デザインを XPS にインポートし直す場合は、[Tools] -> [Import from ProjNav] をクリックします。
2. [Browse] ボタンを使用し、ISE で生成された <xps_project_name>_stub_bd.bmm および BIT ファイルを選択します。 インポート機能により、これらのファイルが XPS プロジェクトにコピーされます。
3. ビットストリームをアップデートし、download.bit ファイルを生成するには、[Update Bitstream] をクリックして Data2MEM を実行します。
AR# 20882
日付 04/12/2007
ステータス アーカイブ
種類 一般
このページをブックマークに追加