UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 2161

4.2i Foundation Project Manager - ユーザーが作成したマクロを別のプロジェクトで使用する方法

説明

キーワード : macro, Foundation, schematic, user symbol, library, manager, copy, attach, マクロ, 回路図, ユーザー シンボル, ライブラリ, マネージャ, コピー

重要度 : 標準

概要 :
あるプロジェクトでユーザーが作成したマクロを別のプロジェクトで使用する方法

ソリューション

ユーザーが作成したマクロを別のプロジェクトで使用する場合、2 つの方法があります。

1. オリジナル プロジェクトの作業ライブラリから新しいプロジェクトの作業ライブラリにマクロをコピーするか、
2. 新しいプロジェクトにオリジナル プロジェクトの作業ディレクトリを追加します。 この場合、新しいプロジェクトとオリジナル プロジェクトでライブラリを共有します。

ライブラリからライブラリへマクロをコピーする場合 :

1. Project Manager で [File] -> [Project libraries] をクリックして [Library Manager] を選択し、Library Manager を開きます。
2. [Library Manager] ウィンドウでソース ライブラリ名をダブルクリックします。 [List Objects] ウィンドウが開きます。
3. コピーするマクロ名を選択します。
4. [Object] -> [Copy] をクリックします。 [Copy Object] ウィンドウが開きます。
5. [Destination Library] リスト ボックスでライブラリ名を選択し、[Copy] をクリックします。
6. [List Objects] ウィンドウで [Close] をクリックして Library Manager を閉じます。

メモ : HDL マクロをコピーする場合、オリジナル プロジェクトのディレクトリにあるソース ファイル (VHD または ABL) を新しいプロジェクトのディレクトリに手動でコピーする必要があります。

既存プロジェクトのライブラリを新しいプロジェクトに追加する場合 :

1. Project Manager で [File] -> [Project Libraries] をクリックします。 [Libraries] ウィンドウが開きます。
2. [Attached Libraries] リスト ボックスで追加するライブラリを選択します。
3. [Add>>] ボタンをクリックします。
4. [Close] をクリックして終了します。 新しいプロジェクトで、ほかのプロジェクトのコンポーネントが使用できるようになります。
AR# 2161
日付 08/12/2003
ステータス アーカイブ
タイプ 一般