UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 21785

8.1i ISE - Project Navigator プロジェクトを ISE 7 のフォーマットから ISE 8 のフォーマットに変換する方法

説明

キーワード : migration, convert, old, revision, version, software, 移行, 変換, 以前, リビジョン, バージョン, ソフトウェア, プロジェクト ファイル

重要度 : 標準

概要 :
Project Navigator プロジェクトを ISE 7 のフォーマットから ISE 8 のフォーマットに変換する方法を示します。

ソリューション

ISE 7 から ISE 8 への移行

ISE 7 プロジェクトを ISE 8 デザイン ツールで開くと、プロジェクトを変換するかどうかを確認するメッセージが表示されます。 [Yes] をクリックすると、ISE 7 プロジェクト ファイルが ISE 8 プロジェクト ファイルに変換されます。 [No] をクリックするとプロジェクトは変換されず、Project Navigator に読み込まれません。 変換プロセスの詳細を、次に示します。

メモ : プロジェクトを変換すると、以前のバージョンの ISE で開くことはできなくなりますが、 次に説明するように、変換プロセスの一部として元のプロジェクトのバックアップが作成されます。 これ以前のバージョンのプロジェクトの変換については、ISE ヘルプ (Project Navigator で [Help] -> [Help Topics] をクリック) を参照してください。

プロジェクトを変換するには

1. ISE 8 の Project Navigator で、[File] -> [Open Project] をクリックします。
2. [Open Project] ダイアログ ボックスで、変換する ISE ファイルを選択します。
3. 次に表示されるダイアログ ボックスで [Yes] をクリックします。

操作後の結果

ISE 7 のプロジェクトが ISE 8 のプロジェクトに変換されます。次の処理が実行されます。

- 変換するデザインを、project_name_ise7_back.zip という名前のアーカイブ ファイルにバックアップします。
- 新しいバージョンでは使用されないファイルを削除します。
- [Simulator] プロジェクト プロパティをアップデートします。 生成されるシミュレーション言語 ([Generated Simulation language] プロパティ) は、[Simulator] プロパティの一部として設定されます。

メモ : パフォーマンスを向上させるため、[Process Properties] ダイアログ ボックスの [Device Options] タブにある [Pipelining] オプション (Synplify Pro のみ) のデフォルト値はオンに変更されています。 ただし、プロジェクトの変換では以前の設定が保持され、 新しいデフォルト値は新規プロジェクトを作成する場合にのみ適用されます。



AR# 21785
日付 08/12/2011
ステータス アーカイブ
種類 一般
このページをブックマークに追加