AR# 24746

9.1i EDK - 1.5-17 より新しいバージョンの Cygwin を使用するとランタイムでエラーが発生する

説明

キーワード : make, bash, dos2unix, newline, return, character

EDK で使用できる Cygwin のバージョンはどれですか。

ソリューション

Cygwin バージョン 1.5-17 は EDK でテストされサポートされています。 これよりも新しいバージョンの Cygwin の make および bash 実行ファイルでは EDK でランタイム エラーが発生します。 これより以前のバージョンの Cygwin は EDK でテストされていません。

この問題を回避するには、次のいずれかの方法を試してください。

- EDK でインストールされる Cygwin よりも以前のバージョンの Cygwin を使用している場合は、DOS プロンプトに xbash -override コマンドを入力し、EDK でサポートされているバージョンの Cygwin を使用します。 このコマンドは一度だけ実行してください。 xbash -override の処理を元に戻すには、xbash -undo コマンドを実行します。

- EDK で インストールされる Cygwin よりも新しいバージョンの Cygwin を使用する必要がある場合は、新しい make.exe および bash.exe を EDK インストール ディレクトリにある同じファイルに置き換えてください。

次のアンサーは、この問題に関連しています。
(Xilinx Answer 24134)
(Xilinx Answer 23716)
(Xilinx Answer 24121)
AR# 24746
日付 07/17/2007
ステータス アクティブ
種類 一般