UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 30611

10.1 ISE - [Project] -> [Apply Project Properties] をクリックすると、「ERROR:ProjectMgmt:387 - TOE: ITclInterp::ExecuteCmd gave Tcl result 'Could not create the Tcl Wrapper component for IInterface」というエラー メッセージが表示される

説明

キーワード : code, hook, migrate, read only, コード, 移行. 読み取り専用

ISE ファイルを選択した後にプロジェクトのプロパティを適用すると、次のメッセージが表示されます。

"Apply Project Properties Failed.
The Tcl code hook did not run properly.
See the transcript window for details."

Transcript window output looks similar to the following:

ERROR:ProjectMgmt:387 - TOE: ITclInterp::ExecuteCmd gave Tcl result 'Could not create the Tcl Wrapper component for IInterface'.
Tcl_ErrnoId: unknown error
Tcl_ErrnoMsg: No error
_cmd: Xilinx::Dpm::dpm_chApplyProjectProperties {C:\Temp\flash\flash.ise} $piThisInterface
errorInfo: Could not create the Tcl Wrapper component for IInterface
while executing
"$_projectComponent GetInterface $::Xilinx::Dpm::IProjectID"
(procedure "Xilinx::Dpm::dpm_chApplyProjectProperties" line 27)
invoked from within
"Xilinx::Dpm::dpm_chApplyProjectProperties {C:\Temp\flash\flash.ise} $piThisInterface"

ソリューション

[Apply Project Properties] を実行する ISE ファイルが読み取り専用で ISE 9.2i などの以前のバージョンのときに、この問題が発生します。

この問題を回避するには、ISE ファイルのアクセス権を読み取りおよび書き込みを許可する必要があります。ただし、以前のバージョンの ISE ファイルからすべてのプロパティがアップデートされるように、現在のバージョンに移行させておく必要があります。(Xilinx Answer 20656) を参照してください。

この問題は 10.1 の最新のサービス パックで修正されています。
http://japan.xilinx.com/support/download/index.htm
この問題が修正されている最初のサービス パックは 10.1 サービス パック 1 です。

ISE 10.1.01 (10.1 サービス パック 1) の Project Navigator で [Apply Project Properties] を実行できるのは、ISE 10.x ".ise" ファイルのみです。

(Xilinx Answer 14626) を参照してください。
AR# 30611
日付 05/13/2010
ステータス アーカイブ
種類 一般
このページをブックマークに追加