AR# 34608

12.1 EDK - ソフトウェア アプリケーションを 11.x SDK から 12.1 SDK に移行する方法

説明

ソフトウェア アプリケーションを 11.x SDK から 12.1 SDK に移行するにはどうすればよいでしょうか。

ソリューション

SDK は Eclipse をベースにしています。Eclipse には作業中のプロジェクトの設定を含むワークスペースという概念があります。ワークスペースのバージョン間でプロジェクト設定を保持するのではなく、SDK 11.x のワークスペースからプロジェクトをインポートすることを推奨します。

SDK からのハードウェア プラットフォームの新規作成
XSP 12.1 で EDK デザインを開きます。
2.バージョン以降のためのウィザードを使用します。
3. 12.1 には新しいドライバがあります。この新しいドライバはハードウェア抽象レイヤに対し書かれていて、ファンクション コールが変更になっています。詳細は (ザイリンクス アンサー 35400) を参照してください。
4. XPS で [Project] -> [Export Hardware Design to SDK] をクリックします。
5. [Export & Launch SDK] ボタンを押します。

SDK で、デフォルト ディレクトリの SDK_Workspace_35 に新しいワークスペースが作成されます。

既存 BSP のインポート

SDK 12.1 では、ソフトウェア プラットフォームはボード サポート パッケージ (BSP) と呼ばれます。
1. [File] -> [Import] をクリックします。
2. [General] を展開表示させ、[Existing Projects into Workspace] を選択します。
3. 11.x のワークスペースに移動し、前のプロジェクトからソフトウェア プラットフォーム/BSP を検索し、[OK] をクリックします。
4. インポートするソフトウェア プラットフォーム プロジェクトを選択します。
5. [Copy Projects into Workspace] をオンにし、[Finish] をクリックします。
6. 新しくインポートした BSP を右クリックして、[Close Project] をクリックします。
7. もう一度 BSP を右クリックし、[Open Project] をクリックします。この 2 つのステップで Eclipse のバグを避けることができます。

BSP プロジェクトが正しくアップデートされていることを確認するには、BSP を右クリックし、[Board Support Package Settings] をクリックします。ダイアログ ボックスが正しく表示されることを確認します。表示されない場合は、BSP プロジェクトが正しくインポートされなかったことを示します。その場合は、SDK を使用して BSP を新規作成し、11.x からの設定を反映させるよう手動で BSP をアップデートします。

既存の C アプリケーション プロジェクトのインポート
1. [File] -> [Import] をクリックします。
2. [General] を展開表示させ、[Existing Projects into Workspace] を選択します。
3. 11.x のワークスペースに移動し、前のプロジェクトから C アプリケーション プロジェクトを検索し、[OK] をクリックします。
4. インポートするソフトウェア プラットフォーム プロジェクトを選択します。
5. [Copy Projects into Workspace] をオンにし、[Finish] をクリックします。
6. SDK で 3.0.0 フォーマットからのビルド設定を 4.0.0 フォーマットに移行させます。

11.x の C アプリケーション プロジェクトのインポート後にエラーが発生する場合は、[Project] -> [Clean] をクリックします。プロジェクトが自動的に再構築され、11.x と 12.x の間で一致しないデータ ファイルがクリーンアップされます。

アンサー レコード リファレンス

マスター アンサー レコード

Answer Number アンサータイトル 問題の発生したバージョン 修正バージョン
34609 EDK 12.x - アンサーのリスト N/A N/A
AR# 34608
日付 12/15/2012
ステータス アクティブ
種類 一般
ツール