UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 4587

Foundation F1.5 - Upgrading your Foundation Express license to 2.1.x

説明

Keywords: license, FPGA, Express, Foundation, FND-EXP, upgrade, license.dat

Urgency: Standard

General Description:
Foundation F1.5 includes a Xilinx-specific version of FPGA Express. The FPGA Express software is version 2.1.2, and is the only part of the Foundation 1.5 software that requires a license (except the HDL simulation tools).

In order to license Foundation Express, you need a valid license.dat from Xilinx. There are three categories into which users will fall:

1. Current User of Foundation Express 1.4.

2. Current User of Foundation synthesis (Metamor)

3. New User of Foundation or Foundation synthesis

If you are not able to open Foundation Express, please consult the Foundation Release Document that was shipped with the software. General licensing issues will not be covered in this solution.

If you are able to open Foundation Express and do not have a BASE license, but cannot access the Express Constraints Editor, then everything is working correctly, as Base licenses do not allow access to this feature.

ソリューション

1

For Current Users of Foundation Express 1.4:

If your license.dat contains FND-EXP-PC in the INCREMENT section, then you have an F1.4 license for Foundation Express. This allows you to access the Foundation Express tools, but a new feature has been added that allows access to the Virtex devices.

You will notice that the PACKAGE statement in your license looks similar to the PACKAGE statement below, but you do not have the "VIRTEX" line. To upgrade your license, replace your PACKAGE section with the following:

PACKAGE FND-EXP-PC xilinxd 1.000 2080B0F13916AA26C238 \
COMPONENTS="system-PC bit-PC \
xc3000D-PC xc4000X-PC xc5200X-PC \
ngd2vhdl-PC verilog-PC \
Foundation-PC X-VHDL-PC \
FPGA-Express:1998.08 \
FPGA-Express-VHDL-Base:1998.08 \
FPGA-Express-VLOG-Base:1998.08 \
FPGA-Express-XC3k-Optimizer:1998.08 \
FPGA-Express-XC4k-Optimizer:1998.08 \
FPGA-Express-XC5k-Optimizer:1998.08 \
FPGA-Express-VIRTEX-Optimizer:1998.08 \
FPGA-Express-XC9k-Optimizer:1998.08 \
FPGA-Express-Constraint-Mgr:1998.08 "

Since the INCREMENT line has not been modified, the hostid and expiration date will remain the same.

If your license.dat contains FND-BSX-PC, follow the same instructions as above, but use the following PACKAGE section:

PACKAGE FND-BSX-PC xilinxd 1.000 20B020D1BB28AF442953 \
COMPONENTS="system-PC bit-PC \
xc3000D-PC xc4000E-PC xc5200E-PC \
ngd2vhdl-PC verilog-PC \
Foundation-PC X-VHDL-PC \
FPGA-Express-RL2100:1998.08 \
FPGA-Express-VHDL-Base:1998.08 \
FPGA-Express-VLOG-Base:1998.08 \
FPGA-Express-XC3k-Optimizer:1998.08 \
FPGA-Express-XC4k-Optimizer:1998.08 \
FPGA-Express-XC5k-Optimizer:1998.08 \
FPGA-Express-VIRTEX-Optimizer:1998.08 \
FPGA-Express-XC9k-Optimizer:1998.08 "

These two packages can also be found within your Foundation directory structure, in FNDTN\DATA\license_update.txt.

2

For Current Users of Foundation synthesis (Metamor):

If your license.dat contains FND-STV-PC or FND-BSV-PC in the INCREMENT section,
then you have a Standard or Base (respectively) license for Foundation and
Metamor. This upgrade is documented in the Foundation Release Document, as
well as in the "Read Me First" document. These two hard-copy documents were
shipped with the software.

The upgrade process here is similar to the upgrade for Foundation Express 1.4
customers.

Note: Base users will not have access to the Express Constraints Editor.

3

For New Users of Foundation or Foundation synthesis:

If you are a new user, or if your license.dat does not enable synthesis
support, then you must contact Xilinx Customer Service to obtain a new license.

Note: A demo license.dat can be found on the Foundation Express CD. This
license will allow users to access all tools with four exceptions. Demo users
will not be able to:

- use the Express Constraints Editor
- use the Timing Analyzer
- create a bitstream for download
- target devices larger than 10k gates

Please register your software with Xilinx Customer Service to obtain a full
license.
AR# 4587
作成日 09/10/1998
最終更新日 06/14/2001
ステータス アーカイブ
タイプ 一般