UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 46533

13.4 COMPXLIB - 「ERROR:Compxlib:292 - Failed to update the setup file(s) for simulator mti_se」というエラー メッセージが表示される

説明

COMPXLIB を使用して ModelSim のシミュレーション ライブラリをコンパイルすると、すべてのライブラリに対して次のようなエラー メッセージが表示されます。

ERROR:Compxlib:292 - Failed to update the setup file(s) for simulator mti_se. Library verilog.secureip will not be compiled.

ERROR:Compxlib:292 - Failed to update the setup file(s) for simulator mti_se. Library verilog.unisim will not be compiled.

この問題の解決方法を教えてください。

ソリューション

このエラーの原因としては、次が考えられます。


  1. 出力ディレクトリのパスにスペースが含まれている
    compxlib.log ファイルで、ライブラリがコンパイルされる出力ディレクトリのパスにスペースが含まれていないか、確認します。
    例 : 出力ディレクトリのパスが 'C:\Documents and Settings\E466894\simlib\EDK11.1_mti_se_nt の場合、パスからスペースを削除してください。


  2. COMPXLIB が正しい modelsim.ini ファイルを検出していない 
    ModelSim インストール ディレクトリにある modelsim.ini ファイルを指すように MODELSIM 環境変数を設定します。
    例 :
    MODELSIM = D:\modeltech_6.6b\win32\modelsim.ini

  3. compxlib コマンドの実行時に、使用している言語とシミュレータをユーザー ガイド指定しなければならない
     
    レ例 : .../verilog/mti_se
     
    次の場合はエラーの原因の可能性があります。
     
    ../<language>/<simulator>
AR# 46533
作成日 02/26/2012
最終更新日 08/14/2014
ステータス アクティブ
タイプ エラー メッセージ
ツール
  • ISE Design Suite - 13.4