AR# 55726

2013.1 Vivado IP フロー - Vivado IP コアをアップグレードしようとるすると「ERROR: [IP_Flow 19-503] Validation failed for parameter...」というエラー メッセージが表示される

説明

Vivado 2013.1 ツールで、ある IP コアをアップグレードしようとすると、次のような警告およびエラー メッセージが表示されます。

7 Series GT Wizard v2.4

upgrade_ip -vlnv xilinx.com:ip:gtwizard:2.5 [get_ips  my_gtwizard]

Removed parameter gtz0_val_reference_clock
Removed parameter gtz1_val_reference_clockRemoved parameter gtz2_val_reference_clock
Removed parameter gtz3_val_reference_clockWARNING: [IP_Flow 19-2191] Attempt to set value '00000000' on disabled parameter 'gt0_val_clk_cor_seq_2_3' is ignored
WARNING: [IP_Flow 19-2191] Attempt to set value '00000000' on disabled parameter 'gt0_val_clk_cor_seq_2_4' is ignoredERROR: [IP_Flow 19-503] Validation failed for parameter 'gt_type'.



For this device GTX is disabled. So please select other options
ERROR: [IP_Flow 19-3196] Value 'DFE-Auto_(no_sliding_TAP)' is out of the range for parameter 'gt0_val_dfe_mode'.
Valid values are - DFE-Auto, DFE-Manual, LPM-Auto.
ERROR: [IP_Flow 19-3235] Customization errors found. Encountered problem restoring previous valid configuration, see errors below.
ERROR: [IP_Flow 19-503] Validation failed for parameter 'gt_type'. For this device GTX is disabled. So please select other options
ERROR: [IP_Flow 19-3196] Value 'left_column' is out of the range for parameter 'gt_column'.
Valid values are - right_column.
ERROR: [IP_Flow 19-503] Validation failed for parameter 'gt0_val'. No Active Transceivers!

ERROR: [IP_Flow 19-503] Validation failed for parameter 'gt1_val'. No Active Transceivers!

ERROR: [IP_Flow 19-503] Validation failed for parameter 'gt2_val'. No Active Transceivers!

FIFO Generator v10.0

upgrade_ip -vlnv xilinx.com:ip:fifo_generator:10.0 [get_ips afifo]

WARNING: [IP_Flow 19-2191] Attempt to set value '1023' on disabled parameter 'Full_Threshold_Assert_Value_wach' is ignored
...
ERROR: [IP_Flow 19-508] Validation failed for parameter 'Full_Threshold_Assert_Value_wach'. Value '1' is out of the range (6,1023)

エラーは表示されますが、IP は問題なくアップグレードされたようです。 

ソリューション

このコアのアップグレードが正しく処理されていません。

Vivado 2013.1 ツールでこの問題を解決するには、このアンサーの最後にあるOS 別のパッチと、アップグレードしようとしている IP のパッチを共にインストールします。

インストール方法については readme ファイルを参照してください。

この問題は Vivado 2013.2 ツールで修正される予定で、その時点でこのパッチは不要になります。

添付ファイル

関連添付ファイル

AR# 55726
日付 05/06/2013
ステータス アーカイブ
種類 既知の問題
ツール