UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 66256

PetaLinux 2015.4 QEMU - Display Port をエミュレートするためダミー クロック ドライバーが必要

説明

2015.4 QEMU を使用している場合、QEMU で SI570 クロック ジェネレーターがモデリングされないので、Display Port をエミュレートするためダミー クロック ドライバーが必要です。

カーネル/DTS にダミー クロック ドライバーの詳細を追加する方法を教えてください。

ソリューション

カーネルおよび DTS にダミー クロック ドライバーの詳細を追加するための 2 つのパッチがあります。

次にパッチの適用手順を示します。

1) dummy-clk.patch を適用する場合

CD $PETALINUX/ components/linux-kernel/xlnx-4.0/

Patch -p1 < dummy-clk.patch

2) DTS パッチを適用する方法

CD <proj>/subsystems/linux/configs/device-tree

Patch -p1 < dts.patch

petalinux-build を実行し、次のコマンドを実行します。

qemu-system-aarch64  -M arm-generic-fdt -device loader,addr=0xfd1a0104,data=0x8000000e,data-len=4  \ -serial mon:stdio -serial /dev/null \ -device loader,file=<proj>/images/linux/bl31.elf,cpu=0  \ -device loader,file=<proj>/images/linux/Image,addr=0x00080000 \  -device loader,file=<proj>/images/linux/system.dtb,addr=0x04080000  \ -device loader,file=<proj>/build/linux/misc/linux-boot/linux-boot.elf \  -net nic -net nic -net nic -net nic -net user \  -hw-dtb <proj>/images/linux/zynqmp-qemu-arm.dtb

添付ファイル

関連添付ファイル

タイトル サイズ ファイルタイプ
dts.patch 1 KB PATCH
dummy-clk.patch 5 KB PATCH
AR# 66256
日付 01/28/2016
ステータス アクティブ
種類 既知の問題
デバイス
  • Zynq UltraScale+ MPSoC
ツール
  • PetaLinux - 2015.4
このページをブックマークに追加