UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 7083

4.1i 4000 MAP - 「ERROR:OldMap:532 - Unable to obey design constraints which require...the following symbols into a single CLB...」というエラー メッセージが表示される

説明

キーワード : OldMap, 532,HMAP, FMAP, function generator, ir, ファンクション ジェネレータ

重要度 : 標準

概要 :
MAP で次のエラー メッセージが表示されます。

ERROR:OldMap:532 - Unable to obey design constraints which require the combination of the following symbols into a single CLB:
HMAP symbol "Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/B546" (output signal=Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/N144)
FMAP symbol "FMAP_3285" (output signal=N943)
FMAP symbol "Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/B541" (output signal=Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/N9255)
FDCE symbol "Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/B579" (output signal=Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/N139)
FMAP symbol "Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/B578" (output signal=Viterbi_0_ACS_ENGINE_INST1_MEMORY_MEM_BLK/N9748)
No function generator is available. These symbols share the same RLOC parameter. Consider using the "-ir" command line switch.

ソリューション

1

MAP のパック エラーはさまざまな原因から発生します。たとえば、ユーザーが無理なパック コマンドを生成したり、マップのバグが正常なパック コマンドを妨害している場合などです。 このエラー メッセージで推奨している -ir オプションの使用は、必ずしも最適な解決策とはなりません。

パック エラーの原因としては、CLB に使用できる FMAP があるかどうかにかかわらず、指定されていない FMAP が CLB に読み込まれることが挙げられます。 この場合、エラー メッセージで、関連するコンポーネントのうち 3 つの FMAP がリストされます。

バージョン 1.5i の場合、環境変数を使用してこのビヘイビアを無効にできます。

setenv XIL_MAP_NO_FMAP_PACK 1 (UNIX)

set XIL_MAP_NO_FMAP_PACK=1 (PC)

バージョン 2.1i/3.1i/4.1i の場合、デフォルトで FMAP パックが無効になっており、必要に応じて新しい変数を使用して有効にすることができます。 2.1i/3.1i ではこの変更が適切に採用されていないため、FMAP パックを無効にするには新しい変数を設定する必要があります。

setenv XIL_MAP_FMAP_PACK 1 (UNIX)

set XIL_MAP_FMAP_PACK=1 (PC)

2

AR# 7083
作成日 07/23/1999
最終更新日 06/13/2002
ステータス アーカイブ
タイプ 一般