AR# 72139

2019.x Zynq UltraScale+ MPSoC: fbdev ウィンドウ システムで libmali を有効にすると Yocto または PetaLinux から警告メッセージが表示される

説明

Zynq UltraScale+ デバイスで Yocto または PetaLinux を使用し、 fbdev ウィンドウ システムで libmali を有効にすると、ビルドで次のような警告メッセージが表示されます。

WARNING: You have included the meta-gnome layer, but 'x11' has not been enabled in your DISTRO_FEATURES.Some bbappend files may not take effect.See the meta-gnome README for details on enabling meta-gnome support.

ソリューション

これらの警告は無視しても問題はありません。

fbdev の場合のように、個々のバックエンド システムを選択するたびに、デフォルトの distro 設定から逸脱していることを知らせる警告メッセージが表示されます。

機能的には何も問題なく、作業を続けることができるはずです。この警告メッセージを削除する必要がある場合は、次の手順に従ってください。

Yocto:

build/conf/local.conf に次の変数を追加します。

PetaLinux:

/project-spec/meta-user/conf/petalinuxbsp.conf に次の変数を追加します。

SKIP_META_GNOME_SANITY_CHECK_zynqmp = "1"

AR# 72139
日付 05/29/2019
ステータス アクティブ
種類 一般
デバイス
ツール
Boards & Kits