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Zip File 
Contents

Click here to download the design files associated with this application note.

The Zip file contains the following directories and files.

coefficients

generate_prototype_filter.m – MATLAB script used to generate the 
prototype channel filter.

coefficients.csv – Prototype channel filter coefficients. Generated by 
generate_prototype_filter.m.

X-Ref Target - Figure 3

Figure 3: Polyphase Filter Bank
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generate_channelizer_coeffs.tcl – Tcl script that processes the 
prototype channel filter into sub-filters.

channelizer_8.coe – Polyphase sub-filters for the eight channel 
example. Generated by generate_channelizer_coeffs.tcl and used by 
the HDL-based reference design

coefficients_8.csv – Polyphase sub-filters for the eight channel 
example. Generated by generate_channelizer_coeffs.tcl and used by 
the System Generator reference design.

golden_data

*.dat – Golden data files; input, output, and intermediate values 
generated by the MATLAB reference design used to validate the HDL and 
System Generator implementations.

hdl

read_data_file.vhd – Configurable component to read and quantize a 
golden data file.

testbench.vhd – HDL test bench. Instantiates both the TX and RX 
paths and compares their outputs to the golden data.

tx.vhd – Transmitter top-level implementation.

rx.vhd – Receiver top-level implementation.

ise

generate_ise_project.tcl – ISE Tcl script to generate the HDL 
reference design. 

matlab

compile_bitacc_models.m – Compiles the MEX(C) bit accurate 
models for the FIR and FFT and sets up the /matlab directory to run 
channelizer.m.

channelizer.m – MATLAB reference design. Implementation of transmit 
and receive paths.

setup_tx_cores.m – MATLAB function that sets up the FIR and FFT 
MEX(C) models for the transmit path.

setup_rx_cores.m – MATLAB function that sets up the FIR and FFT 
MEX(C) models for the receive path.

sysgen

compare_to_golden.m – MATLAB script to compare the System 
Generator reference design output to the golden data.

top.mdl – System Generator reference design. Contains transmit and 
receive path implementations.

vivado

generate_vivado_project.tcl – Vivado Tcl script to generate the 
HDL-based reference design.

http://www.xilinx.com
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Design Specification

The reference design demonstrates an 8-channel polyphase filter bank with a channel sample 
rate of 200 kHz. Due to the nature of the polyphase filter bank, the carrier separation of the 
generated FDM output is also 200 kHz. The FDM output stream operates at a sample rate of 
1.6 MHz (number of channels × channel sample rate). A target Spurious Free Dynamic Range 
(SFDR) of ~86 dB was selected.

Prototype Channel Filter

The channel filter is designed to operate at the sample rate of the higher frequency FDM 
stream but have a pass band less than or equal to the Nyquist frequency of the input/output 
channels. The filter is used to suppress the aliasing introduced by the up/down sampling 
process.

The reference design provides a MATLAB script, 
coefficients/generate_prototype_filter.m, to generate the channel filter 
coefficients along with the script output, coefficients/coefficients.csv. 

A pass band frequency of 90 kHz and a stop band frequency of 100 kHz have been selected. 
These have been expressed in normalized frequency where,

fs/2 = 800 kHz = 1, so Fpass = 0.9 × (1/8) and Fstop = 1/8. 

A suitable stop band attenuation and pass band ripple has been selected with a filter length of 
712 taps.

X-Ref Target - Figure 4

Figure 4: Prototype Channel Filter

http://www.xilinx.com
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Fixed Point Exploration

The MATLAB m-file, channelizer.m, implements the polyphase filter bank using MATLAB 
floating point functions alongside the fixed point Xilinx FIR Compiler and Fast Fourier Transform 
bit accurate MEX(C) models. 

The FIR and FFT bit accurate models are configured in the two functions/files:

• setup_tx_cores 

• setup_rx_cores

Before channelizer.m can be run, the Zip files for the FIR and FFT bit accurate C models 
must be placed and unzipped in:

matlab/fir_cmodel

matlab/fft_cmodel

The Zip files for each supported platform are output during core generation or can be 
downloaded from: 

http://www.xilinx.com/products/intellectual-property/FIR_Compiler.htm

http://www.xilinx.com/products/intellectual-property/FFT.htm

The helper script, compile_bitacc_models.m, should be run to compile the MEX 
executables. After the MEX files have been generated, channelizer.m can be executed. 

Note: For Linux, the LD_LIBRARY_PATH environment variable should be updated to include the 
/matlab directory before channelizer.m is executed.

The script generates input data for each of the eight channels apart from the second and fifth 
channels which are set to zero for demonstration purposes. The input data to the other 
channels is a sinusoid scaled to a unique amplitude for each channel. Hence the difference in 
the amplitudes in Figure 5, Figure 9, Figure 11, and Figure 12. It implements the transmit path 
producing the fixed point combined output stream/spectrum. The script then goes onto 
implement the receive path using the fixed point output of the transmit path as its input.

The channelizer.m script produces several plots; one of the combined spectrum output by 
the transmit path Figure 5 and one for each channel at the output of the receive path Figure 6.

http://www.xilinx.com
http://www.xilinx.com/products/intellectual-property/FIR_Compiler.htm
http://www.xilinx.com/products/intellectual-property/FFT.htm
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X-Ref Target - Figure 5

Figure 5: Transmitter Channel Output Spectrum

http://www.xilinx.com
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The script can be configured to output the test vectors used to verify the HDL implementation 
by setting the write_golden_data variable to 1 at the top of the script.

Implementation As illustrated in Figure 3 the polyphase filter bank is implemented using an IFFT and a set of 
sub-filters, one per channel. The reference design uses the Xilinx Fast Fourier Transform core 
to implement the IFFT and a single instance of the Xilinx FIR Compiler core to implement all of 
the sub-filters. 

The FIR Compiler is configured to support eight coefficient sets and eight interleaved data 
channels. The configuration method is set to "By_Channel" so each interleaved channel can be 
associated with its corresponding sub-filter. The prototype channel filter is split and reordered 
into the eight sub-filters:

hr(n) = h(r + nM), where M = 8 and r ranges from 0 to M - 1. 

The helper script coefficients/generate_channelizer_coeffs.tcl is provided to 
reorder the channel filter coefficients. It outputs the channelizer_8.coe and 
channelizer_8.csv files used by the HDL and System Generator implementations. 

The FIR Compiler instances are customized using the reordered coefficients. At the start of 
operation, the design configures the FIR instances by the CONFIG channel to select the 
appropriate filter set for each interleaved data channel.

X-Ref Target - Figure 6

Figure 6: Receiver Channel Output Spectrum

http://www.xilinx.com
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The Fast Fourier Transform instances are customized as an 8-point transform with natural order 
outputs.

Building the Design

Both the FIR Compiler and Fast Fourier Transform cores have AXI4-Stream compliant 
interfaces. This simplifies and accelerates the process of building any design. For more 
information of the AXI4 Interface Protocol, see http://www.xilinx.com/ipcenter/axi4.htm.

Transmitter

The Transmit path is the simpler of the two modules and only uses three IP instances; 

• FFT

• FIFO

• FIR (plus a small amount of control logic)

The FIFO is used to buffer the frame based output of the FFT to the sample based input of the 
FIR. All three IP instance have AXI4-Stream interfaces resulting in a very straight forward 
design.

Receiver

The Receive path is more complicated due to the input commutator rotating in the opposite 
direction to that of the transmitter output commutator, see Figure 3. The first input sample to the 
receiver must be applied to the last sub-filter and the last FFT bin. The FFT expects its first 
input sample to be for the first bin. Therefore, the data must be buffered into blocks of eight 
samples and the order of the samples flipped. This reordering is done following the FIR 
instance. The FIR is configured to apply the sub-filters in reverse order. The reordering is 
implemented using a Distributed Memory Generator instance along with a counter and some 
control logic. Finally, the receiver uses a FIFO on the output of the FFT instance to convert 
between its frame-based output to the desired sample-based channel output.

X-Ref Target - Figure 7

Figure 7: Transmitter Block Diagram

http://www.xilinx.com
http://www.xilinx.com/ipcenter/axi4.htm
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HDL Design

The HDL-based design provides two top-level HDL files. One for the transmit path, tx.vhd, 
and one for the receive path, rx.vhd. For ISE, the application note delivers the sub-cores 
preconfigured as XCO files in the IP directory. 

For Vivado the sub-cores are generated and configured using the Tcl interface. The 
configurations for the TX and RX FIR and FFT cores match those specified in the 
matlab/setup_tx_cores.m and matlab/setup_rx_cores.m scripts. This ensures the 
hardware implementation matches the specification determined in the Fixed Point Exploration 
stage.

Both the top-level modules are instantiated in the test bench, testbench.vhd, with the output 
of the transmitter path being used as input of the receive path. The input for the transmit path 
is taken from the test vectors generated by the MATLAB script/reference design and the output 
of each module. Extra debug signals are also compared to test vectors produced by the 
MATLAB script.

Project Setup

The HDL design is delivered through a Vivado or ISE project. The projects are created by 
following the steps.

Vivado 

1. CD into /vivado.

2. Start Vivado.

3. Select the Tcl console (bottom panel).

4. To create the project type: 

source -notrace generate_vivado_project.tcl

The script creates the project, imports all the sources (TB and HDL), configures, and generates 
all of the IP cores.

ISE

1. CD into /ise.

2. Start ISE.

3. Close any open projects.

X-Ref Target - Figure 8

Figure 8: Receiver Block Diagram

http://www.xilinx.com
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4. Select the Tcl console (bottom panel). If not visible select View > Panels > Tcl Console.

Note: Ensure that the working directory (type pwd) is still the ISE directory of the application 
note unzipped reference design.

5. To create the project type: 

source generate_ise_project.tcl

The script creates the project, imports all the sources (TB, HDL, and IP), and generates all of 
the IP cores (this step can take a long time).

Simulation

To simulate the design, follow these steps. 

Vivado

To simulate the design, select Run Simulation > Run Behavioral Simulation from the Flow 
Navigator (left-hand panel). This compiles the design and starts the Vivado simulator.

ISE

To simulate the design, select the Simulation view, then in the hierarchy viewer select the test 
bench module. Then in the Processes viewer, select ISim Simulator > Simulate Behavioral 
Model. This compiles the design and starts the ISim simulator. 

Type "run all" to run all the test vectors through the design. This can take a long time. If any 
mismatches between the HDL and the golden vectors occur, the test bench reports an error. A 
successful simulation displays the following statement:

** Failure:*** SIMULATION COMPLETED!!! ***

Note: An assertion of severity failure is used simply as a means to terminate simulation. It does not 
indicate a genuine failure.

Both projects can also be set up to use Questa® SIM for simulation. See the Vivado or ISE 
manuals for instructions.

The test bench de-multiplexes the receiver output into the separate channels. Using Questa 
SIM analogue waveform format, the time domain plot for each channel can be inspected, see 
Figure 9.

http://www.xilinx.com
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Implementation

To implement the design, follow these steps.

Vivado

1. In the Project Manager, select either the TX or RX module, right-click Set as Top.

2. Select Run Implementation from the Flow Navigator (left-hand panel). This automatically 
runs synthesis and implementation.

ISE

1. To implement the design, select the Implementation view. 

2. In the hierarchy viewer, select either the TX or RX module, and right-click Set as Top 
Module. 

3. Select Process > Implement Top Module. This runs synthesis, map, and place and route.

System Generator Design

The System Generator design is delivered as a single Simulink® model, sysgen/top.mdl. 
The top-level model acts as the test bench and instantiates the TX and RX designs as separate 
subsystems.

X-Ref Target - Figure 9

Figure 9: Receiver Channel Output

http://www.xilinx.com
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As with the HDL-based design, the FIR and FFT configurations have been taken from the 
matlab/setup_tx_cores.m and matlab/setup_rx_cores.m scripts. When the model 
is opened, the input stimulus and golden vectors are loaded into global MATLAB variables.

Simulation

When the model simulation is running, Simulation > Start, and completed the Spectrum scope 
displays a similar plot to that generated by the MATLAB script for the transmitter output 
spectrum, Figure 11. 

X-Ref Target - Figure 10

Figure 10: System Generator Top-Level Model

http://www.xilinx.com
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The Channel Demux block output displays a time domain plot for each channel output by the 
receiver. The zeroed channels can be observed in Figure 12.

X-Ref Target - Figure 11

Figure 11: System Generator Transmitter Output Spectrum

http://www.xilinx.com
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The simulation output (including intermediate debug signals can be compared against the 
golden vectors produced by the MATLAB script by running sysgen/compare_to_golden.m. 
It reports any signals that have mismatched or outputs the following string:

PASSED: No mismatches found

Implementation

The TX and RX modules are implemented by opening the System Generator token in the 
subsystem blocks and clicking Generate.

X-Ref Target - Figure 12

Figure 12: System Generator Receiver Output Spectrum

http://www.xilinx.com
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Resource 
Utilization

All of the mentioned designs use Virtex®-7 XC7VX485T-FFG1157-2. The following resources 
are required for the transmitter and receiver modules.

References 1. Harris, Fred, Chris Dick, and Michael Rice, “Digital Receivers and Transmitters Using 
Polyphase Filter Banks for Wireless Communications,” In IEEE Trans. on Microwave 
Theory and Techniques, Volume 51, No. 4., (April 4, 2003).
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Table  1:  Transmitter Virtex-7 FPGA Resource Estimates

Configuration Slice 
Registers Slice LUTs RAMB36E1s RAMB18E1s DSP48E1s

Vivado 1,231 683 1 5 6

ISE 1,209 775 1 5 6

System Generator 1,167 749 2(1) 5 6

1. The extra RAMB36E1 is due to a known issue with the AXI FIFO System Generator block. For more 
information, see the System Generator Known Issues.

Table  2:  Receiver Virtex-7 FPGA Resource Estimates

Configuration Slice 
Registers Slice LUTs RAMB36E1s RAMB18E1s DSP48E1s

Vivado 1,339 746 1 5 6

ISE 1,316 748 1 5 6

System Generator 1,256 704 2(1) 5 6

1. The extra RAMB36E1 is due to a known issue with the AXI FIFO System Generator block. For more 
information, see the System Generator Known Issues.
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