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Licensing

Ensure that the licenses for the Video over IP FEC Transmitter and Receiver cores, Modular
Media over IP Infrastructure, and the 10G Ethernet MAC Subsystem are installed.

Reference Design Steps

Setup

This refeg design runs on the Kintex-7 Evaluation board (KC705) using the
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Figure 35: Modular Video over IP ST 2022-56 System Setup
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Figure 36: KC705, and TB-FMCH-3GSDI2A Boards

In these instructions, the numbers in parentheses correspond to‘the callout numbers in
Figure 36.

1. Connect a USB cable from the host PC to the USB JTAG port (1)¢ Ensure the appropriate
device drivers are installed.

2. Connect a second USB cable from the host PC to the USB UART port (2). Ensure that the USB
UART drivers described in Hardware have been installed.

3. Connect the TB-FMCH-3GSDI2A board to the HPC-FMC of KC705 (3).

4. Ensure that the SMPTE 352/Payload ID is enabled in the SDI Stream connected to the
HPC-FMC of KC705.

5. Connect an SFP+ optical transceiver to the SFP slot (4).
6. Connect a jumper to J4 (5) to enable the SFP+ transmitter.

7. Connect one end of the optical cable (6) to the SFP+ on the VoIP transmitter board, the
other end to the SFP+ on the VoIP receiver board.
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Connect the CHO-TX, CH1-TX, and CH2 ports of TB-FMCH-3GSDI2A (7) to the SDI video
monitor if the KC705 board is the VoIP receiver.

Connect the CHO-RX, CH1-RX, and CH2 ports of TB-FMCH-3GSDI2A (8) to the SDI video
generator if the KC705 board is the VoIP transmitter.

Connect the KC705 board to a power supply slot J49 (9).
Switch on the KC705 board (10).

Make sure that the HW-KC705 board revision (11) is the same for the VoIP TX and RX
platforms.

Connectione end of the optical cable to the SFP+ of the VoIP TX FM-S14 (13) board, the
other’end to the SFP+ of the VoIP RX FM-S14 (13) board.

Ensure LEDs 0,4, 4, 5, 6, and 7are lit on (refer to Debugging for details)

Start a terminal,program (for example, HyperTerminal) on the host PC with these settings:
- Baud Rate: 115,200

- Data Bits: 8

o Parity: None

- Stop Bits: 1

- Flow Control: None

Running the Reference Design

This section details the steps necessary to execute the system using the files in the
ready_for_download directory.

1.

Launch the Xilinx Microprocessor Debugger by selecting Start > All Programs > SDK
2016.1 > Xilinx Software Command Line Tool 2016:1.

Execute the Xilinx Microprocessor Debug, by typing in the Xilinx Software command line:

xmd

In the Xilinx command shell window, change to the ready_fér_download directory:

VoIP_TX: >cd <unzip_dir>/kc705_voip_modular_56_tx/ready_for_download
VoIP_RX: >cd <unzip_dir>/kc705_voip_modular_56_rx/ready_for_download

Download the bitstream to the FPGA:
XMD% fpga -f download.bit
Exit the XMD command prompt:

XMD% exit

Note: The software application starts immediately after the completion of FPGA configuration. The
executable file (.elf) is embedded in the configuration file (download.bit).
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Building Hardware

This section covers rebuilding the hardware design. Before rebuilding the project, ensure that
the licenses for the 10-Gigabit Ethernet MAC Subsystem and VoIP FEC Transmitter and Receiver
are installed.

Note: To ensure that no compilation errors occur due to long file paths, unzip the project files as close
to the root directory as possible. For example, with a typical Windows installation, unzip the files at C:\.

To generate a programming file in the Vivado Design Suite 2016.1, perform the following steps.

1. Open the Vivado Design Suite.

2. At the Tcl Console, change to the workspace directory by typing:
VoIP_TX: >/ed <unzip dir>\kc705_voip_modular_56_tx
VoIP.RX:> cd <unzip dir>\kc705_voip_modular_56_rx

3. Run the allitcl(script to create, compile, and generate the project bitstream.

> source all.tcl

Compiling Software in SDK

The SDK environment for the SI¥2022-56 Modular Media over IP is compiled during execution
of the all.tcl script. If you are required tobuild the SDK environment from the beginning, follow
these steps

1. Export hardware: In Vivado 2016.1elect File > Export > Export Hardware.
a. In the Export Hardware popup window, Check the Include bitstream option.

b. Set the Export to: field correspondingly
VoIP_TX: <unzip dir>\kc705_voip_modular_56_tx\SW\SDK_Workspace
VoIP_RX: <unzip dir>\kc705_voip_modular_56_rxX\SW\SDK_Workspace

2. Launch Xilinx SDK 2016.1vfrom Vivado 2016.1 by selecting File > kaunch SDK.

a. Inthe launch SDK popup window, set the Exported Location field and Workspace field
accordingly:

VoIP _TX: <unzip dir>\kc705_voip_modular_56_tx\SW\SDK_Workspace
VoIP _RX: <unzip dir>\kc705_voip_modular_56_rx\SW\SDK_Workspace

b. Create the local repository in SDK, perform the following steps: (Figure 37)
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i. Select Xilinx Tools > Repositories in SDK. A new window pops up.
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- Java
> Remote Development
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- Run/Debug
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- Tracing
’l 4 ¥ilinx SDK

BootImage
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Hardware Specification
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Toolchain Preferences
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Add, remove or change the order of SDK's software repositories.

Local Repositaries (available to the current workspace)
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Relative |

Global Repositories (available across workspaces)

SDK Installation Repositories

Cof¥iline IDE2016_1/01MAC/SDK 2016, 1 datafembedded s

Mote: bocal repositafy settings take precedence over global repository settings.

Restore Defaults l | Apply

Vv Ae W

Figure 37: Local Repository

ii. Click the New tab, for Local Repositories (available to the current workspace).

iii. Add the local repository path:

VoIP_TX: <unzip dir>sw_repository

VoIP_RX: <unzip dir>sw_repository

Vi.

XAPP1272 (v2.0) May 5, 2016

Click Apply tab.

Click the OK tab.

www.Xilinx.com

Click the Rescan Repositories tab. Note that execution takes around 1 to 2 minutes.
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Note: The software local repository contains the low-level drivers for <v_voip_sdi2axis> for VoIP
Modular 56 Transmitter and <v_voip_axis2sdi> for VoIP Modular 56 Receiver, which is portable to
the Board Support Package in SDK 2016.1.

Create a new Board Support Package; File > New > Board Support Package.

Key in mod_bsp in the Project name field of In the New Board Support Package
Project popup window.

Click Finish, then click OK.

The board support package (BSP) and software applications compile at this step. The process
takes two to five minutes. The existing software applications can now be modified and new
software applications can be created in the SDK.

3. Import SDK Sources: In SDK 2016.1 select File > Import.

a.
b.

C.

In‘the Import popup window, select General > Existing Projects into the Workspace

Click'Next.

Click Browse.&. and. make sure that it points to the corresponding folders.
VoIP_TX: <unzip“dir>\ke705_voip_modular_56_tx\SW\SDK_Workspace
VoIP_RX: <unzip dir>\kc705uwvoip_modular_56_rx\SW\SDK_Workspace

Click OK.
Make sure mod_tx/rx are checked.

Click Finish.
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Program FPGA
Specify the bitstrearn and the ELF files that reside in BRAM mernary

Hardware Configuration

Hardware Platform: | b -

ol |Local v| | Mew |

Device: | Buto Detect | Select |
Bitstream: | ValP_Framewark_FX_I0B.bit | search...| [ Browse. |
BMM/MMIFile; | VolP_Framewark RX IOB_bd.bmm | [search...| [Browse. |

Suﬁ'are Configuration

/ ss0F ELF File to Initialize in Block RAR
term_basic_i/microblaze_1 hootloop

| 1 |

[T Run reset_zyngpl

@

l Prograrn I’ Cancel

Figure 38: FPGA
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Results

The HyperTerminal screen of the VoIP TX and RX displays the output shown in Figure 39
through Figure 44 respectively.

f___{ { S ®%ilinx Inc.

" AV Modular SMPTEZ2022-5/6/7 Tx 10aG

A \ vivado 2015.4 reference Design

/ / Created: January 11, 2016

S/ FAY coqyright {c) 2015-2016 xilinx, Inc.
A NS A1l rights reserwved.

AV VA VI |

-=Initialize System Fe
-=Initialize Input Subsystem....
—=Power on Init Done

-=5tarting System Feripherals....

| “eh. | FEC Mode | FEC Alignment | FEC L | FEC D |
| 1 2D Mode | Block aligned | 77 | 77 |
| 2 20 Mmode | Block aligned | 77 | 77 |
| 3| 2D mMode | Block aligned | 77 | 77 |

Module voip FEC TX Imitialized....

-=5tart Input Subsystent. ..

elect option

System Reset

System Initialize

configure channel

Probe General Space 5tatistic
Reset General Space Statistic
help

Figure 39: Modular VolP 56 Transmitter Main Menu

Primary Channels
1 = Channel 1
2 = Channel 2
3 = Channel 3
secondary Channels
a = Channel 1
b = Channel 2
= Channel 3

Figure 40: Modular VoIP 56 Transmitter Channel Selection Menu
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1 = Channel Reset

2 = Channel Initialize

a = FEC on/off

b = Toggle FEC Level (1D/2D)
€ = S5et Column FEC

d = Set Row FEC

e = Toggle Block Alignment

Tt = Transmit Enable/Disable
r = Transmit Packet Count Stat. Reset
p = Probe Status

m = Main Menu

s = Channel select

Figure 41: Modular VolP 56 Transmitter Channel Menu

*Xilinx Inc.
S Modular sSMPTEZ022-5/6/7 R¥ 10G
Y b\ Wivado 2015.4 reference Design
! / Created: January 16, 20186
f__ 7 k' coqyright {c) 2015-2016 xilinx, Inc.
A N/ Al rights reserved.
AV VA

-=Initialize System Pe, -#Initialize Input Subsystem....

->VoIF Subsystem FoWwer om Init Done

-=5tart Input Subsystem Indtialization..
-=5tarting System Peripherals....

-=5tart SMPTE 2022-536 WOIF RX application....

elect option

System Reset

System Initialize

configure channel

Probe Current Settings

Reset General Space Stat Counters

Figure 42: Modular VolP 56 Receiver Main Menu

1 = Channel 1
2 = Channel 2
3 = Channel 32

Figure 43: Modular VolP 56 Receiver Channel Selection Menu
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1 = Channel Reset

2 = Channel Initialize

p = Probe 5tatus

r = Channel Statistics Reset
m = Main Menu

5 = Channel select

Figure 44: Modular VolP 56 Receiver Channel Menu

Debugging

On-board general purpese I/O (GPIO) LEDs can be used for quick troubleshooting. During
normal operation all’LEDs should asynchronously turn on within five seconds after bit stream
configuration. The LED representations are shown in Table 13.

Table 13: KC705 GPIO LED Designations for Transmitter and Receiver

GPIO_LED | Designation
Primary Link PCS Locked

Secondary Link PCS Locked

Unused

Unused

Si5324 Locked

100 MHz Locked

DDR MMCM Locked

N ojlu| b~ WIN| RO

DDR Memory Initialization Done

GPIO_LED 7: When this LED is low, it means that the memory subsystem did not successfully
initialize. Sometimes switching development boards helps to get afound this problem.

After the system is brought up, IP (Video over IP FEC TX and RX and Modular Media over IP
Infrastructure) debug needs to be performed. This can be found under the Core Debug Section
in the Video over IP FEC Transmitter LogiCORE IP Product Guide (PG206) [Ref 4], the Video over
IP FEC Receiver LogiCORE IP Product Guide (PG207) [Ref 5] and the Modular Media over IP
Infrastructure v1.0 LogiCORE IP Product Guide (PG241) [Ref 14].
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The following table shows the revision history for this document.
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« Replaced “Video over IP SMPTE2022-56" with “Modular ST 2022-56 Media
over IP” in text and in graphics.

« Updated Figures 2, 3, and 4.

« Replaced "SMPTE2022" with “ST 2022" throughout.

« Replaced Table 3 with two new tables (Table 3 and Table 4)
« Updated Figure 4.

05//05/2016"| 2.0 « Beginning after new Table 4 removed text and Figure 9.

« Removed the following sections: ST2022-6 Packetizer Module Register
Space, Frame Module Register Space, Decapsulator Module Register Map,
and ST2022-6 Depacketizer Module,

« Changed 2015.4 to 2016.1 throughout

» Updated old Figure 21 (now Figure 20).
»..Updated,Figure 35 and Figure 38.

« Updated directory structure description.
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