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Summary

This application note covers the steps necessary to set up and run Wind River VxWorks using
the Embedded Development Kit (EDK). It covers installation, setup, building a system using the
EDK, generating and modifying the VxWorks BSP, and booting VxWorks on the Virtex-II Pro™
ML300 Platform.

Introduction

The Embedded Development Kit (EDK) enables developers to jump-start their designs by
providing a VxWorks BSP tailored to their system specifications. The application note is
targeted to the Virtex-II Pro ML300 development platform, but can easily be ported to a
different platform due to the flexibility of the EDK. The application note provides the necessary
steps to get started with the EDK and Tornado 2.2.1/VxWorks 5.5.1 from installation to booting
VxWorks on the ML300. When using a different hardware platform, access to serial and
Ethernet ports is recommended.
The automatic VxWorks BSP generation is documented in Chapter 13 of the Processor IP
Reference Guide in the EDK doc directory. The EDK release also contains pre-configured
BSPs for the ML300 which are documented in Chapter 11 of the Processor IP Reference
Guide.
The host system used is Microsoft Windows XP with system administrator privileges. Make
sure that the computer used meets the system requirements for the Xilinx and Wind River tools.
Table 1 provides a timetable for each step covered in this application note. Table 2 lists the
tools needed to complete the design.
Table 1: Task Timetable
Steps

Details

Time Required
(in Minutes)

Install ISE 6.3i and service pack

Install the implementation software

40

Install EDK 6.3i and service pack

Install the embedded development software

20

Install Tornado 2.2.1

Install the Wind River tools

15

Build an ML300 design

Use Base System Builder in EDK 6.3i to build
a custom system

55

Customize the VxWorks BSP

Modify the automatically generated BSP

10

Build the VxWorks kernel

Use Tornado to create and customize a
VxWorks image and bootrom

15

Create an ACE file

Create a configuration file for the ML300

5

Boot VxWorks

Run VxWorks on the ML300

15
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Installing the Software

Table 2: Required Tools
Item

Installing the
Software

Details

Workstation

Use a PC or laptop with a CD-ROM and sufficient hard drive space to
install the required software

CompactFlash writer or
PC card adapter

For PCs, use a CompactFlash writer. For laptops, use the CF card
adapter that shipped with the ML300

ML300 board

Virtex-II Pro ML300 platform

Cables

Use the serial and Ethernet cross-over cables provided with the ML300
kit

Xilinx ISE 6.3i for Windows
Installation CDs

See
http://www.xilinx.com/products/design_resources/design_tool/index.ht
m to purchase ISE Foundation 6.3i

Xilinx ISE 6.3i
Service Pack 2 for Windows

See
http://www.xilinx.com/xlnx/xil_sw_updates_home.jsp
to download the service pack

Xilinx EDK 6.3i
Installation CD for Windows

See
http://www.xilinx.com/ise/embedded/edk_buynow.htm
to purchase Xilinx EDK 6.3i

Xilinx EDK 6.3i
Service Pack 1 for Windows

See
http://www.xilinx.com/ise/embedded/edk_download.htm
to download the service pack

Wind River Tornado 2.2.1/
VxWorks 5.5.1 for PowerPC
Installation CD

Order TDK-15060-ZC-00 from Wind River

Wind River BSPs/Drivers
for VxWorks 5.5.1 PowerPC
Installation CD

Order TDK-14630-ZC-02 from Wind River

Installing Xilinx ISE 6.3i
Make sure to register the Xilinx ISE and EDK software and write down the registration IDs.
Insert the first CD of ISE 6.3i into the CD-ROM drive and follow the installation instructions.
When finished, insert the second CD of ISE 6.3i into the CD-ROM drive and complete the
installation.
Continue with the ISE 6.3i Service Pack 2 installation by double-clicking on the downloaded
image. Follow the installation instructions.

Installing Xilinx EDK 6.3i
Insert the EDK 6.3i CD into the CD-ROM drive and follow the installation instructions. When
finished, install the EDK 6.3i Service Pack 1 by double-clicking on the downloaded image.

Installing Wind River Tornado
Insert the Core Tornado 2.2 CD into the CD-ROM drive. Select a full installation and follow the
installation instructions. The license number and number of seats is shown on the Tornado
Installation Keys form that shipped with the CDs. Install the default selection for components
and parts. Tornado requires a license, so follow the steps to request an automatic license. If
using a floating license, a license server must be installed and available on the network.
After completing the license registration process, continue by installing the BSP/driver CD.
Restart the computer.
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Starting a Design

Starting a
Design

Building the PowerPC System for the ML300
The first step is to create a processor system that can be loaded into the FPGA using the EDK.
Launch Xilinx Platform Studio:
Start Menu → All Programs → Xilinx Platform Studio 6.3i → Xilinx Platform Studio
The EDK provides a wizard called Base System Builder (BSB) which helps users build a
system targeted at a specific development board.
Using Base System Builder
1. Select Base System Builder Wizard, then click OK.
2. The Create New Project Using Base System Builder Wizard window pops up. Select a
directory for the project. Click OK, then click Next.
3. The Base System Builder - Select Board window lets you choose your target board. Select
Xilinx as the Board Vendor. Select Virtex-II Pro ML300 Evaluation Platform as the
Board Name. Click Next to accept these settings.
4. In the Base System Builder - Select Processor window, click Next to use the PowerPC as
the processor for this design.
5. The Base System Builder - Configure Processor window lets you select the processor and
bus frequencies you want to run at. Select 200 MHz for the Processor Clock Frequency
and 66.67 MHz for the Bus Clock Frequency. Leave the other parameters at their defaults.
Click Next to accept these settings.
Choosing higher bus and system speeds would result in longer implementation times. The
caches would be enabled using the Tornado project facility.
Selecting Configuration Options
The next few windows present configuration options for the I/O interfaces. The number of
windows seen depends on the monitor screen resolution. Click Next to advance to the next
window.
1. Leave the parameters at their defaults while making the following selections:
♦

Enable RS232 UART 1, choose OPB UARTLITE as Peripheral, select Configure with
19200 baud rate, and select Use Interrupt

♦

Disable RS232 UART 2.

♦

Enable Ethernet MAC, choose OPB ETHERNET as Peripheral, and select Use
Interrupt

♦

Enable DDR SDRAM 32Mx32, and choose PLB DDR as Peripheral

♦

Disable SPI EEPROM

♦

Enable LEDs 16Bit

♦

Enable Push Buttons 16Bit

♦

Enable Proto Pins LEDs 32Bit

♦

Disable PCI Arbiter.

♦

Disable PCI32 Bridge.

♦

Disable SysACE CompactFlash

♦

Disable IIC Bus

Click Next to accept the default settings in the Base System Builder - Add Internal
Peripherals window.
2. In the Base System Builder - Software Configuration window, disable Generate Sample
Application and Linker Script. Click Next.
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Starting a Design
3. The Base System Builder - System Created window shows an overview of the system.
Click Generate to write the configuration to the disk.
4. Click Finish in the Base System Builder - Finished! window to complete the Base System
Builder project.
Modifying the Software Settings
Base System Builder created a complete hardware system with the peripherals specified
above. The next few steps are required to change some of the project software options to
automatically generate a VxWorks board support package (BSP).
1. Open the software settings dialog box by selecting Project → Software Platform
Settings… from the XPS menu.
2. Choose VxWorks5_5 as the operating system (OS) in the Kernel and Operating Systems
section of the dialog box.
3. Click on the Library/OS Parameters tab to set additional parameters necessary for
generating the VxWorks BSP.
Setting Additional Parameters
1. Select the RS232 Uart for both STDIN and STDOUT.
2. Click on the Current Value box for the connected_periphs option. Click Add two times. For
each field, select a different peripheral from the drop-down list. The list contains
RS232_Uart_1 and Ethernet_MAC. Click OK.
3. Click OK to accept the settings in the Software Platform Settings window.
4. Click on the Applications tab, right-click on Default:ppc405_0_bootloop, and enable
Mark to Initialize BRAMs.
Building the BSP and Hardware
To be able to work on the VxWorks kernel while EDK builds the hardware, first generate the
VxWorks BSP and then implement the hardware.
1. Build the VxWorks BSP by selecting Tools → Generate Libraries and BSPs from the
menu. The transcript window indicates that the VxWorks BSP has been built.
2. Build the hardware by selecting Tools → Update Bitstream from the menu. This takes
some time. Use this time to customize the BSP and build the VxWorks kernel.

Customizing the Generated VxWorks BSP
Some parameters need to be changed to customize the VxWorks BSP for the system. The BSP
directory is located inside the XPS project ppc405_0 directory under the name
bsp_ppc405_0. The DDR memory is used to store the VxWorks bootrom and the VxWorks
image.
1. Open the config.h file inside the directory.
♦

Change the default memory size
#define LOCAL_MEM_SIZE

♦

Change the ROM address settings
#define ROM_BASE_ADRS

♦

0x00C00000

Change the RAM address settings
#define
#define
#define

4

0x08000000

ROM_SIZE
RAM_HIGH_ADRS
RAM_LOW_ADRS
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Building the VxWorks Image
2. Open the Makefile file.
♦

Change the memory settings to match the config.h file
ROM_TEXT_ADRS
ROM_WARM_ADRS
ROM_SIZE
RAM_LOW_ADRS
RAM_HIGH_ADRS

=
=
=
=
=

00C00000
00C00008
00800000
00010000
00C00000

3. Open the sysNet.c file.
♦

Enter the address from the ML300 board. The Ethernet address is located on the
backside below the Xilinx logo. For an address of 000A35000102 it would be:
Static char XemacMacAddr0[6] = {0x00, 0x0A, 0x35, 0x00, 0x01,
0x02}

Building the
VxWorks Image

VxWorks can be built either in command line mode or GUI mode using the Tornado project
facility. The project facility is used to compile the BSP and add components to the image.

Compiling the BSP
1. Copy the bsp_ppc405_0 directory to the target\config directory of the Tornado
installation.
2. Start Tornado and select Create a Bootable VxWorks Image.
3. Enter a project name and path location, then click Next.
4. Click on A BSP, then select bsp_ppc405_0 and gnu for the Tool field. Click Next, then
Finish.

Configuring the VxWorks Image
After the BSP is compiled successfully, the Workspace window opens. Depending on the
application, some components need to be included or excluded. As an example, the Target
Shell is added to the image:
1. Select the VxWorks tab in the Workspace window. The components already selected
appear in bold. Open the component tree. To display a component description, doubleclick on the component name.
2. Open Development Tool Components.
3. Right-click on Target Shell Components. Select Include ‘target shell components’…
4. Click OK twice.

Building the VxWorks Image and Bootrom
The default VxWorks image is RAM-based and can be loaded using SystemACE, a debugger,
or through a VxWorks boot ROM. Using a boot ROM provides a choice in loading the VxWorks
image through FTP or with SystemACE when configured as a block device. For the ML300
both the image and boot ROM reside in the DDR memory.
1. Select Build → Build
2. Select Build → Build Boot ROM…
3. Select bsp_ppc405_0, bootrom_uncmp, and GNU for the toolchain. Click OK.
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Generating an
ACE File for the
ML300

Generating an ACE File for the ML300

Wait for the Update Bitstream process to be finished before starting. The ACE file contains the
bitstream for the FPGA configuration and the VxWorks bootrom executable. The ACE file is
stored on the MicroDrive shipped with the ML300. At power-up, the SystemACE controller
configures the FPGA then load the VxWorks boot ROM into memory using JTAG commands.
1. Copy the bootrom_uncmp image from the Tornado target\config\bsp_ppc405_0
directory to the XPS project root directory.
2. To generate the ACE file, open a XYGWIN shell using XPS, Tools → Xygwin Shell.
3. Execute:
$ xmd -tcl genace.tcl -jprog -board ml300
-hw implementation/download.bit -elf bootrom_uncmp -ace top.ace
4. Connect the MicroDrive to the computer and copy the top.ace file into the
XILINX\myace directory if using the original ML300 CF image. Otherwise, copy the
top.ace file to the root directory of the CF card. Remove any other .ace or .sys files.
5. Remove the Microdrive from the CompactFlash writer and plug it into the System ACE CF
slot of the ML300. Set the System ACE CF dial to four.

Booting VxWorks
on the ML300

1. Connect a serial cable between the ML300 and the host computer.
2. Connect the Ethernet cross-over cable between the ML300 and the host computer.
3. Start HyperTerminal or any other terminal program and connect at 19200 bauds, 8 bits, no
parity, 1 stop bit, and no flow control.
4. Power the ML300 board. After a few seconds, the VxWorks boot loader appears in the
console window. Press a key to stop the automatic countdown.
5. Press p to display the boot parameters. Press c to change the default settings if needed.
The host computer IP address must be set to 192.168.0.1.
6. Start the Wind River FTP Server, WFTPD, on the host computer. Select Security →
User/rights… Add a new user called xemhost and set the Home Directory to the VxWorks
image directory. The VxWorks image is located inside the default directory where the
project location was specified in step 3 of “Compiling the BSP.” Click Done.
7. In the terminal window, press @ to load the VxWorks image through FTP.
8. After a few seconds, VxWorks boots and the Target Shell appears.
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