Executing the Reference Design in Hardware & XILINX.
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Figure 7: KC705 and TB-FMCH-3GSDI2A Boards

In these instructions, the numbers in parentheses correspond to the callout numbers in
Figure 7.

1.

10.
11.

Connect a USB cable from the host PC to the USB JTAG port (1). Ensure the appropriate
device drivers are installed.

Connect a second USB cable from the host PC to the USB UART port (2). Ensure that the
USB UART drivers described in Hardware Requirements, page 4, are installed.

Connect the TB-FMCH-3GSDI2A board to the HPC-FMC connector (3) of the KC705
board.

Connect an SFP+ Optical Transceiver to the SFP slot (4).
Connect a jumper to J4 (5) to enable SFP+ transmitter

Connect one end of the optical cable (6) to the SFP+ connector of the transmitter board,
the other end to the SFP+ connector of the receiver board.

Connect the CHO-TX, CH1-TX, and CH2 ports of the TB-FMCH-3GSDI2A board (7) on the
receiver KC705 board to the SDI video monitor.

Connect the CHO-RX, CH1-RX, and CH2 ports of the TB-FMCH-3GSDI2A board (8) on the
transmitter KC705 board to the SDI video generator.

Connect the KC705 board power connector (9) to a power supply.
Move the KC705 board power switch (10) to the ON position.

Ensure that the HW-KC705 board revision (11) is the same for both the TX and RX
platforms.
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Executing the Reference Design in Hardware & XILINX.

12. Start a terminal program (e.g., HyperTerminal) on the host PC with these settings:

Baud Rate: 115200
Data Bits: 8

Parity: None

Stop Bits: 1

Flow Control: None

Note: 10 Gb ETH PCS/PMA GTX transceiver P and N pins were swapped on board revisions before
v1.1 (e.g., v1.0 and C). This causes optical signal compatibility issues on standard equipment. This
issue is resolved by connecting TXPOLARITY and RXPOLARITY to Vg in the
ten_gig_eth_pcs_pma_v2_5_gtwizard_1l0gbaser_gt.vhd RTL file which inverts the GTX
transceiver TX and RX ports.

Executing the Reference System Using the Pre-built Bitstream and the
Compiled Software Application with the ISE iMPACT Tool

Follow these steps to execute the system using files in the appropriate ready_for_download
directory:

VoIP_TX: <unzip_dir>/kc705_smpte2022_56_3ch_tx/
VolP_RX: <unzip_dir>/kc705_smpte2022_56_3ch_rx/

Invoke the ISE iMPACT tool and configure the FPGA using the download.bit file in the
appropriate directory:

VoIP_TX: >cd <unzip_dir>/kc705_smpte2022_56_3ch_tx/ready_for_download

VoIP_RX: >cd <unzip_dir>/kc705_smpte2022_56_3ch_rx/ready_for_download

Note: The software application starts immediately after the completion of FPGA configuration. The
executable file (ELF) is embedded in the configuration file download.bit.
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Results from Running Hardware and Software & XILINX.

Results from V_SMPTE2022_56_TX UART Display
Runnmg The HyperTerminal screen of the V_SMPTE2022_56_TX reference design displays the output
Hardware and that is shown in Figure 8.
Software
/oINS
/N / Xilinx Inc.
\ \ \/ V_SMPTE2022_56_TX KC705 Reference Design
\ \ Created: November 15, 2012
/ / Copyright (c) 2012 Xilinx, Inc.
/___/ /\ All rights reserved.
AU VAR
AV VAN

VoIP TX Reset

VoIP TX Initializing...

IP Address: 192.168.0.100

MAC Address: 00-00-00-00-00-AA
Time Stamp: Disabled

IP Version: IPv4

VLAN: Disabled

VLAN Tag: 0xABCD

VoIP TX Initialization done

Initializing Channel 1
Channel Enabled
Dest IP Addr: 192.168.0.50

Source Port: 0x0010
Dest Port: 0x0010
SSRC: 0x12345600
FEC Size: 77x77

FEC: Ooff

Channel 1 Initialization Done

Initializing Channel 2
Channel Enabled
Dest IP Addr: 192.168.0.50

Source Port: 0x0020
Dest Port: 0x0020
SSRC: 0x12345610
FEC Size: 77x77

FEC: Ooff

Channel 2 Initialization Done

Initializing Channel 3
Channel Enabled
Dest IP Addr: 192.168.0.50

Source Port: 0x0030
Dest Port: 0x0030
SSRC: 0x12345620
FEC Size: 77x77

FEC: Ooff

Channel 3 Initialization Done

Select option

1 = Reset Core

2 = Initialize Core

3 = Configure Channel

4 = Probe Current Settings
g = exit
? = help

x896_08_021513

Figure 8: V_SMPTE2022_56_TX HyperTerminal Output
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Results from Running Hardware and Software & XILINX.

One of six options can be chosen from those displayed on the HyperTerminal screen:

1 = Reset core

2 = Initialize core (general space registers only)

3 = Configure channel (opens select channel submenu)

4 = Probe current settings (displays status of selected registers in general space)
q = Exit software application

? = Display current menu

Select the configure channel option by entering 3. One of four options can be chosen from the
resulting select channel display as shown in Figure 9:

1 = Channel 1
2 = Channel 2
3 = Channel 3

m = Main menu

Select Channel

1 = Channel 1
2 = Channel 2
3 = Channel 3
m = Main Menu

x896_09_021513

Figure 9: V_SMPTE2022_56_TX Select Channel HyperTerminal Output

After selecting any of the channels, the select option submenu is displayed as shown in
Figure 10.

Select Option

1 = Channel Init

2 = Channel Enable/Disable
3 = FEC On/Off

4 = Probe Status

m = Main Menu

c = Channel Select

x896_10_021513

Figure 10: V_SMPTE2022_56_TX Select Option HyperTerminal Output

One of six options can be chosen from those in the menu list:

1 = Channel init (configure target channel registers)
2 = Channel enable/disable

3 = FEC On/Off (toggle FEC engine)

4 = Probe status

m = Main menu

¢ = Channel select

XAPP896 (v1.0) March 7, 2013
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Results from Running Hardware and Software & XILINX.

V_SMPTE2022_56_RX UART Display

The HyperTerminal screen of the V_SMPTE2022_56_RX reference design displays the output
shown in Figure 11.

/ /\/ /

/N / Xilinx Inc.
\ \ \/ V_SMPTE2022_56_RX KC705 Reference Design
\ \ Created: November 15, 2012

/ / Copyright (c) 2012 Xilinx, Inc.

/___/ /\ All rights reserved.
\ ANV

AV VA WA

VoIP RX Reset

VoIP RX Initializing...

IP Address: 192.168.0.50

MAC Address: 00-00-00-00-00-BB
VoIP RX Initialization done

Initializing Channel 1
Channel Enabled
Host IP Addr: 192.168.0.100

Source Port: 0x0010
SSRC: 0x12345600
Buffer Size: 14000

Channel 1 Initialization Done

Initializing Channel 2
Channel Enabled
Host IP Addr: 192.168.0.100

Source Port: 0x0020
SSRC: 0x12345610
Buffer Size: 14000

Channel 2 Initialization Done

Initializing Channel 3
Channel Enabled
Host IP Addr: 192.168.0.100

Source Port: 0x0030
SSRC: 0x12345620
Buffer Size: 14000

Channel 3 Initialization Done

Select option

1 = Reset Core

2 = Initialize Core

3 = Configure Channel

4 = Probe Current Settings
g = exit

? = help

> X896_11_021513

Figure 11: V_SMPTE2022_56_RX HyperTerminal Output
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Results from Running Hardware and Software & XILINX.

One of six options can be chosen from those displayed on the HyperTerminal screen:
1 = Reset core
2 = Initialize core general space registers
3 = Configure channel (opens select channel submenu)
4 = Probe current settings (displays status of selected registers in general space)
q = Exit software application
? = Display current menu

Select the configure channel option by entering 3. One of four options can be chosen from the
resulting select channel display as shown in Figure 12:

1 = Channel 1
2 = Channel 2
3 = Channel 3

m = Main menu

Select Channel
1 = Channel 1
Channel 2
Channel 3
Main Menu

5 w N
non

X896_12_021513

Figure 12: V_SMPTE2022_56_RX Select Channel HyperTerminal Output

After selecting any of the channels, the select option submenu is displayed as shown in
Figure 13

Select Option

1 = Channel Init

2 = Channel Enable/Disable
3 = Probe Status

m = Main Menu

c = Channel Select

X896_13_021513

Figure 13: V_SMPTE2022_56_RX Select Option HyperTerminal Output

One of the five options can be chosen from those in the menu list:

1 = Channel init (configure target channel registers)
2 = Channel enable/disable

3 = Probe status

m = Main menu

¢ = Channel select
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Building Hardware & XILINX.

Building This section covers rebuilding the hardware design. Before rebuilding the project, ensure that
Hardware the licenses for the SMPTE 2022-5/6 video over IP transmitter and receiver cores, 10-Gigabit
Ethernet PCS/PMA, and 10-Gigabit Ethernet MAC are installed.

Generating the Programming File with the ISE Design Suite

1. Open the XISE project file with the ISE tools:
TX: <unzip dir>\kc705_smpte2022_56_3ch_tx\HW\VoIP_TX_10G_ISE\VoIP_TX_ISE.xise
RX: <unzip dir>\kc705_smpte2022_56_3ch_rx\HW\VoIP_TX_10G_ISE\VoIP_RX_ ISE.xise

2. Select Generate Programming File.

Compiling Software Using the SDK Tools

1. Click i_system_basic in the Hierarchy view of the ISE design suite.

2. Double click Export Hardware Design To SDK with Bitstream

3. Inthe workspace launcher, select the appropriate workspace:
TX: <unzip dir>\kc705_smpte2022_56_3ch_ tx\SW\SDK_workspace
RX: <unzip dir>\kc705_smpte2022_56_3ch_rx\SW\SDK_workspace
Click OK.

5. Import the board support package (BSP), hardware platform, and software applications
into the workspace by selecting File > Import > General > Existing Projects.

6. Click Next, then browse to the appropriate directory:
TX: <unzip dir>\kc705_smpte2022_56_3ch_tx\SW
RX: <unzip dir>\kc705_smpte2022_56_3ch_rx\SW

7. Click OK.
8. Ensure that all check boxes are selected.
9. Click Finish.

The BSP and software applications compile in this step. The process takes two to five minutes.
Existing software applications can now be modified and new software applications created with
the SDK tools.

Update Bitstream in XPS to include the ELF file
1. Open the appropriate XMP project file with the XPS tool:

TXZ<unﬂpdW>\kc705_smpte2022_56_3ch_tx\HW\TOP\peripheral\system_basic\

system_basic.xmp

RX: <unzip dir>\kc705_smpte2022_56_3ch_rx\HW\TOP\peripheral\system_basic\

system_basic.xmp

2. Add the ELF file from SDK_Workspace into the XPS tool project by selecting Project >
Select Elf File... and, in the Choose Implementation ELF file dialog, select the appropriate
ELF file:

'TXZ<unﬂpdW>\kc705_smpte2022_56_3ch_tx\SW\SDK_workspace\voip_tx\Debug\voip_tx.elf
R)(Z<unﬂpd">\kc7057smpte202275673chﬁrx\SW\SDKiworkspace\voipﬁrx\Debug\voipﬁrx.elf

3. Select Device Configuration > Update Bitstream to initialize the block RAM with a
bootloop program. This ensures that the processor boots with a stable program in memory.
The updated bitstream is placed in the appropriate directory:

TX: <unzip dir>\kc705_smpte2022_56_3ch_tx\HW\TOP\peripheral\system_basic\

implementation\download.bit
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Building Hardware

& XILINX.

RX: <unz ip dir>\kc705_smpte2022_56_3ch_rx\HW\TOP\peripheral\system basic\
implementation\download.bit

Running the Hardware and Software through SDK

1.

Open the JTAG configuration tool as shown in Figure 14 by selecting Xilinx Tools >
Configure JTAG Settings.

Select Digilent USB Cable in the type field.
Select Automatically Discover Devices on JTAG Chain

Note: Two workstations might be necessary, one for TX and another for RX when running from the
SDK tools since the debugger can only connect to a single Digilent USB cable at a time.

Click OK

Select Xilinx Tools > Program FPGA.

Note: Ensure bootloop is used for microblaze_0.

Click Program.

In the Project Explorer window, right click and select the appropriate function:
TX: voip_tx_main > Run As > Launch on Hardware

RX: voip_rx_main > Run As > Launch on Hardware

@ Configure JTAG Settings

Configure JTAG Settings

Specify the JTAG cable to use for comrmunication and JTAG Device Chain configuration of the target board.
These settings affect how XMD connects to the FPGA,

JTAG Cable
Type: | Digilent USE Cable -

Port:
Frequency:

Other Optians:

ITAG Device Chain
@ futomatically Discover Devices on JTAG Chain:
tanual Configuration of ITAG Chain

FPGA? Dewvice Marme 1D Code IR Length

'@,‘ [ Ok l | Cancel

X896_14_120712

Figure 14: JTAG Configuration Settings
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Design Characteristics & XILINX.

Design The reference design is implemented in a Kintex-7 FPGA (XC7K325T-2FFG900) using
Characteristics ISE Design Suite: System Edition 14.4. Resource utilization values are shown in Table 7 and
Table 8.

Table 7: Resources Used for V_SMPTE2022_56_TX Platform per Summary Report

ltem Resources Used
LUTs 46,786 out of 203,800 (22%)
1/0s 163 out of 500 (32%)
RAMB36E1s 91 out of 445 (21%)
RAMB18E1s 13 out of 890 (1%)

Table 8: Resources Used for V_SMPTE2022_56_RX Platform per Summary Report

ltem Resources Used
LUTs 45,752 out of 150,720 (23%)
I/Os 163 out of 500 (32%)
RAMB36E1s 107 out of 445 (24%)
RAMB18E1s 15 out of 890 (1%)

Note: Device resource utilization results depend on the implementation tool versions. Exact results can
vary. These values should be used as a guideline.

Reference The reference design check list is shown in Table 9. The reference design files for this
Design application note can be downloaded from:

http://www.xilinx.com/member/smpte2022/index.htm

Table 9: Reference Design Check List

Parameter Description
General
Developer names Gilbert Magnaye, Josh Poh, Myo Tun Aung, Tom Sun
Target devices Kintex-7 FPGA
Source code provided Yes
Source code format VHDL (some sources encrypted)

Design uses code/IP from existing Xilinx application note/reference | Cores generated from EDK and from Core Generator tool
designs, CORE Generator software, or third party

Simulation

Functional simulation performed N/A
Timing simulation performed N/A
Test bench used for functional and timing simulations N/A
Test bench format N/A
Simulator software/version used N/A
SPICE/IBIS simulations N/A

Implementation

Synthesis software tools/version used XST 14.4
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Table 9: Reference Design Check List (Contd)

Parameter

Description

Implementation software tools/versions used

ISE Design Suite 14.4; System Edition

Static timing analysis performed

Yes (Passing timing in PAR/TRCE)

Hardware Verification

Hardware verified

Yes

Hardware platform used for verification

Kintex-7 FPGA KC705 Evaluation Kit

Table 10 and Table 11 are extracted from the module utilization report of the design summary
from the ISE design suite.

Table 10: V_SMPTE2022_56_TX Device Utilization

Module Name Slices Rezlii:t?ers LUTs | LUTRAM ?R:EI(\:I;I; DSP48E1| BUFG BUFIO BUFR
VolP_Framework_TX_IOB 1 0 1 0 0 0 1 0 0
LMHO0387ctrl 38 84 106 24 1 0 0 0 0
Si5324CTRL 50 101 119 24 2 0 0 0 0
Video Over IP 13052 | 28375 |27238 767 69 0 8 0 0
-i_kc705_sdi_wrapper 0 0 0 0 0 0 3 0 0
>>SDI_GTX 0 0 0 0 0 0 0 0 0
>>gen_sdi_rxtx[0].SDI_RXTX_i 679 1007 1660 13 1 0 0 0 0
>>gen_sdi_rxtx[1].SDI_RXTX_i 670 986 1656 8 1 0 0 0 0
>>gen_sdi_rxtx[2].SDI_RXTX_i 695 993 1663 8 1 0 0 0 0
-i_v_smpte2022_56_tx 7829 18665 | 15398 151 66 0 1 0 0
-ten_gig_block 29 150 21 0 0 0 0 0 0
>>GEN_10BASER.i_10baseR_pcs_pma| 1334 2839 3007 210 0 0 4 0 0
>>xgmac_block 1798 3654 3780 377 0 0 0 0 0
VolP_Framework_TX_IOB 2 0 3 0 0 0 0 0 0
system_basic 10508 | 23630 | 19319 | 2611 32 3 3 0 0
-RS232_Uart_1 65 81 88 18 0 0 0 0 0
-axi4lite_0 177 89 190 0 0 0 0 0 0
-axi_7series_ddrx_0 8048 17389 | 15022 | 2411 0 0 0 0 0
-axi_interconnect_0 1219 4920 2477 6 0 0 0 0 0
-axilite_bridge 6 0 10 0 0 0 0 0 0
-clock_generator 1 0 1 0 0 0 2 0 0
-debug_module 85 128 131 23 0 0 1 0 0
-microblaze 876 982 1372 151 0 3 0 0 0
-microblaze_bram_block 0 0 0 0 32 0 0 0 0
-microblaze_d_bram_ctrl 6 2 4 0 0 0 0 0 0
-microblaze_dimb 1 1 0 0 0 0 0 0 0
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Table 10: V_SMPTE2022_56_TX Device Utilization (Contd)

Module Name Slices Rezlii:t?ers LUTs | LUTRAM ?R:EI(\ZI? DSP48E1| BUFG BUFIO BUFR
-microblaze_i_bram_ctrl 4 2 2 0 0 0 0 0 0
-microblaze_ilmb 1 1 0 0 0 0 0 0 0
-proc_sys_reset 19 35 22 2 0 0 0 0 0

Total 23651 | 52190 |46786| 3426 104 3 12 0 0
Table 11: V_SMPTE2022_56_RX Device Utilization
. Slice Block
Module Name Slices Registers LUTs [LUTRAM I:i:ﬁzl\gl DSP48E1| BUFG  BUFIO | BUFR
VolP_Framework_RX_IOB 9 13 28 0 0 0 1 0 0
LMHO0387ctrl 43 81 106 24 1 0 0 0 0
Si5324CTRL 48 99 119 24 2 0 0 0 0
VolP_Framework_RX_IOB 2 0 3 0 0 0 0 0 0
i_VolP_Framework_RX 12781 29670 | 25522 1099 87 0 8 0 0
-gen_clock_recovery[0].i_clock_recovery 307 665 809 49 0 0 0 0 0
-gen_clock_recovery[1].i_clock_recovery 315 665 798 49 0 0 0 0 0
-gen_clock_recovery[2].i_clock_recovery 303 665 825 49 0 0 0 0 0
-i_kc705_sdi_wrapper 2 1 2 1 0 0 3 0 0
>>SDI_GTX 0 0 0 0 0 0 0 0 0
>>gen_sdi_rxtx[0].SDI_RXTX_i 349 966 784 5 0 0 0 0 0
>>gen_sdi_rxtx[1].SDI_RXTX_i 344 947 755 4 0 0 0 0 0
>>gen_sdi_rxtx[2].SDI_RXTX_i 346 964 779 5 0 0 0 0 0
-v_smpte2022_56_rx_v2_1 7743 18228 | 14166 311 87 0 1 0 0
-ten_gig_block 28 150 29 0 0 0 0 0 0
>>GEN_10BASER.i_10baseR_pcs_pma | 1334 2829 2970 210 0 4 0 0
>>xgmac_block 1683 3508 3549 416 0 0 0 0 0
system_basic 10734 | 24988 | 19974 | 2611 32 3 3 0 0
-RS232_Uart_1 57 81 95 18 0 0 0 0 0
-axi4lite_0 166 89 192 0 0 0 0 0 0
-axi_7series_ddrx_0 8079 17419 | 15051 2411 0 0 0 0 0
-axi_interconnect_0 1433 6248 3071 6 0 0 0 0 0
-axilite_bridge 7 0 10 0 0 0 0 0 0
-clock_generator 1 0 1 0 0 0 2 0 0
-debug_module 98 128 118 23 0 0 1 0 0
-microblaze 863 982 1408 151 0 3 0 0 0
-microblaze_bram_block 0 0 0 0 32 0 0 0 0
-microblaze_d_bram_ctrl 5 2 4 0 0 0 0 0 0
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Table 11: V_SMPTE2022_56_RX Device Utilization (Cont'd)

Module Name Slices Rezlii:tirs LUTs [LUTRAM ?R:If(l\):l‘\:(li; DSP48E1| BUFG |BUFIO | BUFR
-microblaze_dimb 1 1 0 0 0 0 0 0 0
-microblaze_i_bram_ctrl 3 2 2 0 0 0 0 0 0
-microblaze_ilmb 1 1 0 0 0 0 0 0 0
-proc_sys_reset 20 35 22 2 0 0 0 0 0

Total 23617 | 54851 45752 3758 122 3 12 0 0
Conclusion This application note describes a Video over IP network system using various Xilinx IP cores.
The Reference Design demonstrates the ability of the SMPTE 2022-5/6 video over IP cores to
encapsulate and de-encapsulate multiple SDI streams and transport them through a 10 Gb/s
Ethernet pipe. The utilization of the Ethernet bandwidth is over 90% with three 3G-SDI video
streams. The Reference Design can perform recovery of a limited number of Ethernet packets
when impairment is introduced into the network with the forward error correction engine turned
on.
References This application note uses these references:
1. Kintex-7 FPGA KC705 Evaluation Kit :
www.xilinx.com/products/boards-and-kits/EK-K7-KC705-G.htm
2. Inrevium TB-FMCH-3GSDI2A,
solutions.inrevium.com/products/fmc/serial_connectivity/index.html
3. PGO032, LogiCORE IP SMPTE 2022-5/6 Video over IP Transmitter v2.1 Product Guide
4. XAPP589, All Digital VCXO Replacement for Gigabit Transceiver Applications Application
Note
5. PGO033, LogiCORE IP SMPTE 2022-5/6 Video over IP Receiver v2.1 Product Guide
6. PGO071, LogiCORE IP SMPTE SD/HD/3G-SDI v1.0 Product Guide
7. PGO072, LogiCORE IP 10-Gigabit Ethernet MAC v11.4 Product Guide
8. PGO068, LogiCORE 10-Gigabit Ethernet PCS/PMA v2.5 Product Guide
9. UG761, AXI Reference Guide
10. UG586, 7 Series FPGAs Memory Interface Solutions User Guide
11. AMBA AXI4 specifications,
infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.set.amba/index.html
12. UG683, EDK Concepts, Tools, and Techniques: A Hands-On Guide to Effective Embedded
System Design (v14.4)
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Notice of
Disclaimer

The information disclosed to you hereunder (the “Materials”) is provided solely for the selection and use of
Xilinx products. To the maximum extent permitted by applicable law: (1) Materials are made available "AS
IS" and with all faults, Xilinx hereby DISCLAIMS ALL WARRANTIES AND CONDITIONS, EXPRESS,
IMPLIED, OR STATUTORY, INCLUDING BUT NOT LIMITED TO WARRANTIES OF
MERCHANTABILITY, NON-INFRINGEMENT, OR FITNESS FOR ANY PARTICULAR PURPOSE; and (2)
Xilinx shall not be liable (whether in contract or tort, including negligence, or under any other theory of
liability) for any loss or damage of any kind or nature related to, arising under, or in connection with, the
Materials (including your use of the Materials), including for any direct, indirect, special, incidental, or
consequential loss or damage (including loss of data, profits, goodwill, or any type of loss or damage
suffered as a result of any action brought by a third party) even if such damage or loss was reasonably
foreseeable or Xilinx had been advised of the possibility of the same. Xilinx assumes no obligation to
correct any errors contained in the Materials or to notify you of updates to the Materials or to product
specifications. You may not reproduce, modify, distribute, or publicly display the Materials without prior
written consent. Certain products are subject to the terms and conditions of the Limited Warranties which
can be viewed at http://www.xilinx.com/warranty.htm; IP cores may be subject to warranty and support
terms contained in a license issued to you by Xilinx. Xilinx products are not designed or intended to be
fail-safe or for use in any application requiring fail-safe performance; you assume sole risk and liability for
use of Xilinx products in Critical Applications: http://www.xilinx.com/warranty.htm#critapps.

Automotive Applications Disclaimer

XILINX PRODUCTS ARE NOT DESIGNED OR INTENDED TO BE FAIL-SAFE, OR FOR USE IN ANY
APPLICATION REQUIRING FAIL-SAFE PERFORMANCE, SUCH AS APPLICATIONS RELATED TO: (1)
THE DEPLOYMENT OF AIRBAGS, (Il) CONTROL OF A VEHICLE, UNLESS THERE IS A FAIL-SAFE
OR REDUNDANCY FEATURE (WHICH DOES NOT INCLUDE USE OF SOFTWARE IN THE XILINX
DEVICE TO IMPLEMENT THE REDUNDANCY) AND A WARNING SIGNAL UPON FAILURE TO THE
OPERATOR, OR (lll) USES THAT COULD LEAD TO DEATH OR PERSONAL INJURY. CUSTOMER
ASSUMES THE SOLE RISK AND LIABILITY OF ANY USE OF XILINX PRODUCTS IN SUCH
APPLICATIONS.
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