AR# 69916

2017.3 インストール - ダウンロードしたファイルを再利用して、SoCs / Zynq-7000 のみを選択した状態で別のコンピューターにインストールしようとすると「デバイスを最低 1 つ選択する必要がある」というメッセージが表示され、インストールできない

説明

「Download & Install」オプションを使用して、ウェブインストーラーを実行し、SoC デバイスのみを含む WebPACK をインストールしました。

同じインストールのダウンロード ファイルを使用して、同じコンフィギュレーションを別のコンピューターにインストールしようとしました。最初に使用したインストールのダウンロード ファイルから xsetup を実行しました。

デバイスを選択するページに来ると、Vivado インストーラーの GUI がそれ以上先に進まなくなります。「At least one device must be selected」というメッセージが表示されます。

デバイスを選択するウィンドウには、Zynq-7000 が選択されていて、一部の SoC が選択されていますが、プロダクション デバイスは選択されていないようです。

初回インストールで追加デバイスを選択すると、この問題は発生しません。しかし、余分なデバイスをインストールしてディスク容量を無駄にしたくはありません。

ソリューション

この問題を回避するには、2 つの方法があります。

  • 「Download only」のオプションを使用してファイルをダウンロードし、別のコンピューターにインストールします。
  • バッチ インストーラーを使用します。コマンド例は次のようになります。
C:\intall1\downloads\Vivado_2017.3\bin\xsetup.bat -a "XilinxEULA,3rdPartyEULA,WebTalkTerms" -b Install -e Vivado HL WebPACK" -l H:\eda\install2
AR# 69916
日付 10/06/2017
ステータス アクティブ
種類 一般
ツール